Results 1 to 10 of 10

Thread: Laplink Gold 12.0

  1. #1
    denverdude Guest

    Default Laplink Gold 12.0

    I haven't been able to remote controlany computers with Laplink Gold 12.0 since I switched my computer and the target computers from Norton Internet Security to Zone Alarm.Before I post a bunch of diagnostics and stuff, I thought I would ask--is anyonesuccessfully using Laplink Gold 12.0 with Zone Alarm?

  2. #2
    denverdude Guest

    Default Re: Laplink Gold 12.0

    I requested technical support from Laplink (the company). Unfortunately, even Laplink (the company) couldn't get Laplink (the product) to work with the most current version of Zone Alarm (6.1.737.000 at the time of this writing). Laplink was able to work with previous versions of ZA, so Laplink (the company) feels there must be something new (or wrong) with the current version of ZA (6.x).With Laplink andZA installed on both the host and guest computers,here are the symptoms:- Laplink works fine as long asZA is shut down on the *host* computer. In other words, the ZA instance on the *guest* computer doesn't seem to be causing the problem. The problem seems to be caused by ZA on the *host* computer.-When ZA is running on the host computer, Laplink will connect and authenticate just fine, but once the remote control session is under way, Laplink seems to lock-up on the guest computer as soon as the guest tries todo something on the host computer that necessitatesa re-draw of theremote control window. For example, if the guest simply clicks on the host's 'Start' button, the guest's instance of Laplink seems to lock-up after about half of the Start menu is rendered. (AlthoughLaplink may not be actually "locked up" may be waiting indefinitely for data that's probably being erroneously firewalled by ZA on the host computer.)Here is what we did for our tests:- Limited test to a guest and host computer on the same LAN (to elimate variables potentially introduced by routing/NAT/etc.) So the two computers were on the same LAN subnet, both logically and physically.- Added the IP address of each computer to the other computer's respective 'Trusted Zone' in ZA.- Set the trust level to 'Super' and set all 'Access' and 'Server' options to 'Allow' (green checkmark) for the following Laplink components:1) laplink.exe2) wproxy.exe3) tsircsrv.exe4) tsircusr.exe-Just in case, created an 'Expert Rule' for each of the above executables and set all options to "Any" and "Allow".- Just in case, also enabled (checked) 'This program may use other programs...' and 'Allow Application Interaction' for each of the above executables.- Configured the executables as mentioned above on *both* the host and guest computers....While this configuration would seem to give Laplink full reign to the "Zone Alarmed" computers, it doesn't.

  3. #3
    billc Guest

    Default Re: Laplink Gold 12.0

    This one might need the guidance of the technicians at Zone Labs. Contact Zone Labs here .

  4. #4
    mcz Guest

    Default Re: Laplink Gold 12.0

    Hey DenverDude,Did you happen to get in touch with tech support about this problem and learn anything useful? I haven't tried as exhaustively as you to try and give every possible permission to LapLink, but I have the same problem with LapLink v 11.5 and I have tried many of the things you mention.

  5. #5
    denverdude Guest

    Default Re: Laplink Gold 12.0

    Sorry for the delay...I dislocated my elbow while playing hockey the day before your post. I'm just now able to type with both hands again...No, I haven't reported this problem to Zone Labs yet, but I will today, and I will update this thread as soon as Zone Labs gets back with me.

  6. #6
    mcz Guest

    Default Re: Laplink Gold 12.0

    Hey DenverDude.
    How's that shoulder?
    Have you heard anything back
    on this issue in the past 3 weeks?

  7. #7
    denverdude Guest

    Default Re: Laplink Gold 12.0

    It's actually my elbow, which is healing nicely.
    I got really lucky as far as elbow dislocations go...minimal damage requiring no surgery...whew!
    Yes, I'm actually working with Zone Labs right now on this problem (i.e., we are trading e-mails).
    Zone Labs had me try one really good diagnostic--disable 'Program Control' on both the host and guest computers.
    Note that we really didn't need to do this on the guest computer because we already know the host computer is the culprit.
    We still
    did it "just in case" certainly couldn't hurt!
    Zone Labs stated that the computers should be
    rebooted after changing this setting.
    I rebooted and tested Laplink, but unfortunately the problem persists.
    This diagnostic eliminated any ZA program-specific settings as being suspect.
    We now know the problem is more fundamentally related to the "TrueVector" service that marshals all IP traffic on a computer running ZA.
    Zone Labs then had me "reset" my ZA installation by deleting its configuration files (.RDB and .LDB).
    This is easily done
    in Safe Mode, where ZA doesn't fire up.
    Unless you don't mind losing your current configuration, make sure you backup your ZA configuration via the ZA 'Overview...Preferences...' menu.
    Unfortunately, resetting ZA--followed by disabling Program Control again--didn't do the trick either.
    This is where we are right now.
    I am now waiting for Zone Labs' next communication.

  8. #8
    denverdude Guest

    Default Re: Laplink Gold 12.0

    Unfortunately, after battling with this issue for seven
    (7) months, I'm throwing in the towel.
    I attempted to work with both Zone Labs and Laplink (the company) to get resolution.
    Both companies put forth a little effort in the form of technical support...but only a little.
    I will acknowledge that Zone Labs put forth a little more effort than Laplink, although Laplink was pretty
    honest and told me that its software engineers do not have the bandwidth to work on an issue like this.
    We all know it's a matter of corporate priorities and economics.
    In the end, ZoneAlarm is incompatible with Laplink Gold (I'm using Laplink Gold version 12.01).
    So if you are doing some pre-sales research and you found this post,
    DO NOT
    buy Laplink as a remote control solution if you are a die-hard ZoneAlarm user, or if you don't want to disable ZoneAlarm
    for a Laplink remote control session.
    (You only need to disable ZoneAlarm on the Laplink host, which of course makes the host
    a bit more vulnerable
    the remote control session.)
    This is really unfortunate because Laplink is the only remote control solution--that I'm aware of--that can work when both the guest and the host computers are each behind separate NAT routers.
    (To solve this problem, Laplink uses a intermediary, or relay server on the public Internet...a solution which works long as ZoneAlarm is not running on the Laplink host!)

  9. #9
    denverdude Guest

    Default Re: Laplink Gold 12.0

    Side note:
    I just did a little research, and I see that Symantec has finally addressed the "NAT-to-NAT" issue too.
    However, Symantec is doing this with a supplemental product called "pcAnywhere Access Server".
    In my humble opinion, the overall Symantec pcAnywhere solution is way too expensive
    for consumer end-users.
    I also see that UltraVNC supports NAT-to-NAT now.
    Given my quick research, I would guess that most
    players in the remote control marketspace have finally caught on...and I'll probably be switching away from Laplink Gold.

  10. #10
    waldtest Guest

    Default Re: Laplink Gold 12.0

    Well, that's disappointing about the incompatibility of ZA 6 and Laplink. I've been lurking hoping for a positive result.

    Laplink is compatible with ZoneAlarm 5.05.094 and perhaps other, later makes of version 5. I've been sticking with that combination so I can continue to use laplink.

    Can anyone comment on:
    1) What precisely I'm giving up in security by not using version 6 of ZoneAlarm.
    2) What the last make of version 5 of ZoneAlarm is, and where/whether it's availble on the web.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts