Results 1 to 4 of 4

Thread: wireless network doesn't allow internet connection through host computer thu zone alarm

  1. #1
    redrufus Guest

    Default wireless network doesn't allow internet connection through host computer thu zone alarm

    hi folks! here's a puzzle...i have been using zone alarm for ages...now, since installing 6.5.737.000 my host computer wont allow my wireless network internet access until i shut down zone alarm (i then enable windows fire wall - something is better than nothing!). all my other machines are zone alarm enabled, and all network settings are for trusted zone (internet is internet). i
    also have some dificulty with network neighbourhood finding the network from the host (software access point). again, with zone alarm running on the rest, if i shut it down on my host, the network is available. once closed, the wireless network operates without any let or hinderance. i have re-installed zone alarm, wireless network and re-run the network setup wizard. a few times! and i still have the same problem. all machines run xp - host is pro, 2 laptops using xp home and a dual boot machine running win98 and xp pro. i've scratched my head so much, i've now got a bald patch anybody got any ideas? i run sbybot and avg antivirus (no probs with either) each time i shut zone alarm down - sad or what??thanks all!

    Operating System:
    Windows XP Pro
    Product Name:
    ZoneAlarm (Free)
    Software Version:
    6.5

    23 jan 07.

    update to the above!

    i think i may have solved this darn situation! in Zone Alarm under program control, programs tab,
    is a listing for "Generic Host Process for Win32 Services". This is checked under Access for Trusted and Internet. I checked this under the Server column on Trusted. No difference, so i tried checking under the Internet column. A warning box flashed up, warning that allowing this process access to the internet could cause problems - internet connection and so forth. I checked on "Ask". Then, i tried updating my laptop's AVG anti-virus (this has been the main cause of my concern) - up flashed the notification box on my main desktop (host) asking for authority for the "Generic Host Process for Win32 Services" to connect to the internet, i cecked OK, and hay presto! my laptop connected to the internet through Zone Alarm - and i could fire up IE7 and Outlook Express too! in fact, as i write this, my laptop is downloading microsoft updates (something i had to shut zone alarm down on the host to do!) Zone Alarm is now running perfectly on all 4 computers, with full internet access for all!

    I can't say that this work around will work for everybody, and the warning message should be observed. It worked for me, but it is up to you whether you risk altering the settings in the server column. thanks to all for advice freely given. i tried as much as i could, but found i still had to close ZA. Now i dont!


    Message Edited by redrufus on 01-23-200702:25 PM

    Operating System:Windows XP Pro
    Product Name:ZoneAlarm (Free)
    Software Version:6.5

  2. #2
    massimouno Guest

    Default Re: wireless network doesn't allow internet connection through host computer thu zone alarm

    I had a similar problem. If I left my PC unattended for a long period (in hours), the connection would stop a the wireless router. AD-HOC, a guru here, gave me some help which worked for a time, but now, the same problem has re-occurred and I don't know why. So now, I have to exit ZoneAlarm, then re-open it, and things go well. That isn't a solution, obviously.

    Here is what I was told to do, so maybe it will work for you. You have to add your the DHS and DCHP servers IP addresses (internal to your wireless router) to ZA's trusted zone. It's quite easy.

    1) Use 'Start/Run' and type CMD. Press OK. At DOS prompt type: IPCONFIG /ALL (note the space for the slash). A list will be displayed.
    2) Take note of the IP's of DHCP server and the DNS servers (can be more then one).
    3) Then in Zone Alarm, go to tab firewall zones and in the box at the bottom click on ADD. Choose IP address and enter the IP's you found, a brief description, and ensure the zone is set to trusted. You need to this one by one for DHCP and DNS servers.

    Meanwhile, if anyone knows why I am having this problem again after it went away, please don't hestitate to let me know how to fix it. My Internet Zone Security and Trusted Zone Security are both set to HIGH. My Blocked Zone uses the default settings.

  3. #3
    Join Date
    Dec 2002
    Location
    Mikado Michigan
    Posts
    2,596

    Default Re: wireless network doesn't allow internet connection through host computer thu zone alarm

    Is your DHCP server still in the trusted zone? Trusted Zone on medium? Also open un the firewall section click the advanced button, and see what they wireless setting is at the bottom. If its turned on, and you have a corrupted DB then when you reboot, it might put it into the internet Zone.
    My homes are SpywareHammer.com and DonHoover.net and BleepingComputer.com


    Consumer Security - 2011 & 2012

    Tilting at windmills hurts you more than the windmills.
    -From the Notebooks of Lazarus Long
    Senior of the Howard Families

  4. #4
    massimouno Guest

    Default Re: wireless network doesn't allow internet connection through host computer thu zone alarm

    The DHCP server IS in the trusted zone. The trusted zone is set to HIGH. Should it be MEDIUM?

    Under Advanced settings, I assume you mean the last section, Network Settings. This is selected:
    + Ask which Zone to place new networks in upon detection
    + Automatically put unprotected networks (WEP or WPA) in the Internet Zone.

    Generally I don't use the wireless part, I normally use a cable into the router.

    What DB could be corrupted? Is that part of Zone Alarm? I am also not sure why you refer to re-booting. The problem occurs when I leave the computer on and go way for a few hours. When I come back, the router is blocked. In fact, I tried rebooting the computer a few times when this happened and it does not fix the problem, as when I leave the computer unattended for hours (as above), it reoccurs. So, at this point, I can either reboot the computer each time the router is blocked OR I turn ZA off, then turn it on again (faster and simpler).

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •