Results 1 to 2 of 2

Thread: How did this get pasty my fiewall?

  1. #1
    crunhy Guest

    Default How did this get pasty my fiewall?

    I pplay poker online and probably get over concerned about security. Today when i clicked on my poker icon I got a message to wait for an update to finish downloading. This was without me giving permission for poker.exe to connect. I hate this, the reason i got this firewall was so that NOTHING could pass into or out of my computer without aking permission I am happy getting alerts. How did this happen?
    I find that the generic service provider automatically connects to the internet at startup, how can I stop this. I get frequent requests from Svchost for internet access. Can I safely deny access, how can i tell why Svchost wants access.
    I have bought a new laptop to use only for poker but I don't want to start using it until I have got to grips with my firewall. I want to configure it so that internet connection only happens when I initiate it and nothing ever updates unless I initiate it.. Any advice would be much appreciated.

    Operating System:Windows XP Home Edition
    Software Version:
    Product Name:ZoneAlarm (Free)

  2. #2
    Join Date
    Dec 2005

    Default Re: How did this get pasty my fiewall?

    You have to determine if the poker software application has a seperate updater (that would require a seperate connection) or if the poker software has the updater built inside of itself. If the poker software has the updater built within itself and has been previously allowed internet/networking connections, then you hae infact allowed it's internet connections. You should in this case set the poker software to ask for internet access (and any internet servers) and never always allow this connection in the ZA alerts.
    This way you are always in control and not letting the ZA continue with your previous decisions.

    Laptops and svchost can be tricky. Every new local are network or access point you connect the laptop to will always need the svchost.exe to connect and get connections from the always changing dhcp and dns servers as you travel from lan to lan.
    Desktops are more easily tamed.
    At the very least the svchost.exe will always need outgoing and incoming connections between itself and the dhcp (remote port 67 by udp) and dns server (remote port 53 by udp) and of course the time updater for windows (remote port 123 by udp).

    Svchost.exe can be tamed to stay at home if the laptop is always using the same assigned IP (as assigned by the gateway or dhcp router) and is always using the same dhcp server (that has always a constant or never changing IP) and the dns servers are never changed.
    It is then and only then can the dns client service and the dhcp client service can be disabled. Once the dns and dhcp client services are disabled, the supported applications will be forced to do their own domain name lookups, thus reducing the svchost.exe dns connections.
    Furthermore, the svchost is usually involved with the UPnP and SSDP and broadcast to the lan for discovering and connection to other networked devices on your local area network.
    These connections can be eliminated or reduced by disabling the UPnP and SSDP services along with the Net. TCP port sharing service (used inconjunction with netbios). This will of course stop any connections to any devices on the local area network. such as networked printer/scanners, nas, game boxes, media sharing, etc.
    This can be further completed by disabling the netBIOs in the properties of the network adapter(s).
    But this is ideally suited for a desktop not a laptop and for a desktop that has been specifically configured for optimal use and for controlled connections on a local area network with specific configurations.

    Best regards.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts