Zone Alarm Pro has a global setting that will block all Internet or local servers, regardless of program permissions. Make sure this setting isn't causing the problem by following these steps:

1. Go to the Main tab of the Firewall panel

2. Click the Advanced button. This opens the Advanced settings dialog box

3. In the dialog box, locate the General section

4. Confirm that Block local servers and Block Internet servers are not checked.

After completing the steps above, try connecting to the Internet again. If you can't, the next step is to make sure Zone Alarm Pro isn't blocking your ISP's servers.

Thank you for your time and have a Great Day or Evening!

SlyFox