Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: How to allow localhost cookies to reach browser

  1. #1
    qop Guest

    Default How to allow localhost cookies to reach browser

    Hello,I recently upgraded from ZoneAlarm to ZoneAlarmPro 5.1.033.000 (on Windows 2000) to get the cookie control capability. In my setup, I've added localhost to the Privacy Site List to allow all cookies. But ZAP still refused to let cookies set by localhost to pass through to the web browser. I tried adding localhost to the trusted zone, but that didn't help.The only way for ZAP to let the localhost cookies pass through to the browser was to use ZAP's Program Control to turn off the "Enable Privacy for this program" for the browser. But that defeats the purpose of having ZAP.Could someone please help?Thanks.QOP


    Operating System:Windows 2000 Pro
    Product Name:ZoneAlarm Pro
    Software Version:5.1

  2. #2
    muffincharizard Guest

    Default Re: How to allow localhost cookies to reach browser

    Try removing localhost from the list completely.

  3. #3
    qop Guest

    Default Re: How to allow localhost cookies to reach browser



    I did try that.

    In fact, initially I did not have any entry for localhost. But I discovered that ZAP was blocking localhost's cookies. Thus, I added an entry to the Privacy Site List to allow all cookies. But ZAP still blocked localhost's cookies.


    QOP

  4. #4
    qop Guest

    Default Re: How to allow localhost cookies to reach browser



    All of the checkboxes are NOT checked.

    As I fiddled more with ZAP, I noticed that ZAP also blocked localhost's client-side cookies. Localhost's client-side cookies remained visible to localhost's client-side javascript. But ZAP blocked those cookies from reaching localhost.

    Muffincharizard suggested in another thread that to have ZAP blocks client-side cookies, one has to disable client-side javascript. Thus, it was strange to see that ZAP blocked localhost's client-side cookies without having to disable javascript.

    How can I get ZAP to block other site's client-side cookies the way it blocks localhost's client-side cookies?

    Why is ZAP acting so strange regarding localhost?

    I have used ZoneAlarm for a long time and have been impressed by what it does. But my experience with ZoneAlarm Pro has been a shock. It looks as if ZAP is a completely different product with much inferior workmanship.

    What a shame to ZoneLabs.

    QOP

  5. #5
    goddog Guest

    Default Re: How to allow localhost cookies to reach browser

    Hi, qop, I was just wondering if you had stumbled on a solution to this localhost-cookie problem, since I'm having the same proplem. Obviously I've tried all the suggestions I've stumbled on in my search, but no luck so far.

  6. #6
    Join Date
    Dec 2002
    Location
    Mikado Michigan
    Posts
    2,591

    Default Re: How to allow localhost cookies to reach browser

    Have you tried turning on the privacy advisor? If not there is a page on my site that will show you how.
    My homes are SpywareHammer.com and DonHoover.net and BleepingComputer.com


    Consumer Security - 2011 & 2012

    Tilting at windmills hurts you more than the windmills.
    -From the Notebooks of Lazarus Long
    Senior of the Howard Families

  7. #7
    pqbiker Guest

    Default Re: How to allow localhost cookies to reach browser

    I had the problem during website development with PHP session variables, which require the browser to accept cookies, after I upgraded to ZoneAlarm version 5.5 on Windows 2000 workstation. I stayed with ZoneAlarm version 4.5 for a long time because upgrades always brought problems.

    As mentioned here, I enabled alerts so I could figure out what was happening.

    One method (which was mentioned) is to disable privacy for your browser program.
    Got to Program Control, Programs, left click on your browser program, select Options (lower right on screen), and uncheck "Enable Privacy for this Program". As stated, this method is a little self defeating.

    Another method, that works for me, is using the IP address of the localhost instead of http://localhost for the URL. I have a cable modem router with firewall so the URL for my workstation is http://192.168.0.2/. I haven't had any problems with this solution, even with browser privacy enabled.

  8. #8
    asyadiqin Guest

    Default Re: How to allow localhost cookies to reach browser

    I had the same problem. I am running Apache webserver and was developing a site using php_session. Everytime, I login, Zone Alarm Privacy Advisor will come up and say that it have blocked a cookie. But no other details was given and the site was not listed in the Privacy Site List.I only found out that it only happens when I use localhost in the browser's url, eg. http://localhost/mysite/ . However, using my IP, eg. http://192.168.0.2/mysite/ will not have that problem.Anyone found out how I can overide this block in Zone Alarm?Thanks.

  9. #9
    cme Guest

    Default Re: How to allow localhost cookies to reach browser

    I just updated ZA and now have the same problem, does anyone have a solution?

    Thank you,
    Christie

  10. #10
    cme Guest

    Default Re: How to allow localhost cookies to reach browser

    So far, with Cookies on Medium and Ad Blocking on High, I am able to use 127.0.0.1 instead of localhost.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •