Results 1 to 7 of 7

Thread: Global Mobile Code Setting reverts to 'Off'

  1. #1
    balders Guest

    Default Global Mobile Code Setting reverts to 'Off'

    Hi thereI have had occurrences of the Global Mobile Code Setting reverting to 'Off' after a reboot, prior to which I had set it to 'On'. Is this normal behaviour or a possible bug. I want Mobile Code to be set to 'On' permanently and then to tailor specific site on an individual basis.Any help that can be provided will be greatly appreciated.Best regardsBalders

    Operating System:Windows XP Home Edition
    Product Name:ZoneAlarm Internet Security Suite
    Software Version:6.0

  2. #2
    billc Guest

    Default Re: Global Mobile Code Setting reverts to 'Off'

    That is not normal behavior. It should remain as you last set it upon reboot. Try this. Turn it on, then right click on the ZA icon in your system tray, and select 'shutdown Zone Alarm Pro. Wait about a minute, then start ZAP again from your 'All Programs menu or shortcut. Did it 'remember' it should be on? If it did, then it should also remember upon reboot. If not, then you'll need to reset your database. Reset the database this way; you will lose your customizations and will need to reconfigure Zone Alarm.

    1. Boot your computer into the Safe Mode. {Instructions if needed}
    2. Navigate to the c:\windows\internet logs folder.
    3. Delete the backup.rdb and iamdb.rdb files in the folder.
    4.Reboot into the normal mode.

  3. #3
    balders Guest

    Default Re: Global Mobile Code Setting reverts to 'Off'

    Hi Bill

    Many thanks for your prompt response. The 'set Mobile Code on, shut down ZASS, wait a minute, restart ZASS' approach appears to have worked. The Mobile Code setting remained at On after the restart of ZASS. I then rebooted a couple of times and so far the setting has remained on reather then being Off after reboot. I will check this again a few times but your tip seems to have worked......why I do not know. So thanks again.

    By the way, is it normal behaviour for the contents of the Site List to revert back to the few sites that seem to have been automatically 'edited'? Thinking that it might have had something to do with a site having to be edited I did edit a few of the one added during a session but after a reboot they had disappeared from the List. Once you have set up your own preferences for individual sites, ie, edited the settings that ZASS sets, is there anyway of making sure that this customisation does not get deleted?

    Thanks in advance.



    Balders

  4. #4
    billc Guest

    Default Re: Global Mobile Code Setting reverts to 'Off'

    When you shutdown Zone Alarm or reboot your computer all the sites on your Site List are deleted except the ones you have edited. Those appear with a pencil icon next to them. This is indeed normal behavior. So if you want a site to remain there, edit it.

    The likely reason your Mobile Code control kept changing is because your 'Wait to Kill' value in Windows was set too low for ZASS. What that means is that your operating system shuts down before ZASS can write it's files thus 'remembers' it's old settings.

  5. #5
    balders Guest

    Default Re: Global Mobile Code Setting reverts to 'Off'

    Hi BillThanks for the explanation. I will look into the 'Time to Kill' setting that I have. Any suggestions as to what would be a sensible setting in terms of ZASS? I appreciate that this is bound to a certain extent by the 'power' of ones PC.Many thanks for your help and advice to date. It is much appreciated.Best regardsBalders

  6. #6
    billc Guest

    Default Re: Global Mobile Code Setting reverts to 'Off'

    There is no set answer to the value because it depends more on how many programs are opened when you shutdown. ZAP is one of the very first applications to start at boot and last to close at shutdown as it 'watches' the behavior of your other closing programs to make sure they 'mind' themsleves. If you want to change the value, changed the value of the RegKey "WaitToKillServiceTimeout", which you can find here "HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Contr ol" from 'whatever it is' to a bigger number. For example, if the wait to kill value is 5000, change it to 10,000. (5 seconds to 10 seconds) etc.

  7. #7
    balders Guest

    Default Re: Global Mobile Code Setting reverts to 'Off'

    Hi BillThat is what I figured too. I have reset the "WaitToKillServiceTimeout" from 2000 to 10000, and will see whether that has a positive effect.Again, many thanks for your assistance. I am new to this forum and am already impressed by the helpfulness of the Zone Alarm community found here.Best regardsSolly Charbit:8}

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •