Results 1 to 10 of 10

Thread: ZA Blobking PHP $_SESSIONS / $_COOKIES on localhost

Hybrid View

  1. #1
    le_gber Guest

    Default ZA Blobking PHP $_SESSIONS / $_COOKIES on localhost

    There's been other threads discussing this and I wondered if this issue be eventually sorted?

    I had the same problem as the other people (PHP application developped locally) and lost a day's work trying to figure out what the problem was.

    Adding localhost and 127.0.0.1 to the privacy site list doesn't work.
    Leaving the ad blocking(??) on doesn't work
    Disabling privacy for browser in progam control IS NOT AN OPTION

    Operating System:Windows XP Pro
    Product Name:ZoneAlarm Internet Security Suite
    Software Version:6.5

  2. #2
    cyberian75 Guest

    Default Re: ZA Blobking PHP $_SESSIONS / $_COOKIES on localhost

    Is it also in your Trusted Zone?

  3. #3
    le_gber Guest

    Default Re: ZA Blobking PHP $_SESSIONS / $_COOKIES on localhost

    Hi Michael,

    Yes it was. Both 'localhost' and '127.0.0.1'

    the strangest thing is that even if I only turn the ad blocking on, the $_SESSION stopped working

    Message Edited by le_gber on 07-21-2006 06:05 PM

  4. #4
    cyberian75 Guest

    Default Re: ZA Blobking PHP $_SESSIONS / $_COOKIES on localhost

    And you enabled Session Cookies and Private Headers for localhost (127.0.0.1) in Privacy Site List?

  5. #5
    le_gber Guest

    Default Re: ZA Blobking PHP $_SESSIONS / $_COOKIES on localhost

    Yep I did.

  6. #6
    cyberian75 Guest

    Default Re: ZA Blobking PHP $_SESSIONS / $_COOKIES on localhost

    Then I've no idea. Sorry.

  7. #7
    billc Guest

    Default Re: ZA Blobking PHP $_SESSIONS / $_COOKIES on localhost

    I'm not sure this will help, but when you added localhost and 127.0.0.1 to the privacy site, did you go through 'options' to uncheck everything?

  8. #8
    mtanti Guest

    Default Re: ZA Blobking PHP $_SESSIONS / $_COOKIES on localhost

    There is a sort of solution to it, but it's not a change in ZoneAlarm... Instead of typing localhost use your ip address. It will work and if it doesn't put it in the privacy site list since that works for other session using sites. The only problem is that your ip changes so you can't use it in the default preview settings of your php editer...Basically as long as you use ZoneAlarm, forget about localhost or 127.0.0.1 :-(
    Btw, there are many websites which give you your ip, just do a search on 'my ip'.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •