Results 1 to 6 of 6

Thread: global privacy settings overriding site-specific? bug?

  1. #1
    false_dmitrii Guest

    Default global privacy settings overriding site-specific? bug?

    I'm having lots of trouble logging into flickr.com (via yahoo.com) with ZoneAlarm Pro enabled. Yahoo takes and remembers the login, but Flickr rejects it and tells me I need to enable cookies, even though both Yahoo and Flickr have full cookie permissions in ZA.

    With help from Ad-Hock in the config forum, I determined that disabling *all* cookie and advertising blocking (except for "expire after...") in the "main" privacy tab will allow flickr.com to function properly. However, I can't get the same settings to work with entries on the "site list" tab, no matter how many specific yahoo-related sites I added (login.yahoo.com, us.rd.yahoo.com, etc.). Only disabling the global settings will work.

    The opposite isn't true. With global privacy settings relaxed, I tried blocking *all* cookies and ads from flickr.com and yahoo.com. Both sites continued to pass cookies straight through ZoneAlarm, and Flickr login continued to work properly.

    It seems as though ZA's "main" privacy tab is overriding any exceptions on the "site list". I'm using the most recent version. I've only encountered problems on Flickr so far, so I don't know how to isolate and test ZA any further. Is this a low-profile but known bug? If not, would anyone here care to investigate?

    Operating System:Windows XP Home Edition
    Product Name:ZoneAlarm Pro
    Software Version:6.5

  2. #2
    billc Guest

    Default Re: global privacy settings overriding site-specific? bug?

    First, the permissions you've set in your Privacy List should over-ride the 'global' settings. I'm not at all sure it is cookies that's your problem; I'm thinking it is Private Headers being blocked. Try this...go to your Privacy > Site list, and if yahoo.com and flickr.com are on the list, right click on the entries then click to 'remove' them. Now manually add them both back to the list using the 'add' button found on your Privacy List panel. Once added, locate each of the site you just entered on the Site List, right click on it and select 'options'. Next go through all three tabs to uncheck everything and click 'apply' as you go through each tab. Now clean your browser cache and try the site again.

  3. #3
    false_dmitrii Guest

    Default Re: global privacy settings overriding site-specific? bug?

    It's cookies, headers, pop-up script--any one privacy checkbox will trigger the error page.

    I'd already done most of what you said at various points, but I went ahead and tried it again, this time switching each checkbox on and off before each "apply" just in case. In the process, I found I can now get Flickr to open properly if I uncheck the site's "expire cookies" checkbox along with the other settings. This is quite strange, since I had no trouble when I had that setting (and nothing else) enabled in the "main" tab. Something isn't right here.

    I can't rule out a ZA bug on my own. However, it's just as possible that my latest installation went corrupt at some point (which could explain why there's a taskbar-colored silhouette in place of the flashing taskbar "alert" light). Is there another website that would make a good testbed for cookie and script privacy settings?

  4. #4
    billc Guest

    Default Re: global privacy settings overriding site-specific? bug?

    Just about any of the active commercial sites have Privacy issues. The two I hear about most often here is eBay.com and a site called neopets.com . Any site requiring a login is a good test like newspaper outlets. I don't know of a specific test site per se. You might want to turn on your Privacy Advisor for awhile just to see what happens and is getting blocked. You will need to go to the Privacy Panel and click on 'custom' in Cookie Control. Then go to the bottom and enable 'Show Privacy Advisor' click apply then ok.

    If you'd like to install Zone Alarm Pro anew, then first uninstall your firewall this way for the best results. Go into the start menu locate the zonelabs entry and right click on the uninstaller and select properties. Now in the target box you must add a space and then /clean to the end so that it looks something like this "C:\Program Files\Zone Labs\ZoneAlarm\zauninst.exe" /clean click apply and then OK. Next open ZA and turn off the load on boot option, then reboot and then run the uninstaller.This should get rid of all of ZoneAlarm. Now go to your windows temp folder and delete everything. Find the folder named Internet logs and delete it then empty your recycle bin.

  5. #5
    howdy Guest

    Default Re: global privacy settings overriding site-specific? bug?

    I have discovered the same, or at least a very similar, bug. I've seen hints of this before with previous versions of ZA, but I never took the time to isolate the problem. (Instead I would just use the 'work-around' of shutting down ZA completely, until I no longer needed access to the sites in question.)

    In short, I've had Privacy Controls block aspects of sites, so that the site doesn't fully load. When I go to the site specific list, I green-checked ALL columns (mobile code, all three cookie controls, web bugs and private headers) but still have the identical problems loading the site. I go back into the site list, right click on the site, bring up options, and make sure that everything is un-checked which, in theory, allows everything and blocks nothing). I attempt to reload the site, and it still fails to completely load.

    On this last go round, I turned off all the global settings and ... the site loaded completely. Setting any ONE of the global settings (that is EITHER the global cookie control, or the global ad blocking, or the global mobile code control) to ANY setting other than off would cause the site to not load properly. (Yes, I went back and forth. All global off, the site loads. Global cookie control to medium, site does not fully load. All global off, site loads properly. ad blocking to medium, site does not load completely. Repeat for every possible global control setting. Any global control setting to other than off would cause the site to NOT load properly.)

    In addition, this behaviour occurs even when the ONLY site listed in the site list is the one in question. That is, ALL sites are cleared from the list. All caches, etc., are cleared, machine is turned off, then re-started. The ONE site is visited, and is the only site appearing in the site list. As such, it is the ONLY site to which site specific exceptions or allowances can be applied. Even though every site specific exception is allowed for everything, the site is partially blocked, and can only be fully accessed by turning all global controls to off.

    Somehow, somewhere, Privacy Control is blocking the full download and there is no method to create an exception for the specific site in question. The only 'work-around' is to turn off all global privacy controls.

    PLUS, I have Privacy advisor set to advise me of everything, but for the sites that his happens on, Privacy advisor does NOT advise me that it is blocking anything (even though it is obvious that something is being blocked).

    This is NOT browser related, as I get the identical behaviour in both IE and Firefox.

    Currently running ZA Security Suite 6.5.737.000 on WinXP PRO.

    Thanks.

  6. #6
    marbrax Guest

    Default Re: global privacy settings overriding site-specific? bug?

    HELP, I am not technical at all. But my zonealarm blocks my photo's on flickr.com.
    I don't want this and a want that this stops. I tried all the suggestions but that does not work. HELP.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •