You're welcome...A side note, ZA products do not officially support XPMCE only XP/2000 and VISTA thougth many users seems to have no problems with it on MCE.Cheers,Fax