Results 1 to 6 of 6

Thread: Disable all networking

  1. #1
    matriloch Guest

    Default Disable all networking

    I am doing everything right. I use strong passwords. I don't use Outlook Express or IM. I use Zone Alarm Security Suite. Still I have a problem with people networking with my computer.
    I have disabled remote assistance. I went into services.msc and disabled wireless zero configuration. I have a dial-up Internet connection.
    How can I disable anything that will allow networking and still have an Internet connection? I guess it would be local networking I'd want to disable. Is there anything else I can disable in services.msc?
    Thank you.



    Operating System:Windows XP Home Edition
    Product Name:ZoneAlarm Internet Security Suite
    Software Version:

  2. #2
    Join Date
    Dec 2005
    Posts
    9,056

    Default Re: Disable all networking

    Hi

    Which people or sites? Do you have any hardware firewall in front of the PC or is this a phone line into the back of the PC where this is not possible? A hardware firewall would drop all unwanted connections and provide perfect stealth at all times.

    Open the network connections and open the properties of the connection. There is listed several items in the middle and most are not needed-file and printer sharing over MS networks is one of them. A very good site describing in detail for what you are looking of can be found here>

    http://www.markusjansson.net/exp.html

    An easy to follow guide is here>

    http://mywebpages.comcast.net/SupportCD/SecureXP.html

    also more is found here>

    http://www.microsoft.com/technet/sec.../legsgch3.mspx

    and here>

    http://www.hsc.fr/ressources/breves/...win.en.html.fr

    A service guide is here (disabling unwanted services does help fix some security issues and make PC a little easier on resources)>

    http://www.theeldergeek.com/services_guide.htm

    A good user-check of the system for issues is here>

    http://www.cert.org/tech_tips/WIDC.html

    Oldsod

    Message Edited by Oldsod on 04-04-2007 11:40 AM
    Best regards.
    oldsod

  3. #3
    watcher Guest

    Default Re: Disable all networking

    Dear Matriloch:

    Make sure you have both Remote Assistance and Remote Desktop disabled. Both can be done within the System applet in Control Panel. Open System, click the Remote tab, and make sure both options are unchecked.

    Re services.msc, the following can be disabled:

    Alerter
    Application Layer Gateway Service
    ASP.NET State Service
    Computer Browser
    Messenger
    Net Logon
    NetMeeting Remote Desktop Sharing
    NetworkDDE
    NetworkDDE DSDM
    Network Location Awareness
    Network Provisioning Service
    Remote Desktop Help Session Manager
    Remote Registry
    Routing and Remote Access
    Secondary Logon
    Server
    SSDP Discovery Service
    TCP/IP NetBIOS Helper
    Telnet
    Terminal Services
    Universal Plug and Play Device Host
    WebClient
    Windows Media Player Network Sharing Service

    Note you may not have all of these but I do and they are all disabled with no negative effects. Besides hardening your computer against attacks, disabling these unnecessary services will save you RAM.

    One last change, in the Registry, will disable Remote Assistance even if it is reactivated by a hacker in the services.msc list.

    HKLM\SYSTEM\CurrentControlSet\Control\TerminalServ er\
    WinStations\RDP-tcp

    PortNumber=3389, change to 33891(decimal). This changes the default port number that Terminal Services uses to an nonstandard port number, rendering it useless. The hacker would have to know which port you changed it to in order to defeat this tweak.

    Hope this helps.

    WATCHER

  4. #4
    exxon Guest

    Default Re: Disable all networking

    Thank you both. So far I've just had time for elder geek.
    It took me a couple of days on the phone with ATT to solve a problem I've never had
    before. I never even heard of a Winsock. If anyone here has a similar problem, the symptoms are these. Your modem connects to something, God knows what, but you get an error page on your browser.
    It's very easy to fix. The tech telnetted me the file. It comes in Windows XP Security package 2, but I'd deleted the whole package, trying to see if it was the reason I couldn't get online. The file has a big red cross icon and is called WINSOCKXPFIX.
    The elder geek assumes that most people have DSL, which they do, but I don't. I have a phone connection, so I had to restore a couple of the services that a person with DSL doesn't need. Zone Alarm is my only firewall.
    Speaking of Telnet, I think my hacker is using it. Unfortunately XP home edition doesn't have an option to turn off telnet service. I found two copies and deleted them. But there's another one that won't let me delete it. I think he's using it in DOS, because when I opened it, that's where it went.
    Do Zone Alarm forums have an address that ends in lithium.com? I think he may be forging my pages.
    Ann


  5. #5
    watcher Guest

    Default Re: Disable all networking

    Dear exxon:

    I hope you have SP2 installed on your computer as it contains many security updates, all rolled into one package.

    You can disable the Telnet service by clicking Start, Run, type services.msc, then click OK. In the Services window that displays, scroll down the alphabetic list to Telnet, right click that entry, click Properties. In the Telnet Properties dialog box, click Stop if the Service Status=
    Started. Otherwise, click the down arrow by Startup type and select Disabled. Click OK. Now, anyone trying to use telnet on your computer will be unable to. In a computer lab, I tried to telnet to a computer that had telnet disabled and I could not connect.

    You can also use ZA to kill the program if it ever starts on your computer. Go to Program Control panel, Programs tab, and find the Telnet entry. If it is not there, it has not been used then since ZA was installed because ZA populates this list with programs when they are first opened. Anyway, once you found the entry, click in the Trust Level column and then click Kill. It will populate all the program permission columns with a red circle with a diagonal line. Now, every time the telnet program attempts to open, you will get an alert saying it was prevented from starting.

    Windows XP has what they call Windows File Protection(WFP) that protects certain Windows files. It was designed to protect system files from being overwritten, also known as DLL **bleep**, but you'll find other files there besides these.
    The files that are protected are found in the C:\Windows\system32\dllcache. These are copies. The originals are on your hard drive in various locations. If you try to delete the original the copy is copied to the original's location. The ONLY way I found around this was to reboot, hit the F8 key to go into Safe Mode, and then delete the file from both locations. It's a poorly documented feature, many of the files listed there are not system files and there is no rhyme or reason for the selection process that I can see, and about the only control you have over it is the size of the dllcache folder which you can set in the Registry. This feature cost me hours of my time when I tried to install a new version of Windows Media Player but WFP kept restoring the updated files, rendering the installation useless. You are much better off making an image of your hard drive and restoring files from there if you need to.

    Hope this helps.

    WATCHER

  6. #6
    exxon Guest

    Default Re: Disable all networking

    Thank you for the information.
    I do have SP2 installed. I got the disk from Microsoft, and I sure wish they'd make an SP3 available.
    When I went into services.msc, there wasn't an option to disable Telnet, probably because I have XP home edition. It should be in Zone Alarm, because I used it with the ATT tech. I'll try that.
    Thank you for the dll information. I didn't know about the sneaky little cache.
    X

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •