"You can add the PPP dns and dhcp IP as trusted too.
I suspect this is the problem and the IP of the PPP should be tried with 'trusted'."

"I suspect this is the problem and the IP of the PPP should be tried with 'trusted'"

Well when the [IP] of the PPP was detected with ZA, I don't think there was a window giving me an option between Internet or Trusted (There Was one which it detected the unused PCI Card), but it was automatically detected and added in Zones after changing security level to Medium, and connecting with the dialer. It was automatically detected and added as Trusted.
Only then, I changed it to Trusted as you wrote before.
I just wrote that I also to access the internet with High security, with the IP marked as Trusted, as well maeked as Internet, and with both there was no access.
And of course, I did add as well the DNS servers and Default Gateway servers listed under PPP as Trusted, I think I wrote before. And there was no DHCP server there, only one under the Marvell Yukon.

So I think I tried what you wrote, adding the DNS, DHCP, localhost, Default Gateway IPs as Trusted, as well as the IP of the PPP. Nothing worked, what now?
I can try again to add the IPs... but to be sure, I should add the [2 DNS] and [1 DHCP] IPs listed under the Marvell Yukon, AND the [2 DNS] and [1 Default Gateway] IPs listed under PPP, all as trusted? What about the [1 Default Gateway] IP of the Marvell Yukon? Needed as Well?
And then change the IP listed under PPP, from Internet to Trusted (its automatically added as Internet when detected)


*****UPDATE
Note I did not reset my ZA preferences since the last time.
I read a similar thread to mine in this forum, and decided to try and add my ISP address which the dialer is always connecting to.
Just to be sure, I tried adding all of the DNS, DHCP and Default Gateways IPs, of the Marvell Yukon And of the PPP, all as Trusted, then I was able to connect and access the internet on High Security Level. But after it is connected, there is no internet for about 15 seconds, and it seems that ZA is searching for the IP or something, because only after about 15 seconds, I see the PPP IP line is added in ZA Firewall Zones and then theres internet access. It detects it much faster in Security Level of Medium, and theres internet access instantly after connecting.
The PPP IP is automatically being detected and added as Internet, not as Trusted. And as I wrote internet access works. So I assume its ok to be marked as Internet, and not as Trusted like the manually added IPs?
Note that every time I connect to the internet, I get a different IP adress (only last 2 octets of it I think).

So the questions are:
-Which IPs do I actually need to add, which of the PPP, and which of the Marvell Yukon? There are Default Gateway, DHCP and DNS. I just don't want any unnecessary IPs marked as trusted, only those that are needed for me to access the internet.
While all of those should be marked as Trusted, should the PPP IP be changed to Trusted, or be kept as Internet?
-Why does it take for ZA longer to detect an IP on High Security Level, thus there is no internet access immediately after connecting, unless using Medium Security Level, then there is internet access instantly after connecting.
-Does it matter that I have the PPP IP listed as [IP/255.255.255.255], and not as [IP/255.255.255.0]? I really dont know what it means or if it affects anything?

Thanks.

Message Edited by catcherr on 04-21-2009 11:07 AM