Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: cygwin commands SLOW

  1. #1
    ewulff Guest

    Default cygwin commands SLOW

    Hi all, I just rid myself of McAfee virus scan in lieu of Zone Alarm Pro Security Suite including virus scan. However, now commands in cygwin take SIGNIFICANTLY longer to execute. For example, the simple 'ls' command takes about 4 seconds and the 'ant build.xml' command takes about 25 seconds just to initiate execution.

    Please keep in mind that I've tried changing various Zone Alerm settings, such as trusted zone and program control, with no success, and when I turn off Zone Alarm cygwin commands operate virtually instantly.

    How can I fix this?

    Eric

    cygwin 1.5.21-1

    ZoneAlarm Security Suite version:6.5.737.000
    TrueVector version:6.5.737.000
    Driver version:6.5.737.000
    Anti-virus Vet engine version:11.9.1.000
    Anti-virus signature DAT file version:11.9.9977.000
    Anti-spyware engine version:5.0.83.0
    Anti-spyware signature DAT file version:01.200609.345
    AntiSpam version:4.8.2.7565

    Operating System:Windows XP Pro
    Product Name:ZoneAlarm Pro
    Software Version:6.5

  2. #2
    ewulff Guest

    Default Re: cygwin commands SLOW

    viewed 50 times but no response. Please, I can't be the only one who has had this problem. Any ideas?

    Eric

  3. #3
    botag Guest

    Default Re: cygwin commands SLOW

    I am dealing with this same problem and haven't found a solution yet, but would surely appreciate it if someone had one to share.

  4. #4
    ewulff Guest

    Default Re: cygwin commands SLOW

    Appreciate at least someone responding to say they're in the same boat. I figure, if I have the problem I'm likely not an isolated case.

    I'll try contacting zome alarm directly since it seems a solution is not yet found by those on this thread. I'll reply with what, if anything, I find.

    thx
    Eric

  5. #5
    ewulff Guest

    Default Re: cygwin commands SLOW

    Well, the support instructs are circular directling the user around and back to either pay for phone support, a virtual assistant, and/or the user forum. So far I feel I've been patient. The user forum hasn't produced even a lead in 4 days. The virtual assistant didn't help and I hardly want to pay for technical assistance when I already paid for a product and it's not working. This is disappointing to say the least.

    How can I speak to a technical support even if it's by email?

    Eric

  6. #6
    botag Guest

    Default Re: cygwin commands SLOW

    There are several different threads asking about this issue. They point to On Access Scanning being the culprit but no solutions are proposed for the bash shell other than disabling the scanning. It is unfortunate that this has not been addressed.

  7. #7
    ewulff Guest

    Default Re: cygwin commands SLOW

    fyi - I've made contact with technical support who so far suggested one fix that did NOT work...

    for the record - this does NOT solve the problem...

    1. Reboot your system into Safe Mode. The method is determined by
    your OS but normally either pressing F8 at the beep, or holding the
    control key during boot up works. For more information on rebooting
    in Safe Mode, click Start, then Help. Click the Search tab, and
    type in SAFE MODE
    2. Open the Internet Logs directory (in 98SE/ME this will be
    c:\windows\internet logs, in 2000 it will be c:\winnt\internet logs,
    in Windows XP it could be either of these folders).Hold CTRL on your
    keyboard and hit F.
    We will do 3 searches,

    Search *.LDB and erase all that it finds.
    Search *.RDB and erase all that it finds.
    Search *.TMP and erase all that it finds.

    3. Empty your Recycle Bin.
    4. Reboot your system.

  8. #8
    bweinste Guest

    Default Re: cygwin commands SLOW

    I've had this problem for quite some time. The only workaround I've found is shutting of the anti-virus in the ZoneAlarm Security Suite control center. I turn it back on when I'm done with Cygwin. This is fine given my usage patterns but would not work if I used cygwin more heavily.

  9. #9
    ewulff Guest

    Default Re: cygwin commands SLOW

    many thx for this post! Perhaps I've taken your lead a step further and turned off just the 'On-Access Scanning' feature of the anti-virus and that resolves the issue. It's one of the 'advanced options' from the 'Anti-virus/Anti-spyware' tab of Security Suites control center.


    <blockquote><hr>bweinste wrote:
    I've had this problem for quite some time. The only workaround I've found is shutting of the anti-virus in the ZoneAlarm Security Suite control center. I turn it back on when I'm done with Cygwin. This is fine given my usage patterns but would not work if I used cygwin more heavily.
    <hr></blockquote>

  10. #10
    antinul Guest

    Default Re: cygwin commands SLOW

    I just installed cygwin today and I have the same problem here, bash takes 5 seconds to do an ls, and vsmon uses 100% of the cpu.
    Yes, disabling OAS seems to resolve the problem, but that isn't really a solution, more like a compromise.
    If I have to, I'll pay to have support figure this one out, although I'm trying to get it resolved without having to pay - after all it looks like a problem with vsmon, no?
    I need cygwin, and I'm too invested in zone alarm to switch to something else.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •