Results 1 to 7 of 7

Thread: Cookie control disabled localhost site states "Cookies must be enabled past this point"

Hybrid View

  1. #1
    jkpalmer Guest

    Default Cookie control disabled localhost site states "Cookies must be enabled past this point"

    I'm using WAMP5 for local development. (Windows, Apache, MySQL, PHP)

    phpMyAdmin comes bundled with WAMP5

    I have Cookie Control Off but when I try to access my MySQL database using phpMyAdmin from localhost, I receive message "Cookies must be enabled past this point" at the top of my UI and many features of phpMyAdmin are "gone". If I Shutdown ZoneAlarm Security Suite, everything works fine for phpMyAdmin.

    I'm using FireFox 2.0.0.3 and it is configured to "Accept Cookies From Sites" and Keep until "they expire"

    What do I need to do to get local cookies to work properly

    Someone please HELP

    TIA

    Jim P

    Operating System:Windows XP Pro
    Product Name:ZoneAlarm Internet Security Suite
    Software Version:7.0

  2. #2
    ned Guest

    Default Re: Cookie control disabled ..."Cookies must be enabled past this point"

    Jim, I feel your pain. I just spent over 18 hours exploring the phpMyAdmin / ZoneAlarm conflict. A lot of time Googling, a lot of time adjusting my machine. The short of it--we're out of luck.

    It's amazing how many plaintive posts like yours are out there _without_ any replies. Not a good sign. I hope this post saves some third person from beating his head against a wall for 18 hours.

    You will find a number of posts on the web that "Cookies must be enabled past this point" is "just" a warning. Yeah, a warning that phpMyAdmin can't function properly.

    The only way I've found to stop the interference is to disconnect my PC from the net and stop ZoneAlarm. phpMyAdmin then works fine, immediately.

    In ZA's defense, I'm not sure it can recognize phpMyAdmin as a distinct application. I'm also not sure how ZA could tell the difference between the kind of interprogram interaction phyMyAdmin has with MySQL and evil behavior.

    When I started my development project, I intended to run LAMP and CVS on an old server box and use my W2000 machine simply as an editing station (UltraEdit Studio, BTW). I had most of it in place and working, but for some reason decided that a WAMP & CVSNT configuration would be less complicated and so less potentially troublesome. I WAS WRONG.

    My current plan is to continue with the WAMP configuration until the initial release, tolerating going off the net to run phpMyAdmin. When I've got some time, I'll get the LAMP configuration I originally intended running right. That's a better solution, even if you have to buy a box to run Linux to do it.

    Ned

    MySQL 5.0.45
    Apache 2.2.4
    PHP 5.2.4 with mysqli 5.0.45
    phpMyAdmin 2.11.0
    Operating System: Windows 2000
    Product Name: ZoneAlarm Security Suite
    Software Version: 7.0

  3. #3
    skeezix Guest

    Default Re: Cookie control disabled ..."Cookies must be enabled past this point"

    What's also interesting is that this problem is unknown on the WordPress and phpmyadmin forums. Guess not too many folks are using their PCs as local servers in conjunction with Xampp and Zone Alarm.
    Maybe this will be addressed in the next release of ZASS...

  4. #4
    magicjebb Guest

    Default Re: Cookie control disabled ..."Cookies must be enabled past this point"

    Even though I don't have this WAMP5 I went through the same problem with phpMyAdmin.

    All my browsers, IE, Firefox and even the old Netscape, showed the same message "Cookies must be enabled past this point" when I logged in my two sites C-Panels and entered phpMyAdmin. All browsers had cookies enabled and the sites were hosted in two completely different servers, with completely different c-panels.

    While getting some free nervous breakdown, I've noticed that my antivirus also didn't update anymore. Even though the last update was installed, the AV insisted it was still out-of-date, so I went on google to check and found the grisoft AVG website, where somewhere it was written "CHECK YOUR CLOCK".

    That was it - my windows clock (Date and Time Properties) was showing some weird date, it was may, when it should be april, or something like that. After correcting the clock, everything started to work fine again, both phpMyAdmin and the antivirus.

    I don't know if it would solve everybody's problems regarding this nasty "Cookies must be enabled past this point" phpMyAdmin error, but since it helped me and there seems to be some people facing a similar situation with no solution, well, this is my solution for that - at least it worked for me,

  5. #5
    saddas Guest

    Default Re: Cookie control disabled ..."Cookies must be enabled past this point"

    I found a workaround that is slightly less convenient than having to disconnect from the Internet and shutting down ZA before running your phpMyAdmin. Restore the databases in ZA by doing the following:
    1) Login to the PC in Safe Mode (hit F8 as you restart)2) Go to the Internet logs folder under C/Windows or C/Winnt3) Delete all files that end with *.LDB, *.RDB, and *.TMP (note that this will erase any customized settings you have made in ZA, but it is usually not a big deal to restore these settings as you go along)4) Restart in normal mode5) In ZA, go to Privacy, and set both "Cookie Control" and "Ad Blocking" to off (keep in mind this will affect your security settings for cookies and ads)6) Run phpMyAdmin; it should work now without the annoying "Cookies must be enabled past this point" error message.
    Don't forget after finishing with phpMyAdmin to reset "Cookie Control" and "Ad Blocking" to medium or high if you wish to do so. At least this way you don't have to be off the Internet and can work while ZA is still on. Hope this works.
    Shamel

  6. #6
    pmdw Guest

    Default Re: Cookie control "Cookies must be enabled past this point"

    I had a similar problem and the way I fixed this is as follows:

    Open Zonealarm go to the privacy settings
    go to the site list
    click on the add button and when Zonealarm asks for the url give it the full network name of your local server ie [the server / PC name].[the domain]
    ( note the dot or full stop between the server name and the domain name)

    Then you can allow everything from mobile code to private header information for the specific site.
    OR
    You can also just allow specifics ie If your local site does not use java then you can still block mobile code but allow 3rd party cookies and private header information.

    Alternately you can get Zonealarm to help you.
    Open Zonealarm go to the privacy settings
    go to cookie control click on the custom button
    and enable the privacy adviser ( this can be very annoying but you can turn it off once you get things working)
    Then try to go to the website you are working on or with and allow what you need.
    this will automatically create a site in your site list for you.
    hope this helps

  7. #7
    jonessm Guest

    Default Re: Workaround for "Cookies must be enabled past this point"

    In my case, I got around the problem by substituting the IP address of my network card in place of "localhost" in the phpMyAdmin URL in my browser

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •