Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: Problems with sharing folders on a network

  1. #11
    watcher Guest

    Default Re: Problems with sharing folders on a network

    Dear kchight:

    Do you have Internet Information Services(IIS) running on OLD? The reason I ask is that the folder you are attempting to share has a Web Sharing tab. IIS is a web server that can be activated in Windows XP Pro to serve up web or other content. Also, have you tried my previous post without using the network connections wizard?

    WATCHER

  2. #12
    kchight Guest

    Default Re: Problems with sharing folders on a network

    Hello Watcher,
    On OLD, in the services snap-in there was a service labeled as IIS Admin that was started and listed as automatic. I stopped this service and changed it to disabled. Now there is no Web Sharing tab on any folder, but alas, no sharing either.

    Regarding trying "your previous post without using the network connections wizard?" I am not sure what you are asking. I have done the following in addition to running the wizard. Via the control panel, I chose Network connections. From the Network connections listed, I right-clicked on LAN Connection and chose properties. In the resulting box, it listed my network card (which is the correct one) as "Connect using:"

    In the box below labeled "This connection uses the following items:" there are (all with checks in the boxes): Client for Microsoft Networks; File and Printer Sharing for Microsoft Networks; QoS Packet Scheduler; NWLink NetBIOS; NWLink IPX/SPX/NetBIOS Compatible Transport Proto...; and Internet Protocol (TCP/IP).

    I have unchecked the box next to File and Printer Sharing and rebooted. I have also clicked on it and clicked uninstall, rebooted, and re-installed in various combinations. None of these options brings the Sharing context menu or sharing tab.

    Is there anything else you might suggest trying?

    I really do appreciate your attempting to help me with this problem.
    Thanks,
    Ken


    <blockquote><hr>WATCHER wrote:
    Dear kchight:

    Do you have Internet Information Services(IIS) running on OLD? The reason I ask is that the folder you are attempting to share has a Web Sharing tab. IIS is a web server that can be activated in Windows XP Pro to serve up web or other content. Also, have you tried my previous post without using the network connections wizard?

    WATCHER
    <hr></blockquote>

  3. #13
    watcher Guest

    Default Re: Problems with sharing folders on a network

    Dear kchight:

    In the Properties sheet for Local Area Connection, General tab, uncheck Client for Microsoft Networks(this is for domains only), NWLink NetBIOS and NWLink IPX/SPX/NetBIOS Compatible...(for NetWare operating systems which you don't have), and this will unbind these protocols from your NIC adapter. I doubt that will resolve this issue but will certainly speed things up by not running these.

    Re the network connections wizard, I meant don't use it. It is one way to set up file sharing but I posted the DIY configuration method.

    I will do some research tomorrow and report back either tomorrow night or the next day. I have simulator programs from college that include setting up file sharing. I'll see if I missed anything. I don't use it myself and there's nothing like hands-on experience.

    WATCHER

  4. #14
    kchight Guest

    Default Re: Problems with sharing folders on a network

    Hi Watcher,
    I unchecked those items on OLD that you suggested. As you guessed that, did not solve the problem. I am assuming that the steps I am taking to check/uncheck, uninstall/reinstall protocols in the LAN Connections properties window are correct for activating File and Printer Sharing by the DIY method. I have a very fast connection already, I average around 850 kb/sec on large file downloads right now, but faster is always better.

    Thanks again for taking the time to reply. I hope you find something in the simulator program that may help me. Otherwise, I will start the sneaker-net process this weekend.
    Ken



    <blockquote><hr>WATCHER wrote:
    Dear kchight:

    In the Properties sheet for Local Area Connection, General tab, uncheck Client for Microsoft Networks(this is for domains only), NWLink NetBIOS and NWLink IPX/SPX/NetBIOS Compatible...(for NetWare operating systems which you don't have), and this will unbind these protocols from your NIC adapter. I doubt that will resolve this issue but will certainly speed things up by not running these.

    Re the network connections wizard, I meant don't use it. It is one way to set up file sharing but I posted the DIY configuration method.

    I will do some research tomorrow and report back either tomorrow night or the next day. I have simulator programs from college that include setting up file sharing. I'll see if I missed anything. I don't use it myself and there's nothing like hands-on experience.

    WATCHER
    <hr></blockquote>

  5. #15
    watcher Guest

    Default Re: Problems with sharing folders on a network

    Dear kchight:

    Please try this on OLD. Click Start, Settings, Control Panel, Administrative Tools, and open Computer Management. Expand System Tools if it isn't already. Expand Shared Folders and click on Shares. Note you must have the Server service running or you will receive an error. In the right pane will be listed all the shares on OLD. Now, right click the Shares folder in the left pane and click New File Share. The Create a Shared Folder Wizard opens. Click Next. Click the Browse button next to Folder to share: section. Find the folder you want to share, click on it, then click OK. Its pathname will now be listed in that section. In the Share name: section, add a share name(aka alias) for the folder you want to share. If you want, you can add a description but this is optional. Click Next. In the Shared Folder Permissions wizard page, enable the 2nd option, Administrators have full access; other users have read-only access. Click Next. Click Finish on the next wizard page. It should now show up in the right pane when Shares in the left pane is clicked. There should now be a Sharing and Security... command in the context menu of folders.

    Note that this method does not require you enable, Use simple file sharing(Recommended), in Folder Options. If you don't enable it, the Properties sheet for a folder will have BOTH Sharing and Security tabs. I tested everything written here and it worked.

    Good luck and please post your results.

    WATCHER

  6. #16
    kchight Guest

    Default Re: Problems with sharing folders on a network

    Hi Watcher,
    On OLD, I clicked on Start --&gt; Control Panel --&gt; Administrative Tools --&gt; Computer Management. System Tools was already expanded. I expanded Shared Folders and it had the following: Shares, Sessions, and Open Files. Each of these is a folder icon with a hand underneath it (same icon as the shared folders.) Before doing this, I double checked to be sure the Server Service was running. I can see shares on the right pane. There are icons of a computer hard drive with a hand underneath it for each partition of my hard drives plus a couple of others. They are in this order from top to bottom: ADMIN$; C$; D$; E$; G$; IPC$; P$; and R$. Note that C, D, E, G, P and R are actual partitions on my two internal hard drives. I do not know what ADMIN$ or IPC$ are. When I right click the Shares folder in the left pane these are the options on the context menu: All Tasks (which has an additional context menu for &quot;Send Console Message...&quot; View (which has additional context menus for Add/Remove Columns, Large Icons, Small Icons, etc.); New Window from Here; Refresh; Export List...; and Help. There is NO option for &quot;New File Share&quot; listed. Also in the right pane, the &quot;Shared Paths&quot; appear to be correct... pointing to the correct partitions. The other columns are &quot;Type&quot; with all items listed as Windows; &quot;# of Client Connections&quot; with all listed as zero; and &quot;Comment&quot; which are listed as Remote Admin for Admin$, Default Share for the partitions, and Remote IPC for IPC$. Also note that right clicking on any of the icons in the right pane gives me a context menu with options for &quot;Refresh&quot; and &quot;Help.&quot;

    So this is where I stopped. I could not complete any further steps in your instructions. I did go back into the services snap-in and checked on dependencies for the Server service. One of the dependencies listed was Computer Browser. I noted that this service was stopped and disabled. I switched it to automatic and started it with no apparent results. I rebooted the computer just in case, and still no apparent changes. Workstation was also listed as a dependency, but it was listed as automatic and started. I stopped it, restarted it, and rebooted with no apparent changes.

    One other thing that might be working against me somehow if that I am using a setting in &quot;Tweak UI&quot; to automatically log-on to the computer. I will try resetting that so that I have a standard log-on and report back the results. I will also go through the services that are running on OLD and check that they are the same as NEW and that dependencies are all listed and working okay.

    Once again, I really appreciate your efforts trying to help me resolve this issue. If you have any further suggestions, please let me know what they might be.

    Thanks,
    Ken



    <blockquote><hr>WATCHER wrote:
    Dear kchight:

    Please try this on OLD. Click Start, Settings, Control Panel, Administrative Tools, and open Computer Management. Expand System Tools if it isn't already. Expand Shared Folders and click on Shares. Note you must have the Server service running or you will receive an error. In the right pane will be listed all the shares on OLD. Now, right click the Shares folder in the left pane and click New File Share. The Create a Shared Folder Wizard opens. Click Next. Click the Browse button next to Folder to share: section. Find the folder you want to share, click on it, then click OK. Its pathname will now be listed in that section. In the Share name: section, add a share name(aka alias) for the folder you want to share. If you want, you can add a description but this is optional. Click Next. In the Shared Folder Permissions wizard page, enable the 2nd option, Administrators have full access; other users have read-only access. Click Next. Click Finish on the next wizard page. It should now show up in the right pane when Shares in the left pane is clicked. There should now be a Sharing and Security... command in the context menu of folders.

    Note that this method does not require you enable, Use simple file sharing(Recommended), in Folder Options. If you don't enable it, the Properties sheet for a folder will have BOTH Sharing and Security tabs. I tested everything written here and it worked.

    Good luck and please post your results.

    WATCHER
    <hr></blockquote>

  7. #17
    btreloar Guest

    Default Re: Problems with sharing folders on a network

    Hi, Watcher,

    Hope I don't confuse things by stepping into the discussion again, but I'm having a very similar problem here. On my new laptop with ZoneAlarm, every time I reboot, file &amp; printer sharing in my Local Area Network Connection properties gets turned off. If I go there and manually turn it back on, everything works fine. Until I have to reboot.

    I followed your suggestions about making sure file sharing is turned on for both the OS and the connection, but I found everything set properly in the Operating System when I checks (as you suggested) under Folder Options.

    Still, every time I reboot, the OS comes back up with the connection properties checkbox for file &amp; printer sharing unchecked.

    Can you suggest anything I can do?

    Thanks,
    Bill

  8. #18
    watcher Guest

    Default Re: Problems with sharing folders on a network

    Dear kchight:

    If you have no option for creating shares in Computer Management, there isn't anything further I can think of. I'm thinking OLD's Registry has either become corrupted or damaged as the context menu commands are usually defined in the Registry. However, I wouldn't know where to look as I've never had use for file sharing and prefer using the GUI front end versus directly editing the Registry when making configuration changes in the operating system. What is interesting is that I had file and print sharing disabled on my computer since I purchased it almost 3 years ago yet I was able to create a share using either method.

    Luckily, you have a workaround using removable storage.

    Well, we tried. I hope the alternate works better.

    WATCHER

  9. #19
    watcher Guest

    Default Re: Problems with sharing folders on a network

    Dear btreloar:

    Please repost this as a new thread. Normally, I don't care whether someone posts a similar problem in another person's thread but, in this case, kchight's thread is already on the 6th page of the Configuration section of this forum, your problem is different from kchight's, and you've provided no details on your operating system, ZA edition/version, and what exactly you've configured. This way, it will receive more exposure as a new thread and you might receive help from other forum members as well.

    I'll look for the new thread in the Configuration section.

    WATCHER

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •