Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Problems with sharing folders on a network

  1. #1
    kchight Guest

    Default Problems with sharing folders on a network

    Hello all,
    I don't really know if this a Zone Alarm Pro Problem or not, but here goes. I just bought a new computer and hooked it into my network. My network is two computers connected to an older LinkSys router (no wireless). The router came with Zone Alarm gateway security built-in. The old computer has good internet access and no problems with connections. I installed Zone Alarm Pro on the new computer and it detected the router okay. To get internet access, I had to turn off "Enforce Zone Alarm Security" in the router security section. I also had to make the detected network "internet" to get access. Internet access if good from the new computer. However, I can see the old computer from the new computer, but cannot access anything on the old computer.

    Here is where the problems started. I have a number of files on the old computer that I need to access from the new computer -- files I moved to the old computer when my wife's computer died. On the old computer, when I right-click on a folder there is no "sharing" listed in the context menu. I went to Microsoft's Help and their website and followed various suggestions regarding enabling file and folder sharing... turned on file and printer sharing through network connections setup. I still do not have "sharing" in the context menus and no access from the new computer. I do notice that when I turn on file and printer sharing, Windows Firewall turns on. Still no sharing though. I also notice that if I reboot the old computer then go back into network connections setup, it is turned off again. I have tried turning off the Windows Firewall, turning on the Windows Firewall, turning on file sharing through network connections setup. With all configurations, I do have file or folder sharing, and everytime I reboot, Windows firewall turns itself on and file/folder sharing switches itself to off.

    Both computers are running Windows XP Pro SP2. On the new computer, I am logged on as administrator. On the old computer, I am logged on as a user that has all administrative rights.

    If you need more details, I'll be happy to provide them.
    Thanks,
    Ken

    Operating System:Windows XP Pro
    Software Version:7.0
    Product Name:ZoneAlarm Pro

  2. #2
    kchight Guest

    Default Re: Problems with sharing folders on a network

    Bump

    No thoughts on what this might be?

    Thanks,
    Ken

  3. #3
    kchight Guest

    Default Re: Problems with sharing folders on a network

    Bump.

    If this is in the wrong forum, could someone at least direct me to the right one?

    Thanks,
    Ken

  4. #4
    btreloar Guest

    Default Re: Problems with sharing folders on a network

    Me, too -- same problem. Hoping someone will respond with a solution.

    Bill

  5. #5
    btreloar Guest

    Default Re: Problems with sharing folders on a network

    I discovered that turning off WIndows Firewall is insufficient to keep it from turning itself back on. I had to go into Control Panel | Windows Firewall | Advanced and uncheck all the things the firewall was supposed to protect me against.

    On reboot, Windows firewall did NO turn itself back on.

    Nevertheless, my other computers still can't see files on this PC -- and I've confirmed I have file & printer sharing turned on. So I'm still stumped.

  6. #6
    kchight Guest

    Default Re: Problems with sharing folders on a network

    Hello btreloar,
    Good to hear that at least I'm not the only one having problems. I was beginning to feel like the Lone Ranger. I have not found a solution yet, either. I guess I will have to resort to the only option that seems available, which is to turn off Zone Alarm on both computers and see if I can get the computers to share. That worries me because Zone Alarm on my main computer has been reporting several threats since I had to turn off the zone alarm protection in my router.

    I use Trend Micro anti-virus and they offer a firewall. I have it turned off, because I trusted and liked the use of Zone Alarm Pro. I might have to try it, if I can't get Zone Alarm functioning as it should.

    Good luck to you. I'll let you know results of continued experimentation. Let me know if you find anything,
    Thanks,
    Ken



    <blockquote><hr>btreloar wrote:
    I discovered that turning off WIndows Firewall is insufficient to keep it from turning itself back on. I had to go into Control Panel | Windows Firewall | Advanced and uncheck all the things the firewall was supposed to protect me against.

    On reboot, Windows firewall did NO turn itself back on.

    Nevertheless, my other computers still can't see files on this PC -- and I've confirmed I have file &amp; printer sharing turned on. So I'm still stumped.
    <hr></blockquote>

  7. #7
    watcher Guest

    Default Re: Problems with sharing folders on a network

    Dear kchight:

    When you enable file sharing on the computer hosting the shares, you must do so BOTH in the operating system and the connection. It appears you have done so in the connection but not in the operating system. To do that, go to Control Panel and open Folder Options. Click the View tab. At the bottom of the list in Advanced Settings, enable, Use simple file sharing(Recommended). You will now notice that the context menu for folders has a Sharing and Security command and, if you click Properties instead in the context menu, you will notice a Sharing tab there as well. Both bring up the same dialog box. If, under the Network sharing and security section, the checkboxes are dimmed out, that means you have the Server service disabled. Click Start, Run, type services.msc, and click OK. In the Services window, right click the Server service, click Properties, and set to Automatic and click Apply. Click Start and then click OK.

    Hope this helps.

    WATCHER

  8. #8
    kchight Guest

    Default Re: Problems with sharing folders on a network

    Hello Watcher,
    Thank you for the reply and the suggestions. I tried what you suggested regarding the folder options &gt; view checkbox in the control panel. This box was unchecked. I checked the box. There was no Sharing or Security menu option offered in the right-click context menu for the folder I wanted to share. When I clicked on the right-click option for properties the folder did NOT show a tab for sharing and the tab for security was gone. The only tabs are General, Web Sharing and Customize. I went to the services snap-in via the method you suggested. The server service was listed as started and automatic. I stopped the service, left it on automatic and re-booted. After rebooting, everything was still the same. No sharing and security on the right-click context menus or on the tabs in properties. Just one note, after the reboot, I ran the network connection wizard and the &quot;Turn on Printer and File sharing&quot; option was checked already. I continued the wizard and &quot;Windows Firewall&quot; was enabled, but still no options for sharing (or security) in either place. I turned Windows Firewall off and unchecked the connections in the advanced tab. Still no sharing or security. After doing this, I ran the network connection wizard again and the &quot;Turn OFF Printer and File sharing&quot; option was checked when I got to that part. I clicked on &quot;Turn on...&quot; and completed the wizard and Windows Firewall was enabled again. Still no sharing, though. Turned off windows firewall. Still no sharing. Unchecked Windows Firewall advanced options. Still no sharing. Unchecked folder options for &quot;Use simple file...&quot; and got security option back in the properties window, but not in the right-click and still no sharing.

    Here are other things I have tried. In a Command Prompt window, I can ping the second computer (new) IP and get a reply from that computer. On the first computer (old), when I ping it from the new computer, I get a reply. So, at a base network level (DOS), the computers ARE connected to each other. I went back into windows and shared the printer connected to the new computer. Back in windows on the old computer, I can see that printer and print to it. I can also see shared folders on the new computer.

    Now for the weird part... I CAN share the printer that is directly connected to the old computer. Once it is shared, I can see it and print a test page from the new computer!!! I am just unable to share files or folders on the old computer. This is the main reason for networking the computers. Basically, my wife will use the new computer and she needs to access files and folders on the old computer. I know I can burn files to a DVD, thumb drive, etc. and &quot;sneaker-net&quot; them over to the new computer, but it sure would be handy if the network worked.

    Any other suggestions will be most welcome. At this point, I don't know if it is a Zone Alarm or a Windows problem.

    Thanks,
    Ken



    <blockquote><hr>WATCHER wrote:
    Dear kchight:

    When you enable file sharing on the computer hosting the shares, you must do so BOTH in the operating system and the connection. It appears you have done so in the connection but not in the operating system. To do that, go to Control Panel and open Folder Options. Click the View tab. At the bottom of the list in Advanced Settings, enable, Use simple file sharing(Recommended). You will now notice that the context menu for folders has a Sharing and Security command and, if you click Properties instead in the context menu, you will notice a Sharing tab there as well. Both bring up the same dialog box. If, under the Network sharing and security section, the checkboxes are dimmed out, that means you have the Server service disabled. Click Start, Run, type services.msc, and click OK. In the Services window, right click the Server service, click Properties, and set to Automatic and click Apply. Click Start and then click OK.

    Hope this helps.

    WATCHER
    <hr></blockquote>

  9. #9
    watcher Guest

    Default Re: Problems with sharing folders on a network

    Dear kchight: You didn't state what computer you performed this on so let's use a naming convention so I have this straight. We'll call the new computer NEW and the old computer OLD. Both have operating system Windows XP Pro SP2. NEW and OLD are connected to a router. This router had Zone Alarm gateway security built in, something I never heard of. You have it currently disabled. NEW has ZAPRO's current version installed and OLD uses the Windows Firewall. Both have no problems connecting to the Internet and can connect to each other but you still cannot share files.

    OLD Configuration

    1)Network Connections-Local Area Connection-&gt;Local Area Connection Properties-make sure File and Printer Sharing for Microsoft Networks is enabled. If it is not listed, then add it and enable it.

    2)Folder Options-follow previous post to enable Use simple file sharing(Recommended).

    3)Services.msc-follow previous post to set Server service to Automatic and then start the service. When you right click a folder, it should have Sharing and Security... command. In the Properties sheet for the folder, there will be a Sharing tab now instead of a Security tab. 4)Right click the folder you want to share, click Sharing and Security... command. Click Sharing tab. Under the Network sharing and security section, check both boxes there.

    NEW Configuration

    1)Same as OLD

    2)Same as OLD

    Other Factors

    1)Does your router provide DHCP service and assign IP addresses in the range of 192.168.x.2-254? You can determine this by typing ipconfig /all at the command prompt. If this is the case then for ZAPRO on NEW, click the Firewall panel, Zones tab, make sure this network is being detected and in the Trusted zone. By default, the Trusted zone has Medium security which allows file and printer sharing. If your network is in the Internet zone, which has High security by default, then file and printer sharing will be blocked. Entry Type should be Network and network address/subnet mask 192.168.x.0/255.255.255.0 should be listed. While you are there, be sure you have the Local Loopback IP address listed there, 127.0.0.1 in the Trusted zone as well. If you use separate DNS servers, add their IP addresses here as well and place in Trusted zone. Now go to Program Control panel, Programs tab, find Generic Host Process for Win32 Services, make sure it has 3 green bars and green checkmarks in all columns except Server Internet and Send Mail.

    2)I don't use the Windows Firewall nor can I activate it while running ZAPRO(which disables it by default as you should never have 2 firewalls running concurrently on a computer) so I can't give you step-by-step on that. However, make sure it is on for OLD and does not block ICMP(ping) or file sharing. There is an Exceptions list where you can allow these.

    3)On both NEW and OLD, click Start, Run, type CMD, then click OK. Type ipconfig /all at the command prompt on each. On NEW, type ping (OLD IP address) and on OLD type ping (NEW IP address). Make sure you have connectivity and then from each type ping (router IP address) to make sure you have connectivity. Then type ping www.yahoo.com. These tests will determine that you have connectivity between PCs, between PCs and router, and between PCs and the Internet. Please go through this list and report any problems you encounter.

    WATCHER

    Message Edited by WATCHER on 09-02-2007 09:24 PM

  10. #10
    kchight Guest

    Default Re: Problems with sharing folders on a network

    Hello Watcher,
    Thanks again for the reply. I agree with your naming conventions. There is only one thing that is going on that I don't believe you caught. On OLD, when I enable File and Print Sharing through the network connections wizard, the Windows Firewall turns itself on. I don't turn it on. It does it by itself. I can turn it off and uncheck the advanced options and when I run the wizard again, Turn on File and print sharing is chosen as the default on that window. When I go to the properties of the LAN Connection, it has a check beside File and Printer sharing for Microsoft Networks. Under folder options, Use simple file sharing (recommended) is checked. In the services snap-in, the server service is set to automatic and reports it is started. This is all on the OLD computer. With all of this set, when I right-click on a folder on the OLD, the context menu reads as follows from top to bottom: Collapse; Explore; Open; Search...; Encrypt; WinZip &gt;; Find Viruses; Send To &gt;; Cut; Copy; Delete; Rename; and Properties. &quot;&gt;&quot; indicates additional drop-down context available. When I click on Properties, the tabs read (from left to right): General; Web Sharing; and Customize. On OLD, if I go to the start menu and choose &quot;Printers and Faxes,&quot; and then right-click on the printer installed directly on OLD, I get an option for Sharing. If I share it, I can access and use it from NEW. That is the only place I can see sharing on OLD. If I uncheck the &quot;Use simple sharing (recommended)&quot; option in the View menu, I do get a security tab as the 2nd from left tab in the properties window.

    As far as configurations on OLD, 1, 2, and 3 were done, but still no sharing. On NEW, 1 and 2 are done and I shared the printer directly connected to NEW and a folder and I can access and use both of them on OLD.

    In other factors, for number 1, both computers are set-up as with all of the entries you mention and set the way you recommend. Both OLD and NEW can access the internet. For number 2, the only time windows firewall is on, it right after I run the network connections wizard, which turns it on by itself. For number 3, both NEW and OLD can ping each other, the router, and www.yahoo.com.

    At this point, I believe something is wrong between Windows and Zone Alarm Pro. I am leaning toward something being wrong in Windows, possibly caused by compatibility problems with some program and windows. I think it is probably something in the registry dealing with Windows Firewall because of the odd way it turns itself on. The bad thing is that going to into the Microsoft Knowledge Base and searching around for a solution leads nowhere. All of the solutions assume that I can see Sharing on the right-click context menus, but I can't see that. I am about ready to give up and go with the &quot;sneaker-net&quot; solution. I'll just work on this on a continuing basis and see if I can figure anything else out.

    If you do have any further suggestions, I'm willing to try them. Thanks again for your help,
    Ken




    <blockquote><hr>WATCHER wrote:
    Dear kchight: You didn't state what computer you performed this on so let's use a naming convention so I have this straight. We'll call the new computer NEW and the old computer OLD. Both have operating system Windows XP Pro SP2. NEW and OLD are connected to a router. This router had Zone Alarm gateway security built in, something I never heard of. You have it currently disabled. NEW has ZAPRO's current version installed and OLD uses the Windows Firewall. Both have no problems connecting to the Internet and can connect to each other but you still cannot share files.

    OLD Configuration

    1)Network Connections-Local Area Connection-&gt;Local Area Connection Properties-make sure File and Printer Sharing for Microsoft Networks is enabled. If it is not listed, then add it and enable it.

    2)Folder Options-follow previous post to enable Use simple file sharing(Recommended).

    3)Services.msc-follow previous post to set Server service to Automatic and then start the service. When you right click a folder, it should have Sharing and Security... command. In the Properties sheet for the folder, there will be a Sharing tab now instead of a Security tab. 4)Right click the folder you want to share, click Sharing and Security... command. Click Sharing tab. Under the Network sharing and security section, check both boxes there.

    NEW Configuration

    1)Same as OLD

    2)Same as OLD

    Other Factors

    1)Does your router provide DHCP service and assign IP addresses in the range of 192.168.x.2-254? You can determine this by typing ipconfig /all at the command prompt. If this is the case then for ZAPRO on NEW, click the Firewall panel, Zones tab, make sure this network is being detected and in the Trusted zone. By default, the Trusted zone has Medium security which allows file and printer sharing. If your network is in the Internet zone, which has High security by default, then file and printer sharing will be blocked. Entry Type should be Network and network address/subnet mask 192.168.x.0/255.255.255.0 should be listed. While you are there, be sure you have the Local Loopback IP address listed there, 127.0.0.1 in the Trusted zone as well. If you use separate DNS servers, add their IP addresses here as well and place in Trusted zone. Now go to Program Control panel, Programs tab, find Generic Host Process for Win32 Services, make sure it has 3 green bars and green checkmarks in all columns except Server Internet and Send Mail.

    2)I don't use the Windows Firewall nor can I activate it while running ZAPRO(which disables it by default as you should never have 2 firewalls running concurrently on a computer) so I can't give you step-by-step on that. However, make sure it is on for OLD and does not block ICMP(ping) or file sharing. There is an Exceptions list where you can allow these.

    3)On both NEW and OLD, click Start, Run, type CMD, then click OK. Type ipconfig /all at the command prompt on each. On NEW, type ping (OLD IP address) and on OLD type ping (NEW IP address). Make sure you have connectivity and then from each type ping (router IP address) to make sure you have connectivity. Then type ping www.yahoo.com. These tests will determine that you have connectivity between PCs, between PCs and router, and between PCs and the Internet. Please go through this list and report any problems you encounter.

    WATCHER

    Message Edited by WATCHER on 09-02-2007 09:24 PM
    <hr></blockquote>

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •