Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Dile & Printer Sharing Gets Unchecked Every Time I Reboot

  1. #1
    btreloar Guest

    Default Dile & Printer Sharing Gets Unchecked Every Time I Reboot

    On my new laptop with ZoneAlarm, every time I reboot, file & printer sharing in my Local Area Network Connection properties gets turned off. If I go there and manually turn it back on, everything works fine. Until I have to reboot.

    I made sure file sharing is turned on for both the OS and the network connection, but I found everything set properly in the Operating System when I checked under Folder Options.

    Still, every time I reboot, the OS comes back up with the connection properties checkbox for file & printer sharing unchecked.

    I'm running Windows XP (all patched and current) and ZoneAlarm Security Suite 7.0.337.000. My Microsoft Windows Network is in the Trusted zone. Anything else I can tell anyone that would help identify the source of the problem?

    Can you suggest anything I can do?

    Thanks,
    Bill

    Operating System:Windows XP Pro
    Software Version:7.0
    Product Name:ZoneAlarm Internet Security Suite

  2. #2
    watcher Guest

    Default Re: Dile & Printer Sharing Gets Unchecked Every Time I Reboot

    Dear btreloar:

    Click Start, Run, type services.msc, then click OK. In the Services window, find the Windows Firewall/Internet Connection Sharing(ICS) service. Is it set to Automatic? If so, double click it, click Stop, then set Startup type to Disabled. Also, check the Server service and make sure Startup type is Automatic. Then reboot.

    Please post your results.

    WATCHER

  3. #3
    btreloar Guest

    Default Re: File & Printer Sharing Gets Unchecked Every Time I Reboot

    Thanks, Watcher.

    I found Firewall/Internet Connection Sharing Services set to Automatic, so I stopped and disabled it. The Server service s was already set to automatic.

    I rebooted. Windows came up with file and printer sharing turned off again. So I turned it back on and rebooted again.

    Windows is continuing to start up with file and printer sharing unchecked.

    Anything else I can try?

  4. #4
    watcher Guest

    Default Re: File & Printer Sharing Gets Unchecked Every Time I Reboot

    Dear btreloar:

    I thought for sure it was the service as the behavior occurred on boot. By default, File and Printer Sharing for Microsoft Networks is bound on all network interfaces. According to Windows XP Professional Resource Kit, 3rd edition, ways to prevent other computers from sharing your files include: 1)unbinding the protocol manually by unchecking it in Local Area Connection; 2)stopping the Server service; 3)activating the Windows Firewall; 4)editing the Registry, specifically, HKLM\System\
    CurrentControlSet\Services\NetBT\Parameters, Value Name-TransportBindName, and deleting its Data Value.
    This is informational only. Please check this Registry subkey and post the Data Value for TransportBindName.

    Also, check Local Area Connection Properties, double click Internet Protocol(TCP/IP), click the Advanced button on the General tab, go to the WINS tab, and, under NetBIOS setting section, let me know which of the 3 options is enabled.

    One more thing. Do your shared folders show up in Computer Management-Shared Folders-Shares?

    WATCHER

  5. #5
    btreloar Guest

    Default Re: File & Printer Sharing Gets Unchecked Every Time I Reboot

    Thanks, Watcher,

    The value for TransportBindNema is /Device/

    I may have to do the rest on Sunday -- we're out of town at the moment and I'm connected wirelessly right now. In case it helps, here's what I find:

    Wireless connection properties shows File & Printer Sharing on. So does the Local Area Connection (surprise!) even though that icon has a red X because it's not connected. NetBios Setting is set to Default.

    In Computer Management | Shared Folders | Shares I have the following shared: Admin$, C$, IPC$, print$, SharedDocs, and TAL C (C). The last is my entire c: drive, which I am intending to share on the network.

    Any clues in any of this?

    Bill

  6. #6
    watcher Guest

    Default Re: File & Printer Sharing Gets Unchecked Every Time I Reboot

    Dear btreloar:

    I'm confused now. In your first post, you stated that it was your Local Area Connection where File and Printer Sharing for Microsoft Networks was turning off when you booted up and it appeared this was the connection you were using because you stated it worked fine after you enabled it manually. Now you state that Local Area Connection is not connected and that you are using the Wireless Network Connection for file and printer sharing.

    WATCHER

  7. #7
    btreloar Guest

    Default Re: File & Printer Sharing Gets Unchecked Every Time I Reboot

    Hi, Watcher,

    Thyat's because I'm not in my home office now -- which is why I said we may have to pick this up again on Sunday or Monday when I'm back. Here on vacation, I only have wireless connectivity. On Sunday I'll be back home and will once again be connected to my normal local area connection - the one that's giving me trouble.

    Hope that clarifies ...
    Bill

  8. #8
    watcher Guest

    Default Re: File & Printer Sharing Gets Unchecked Every Time I Reboot

    Dear btreloar:

    Acknowledged. When you get back home, try disabling your Wireless Network Connection in Network Connections. To do this, right click it and then click Disable. Make sure the protocol, File and Printer Sharing for Microsoft Networks is checked and then reboot to see if this might work. You can always enable Wireless Network Connection later on.

    Other than that, I can't think of why it is doing that.

    WATCHER

  9. #9
    btreloar Guest

    Default Re: File & Printer Sharing Gets Unchecked Every Time I Reboot

    Thanks, Watcher,

    I have a switch on my laptop that enables or disables the wireless network connection -- I turned it off, as I don't use that in my home office. I plugged my laptop into the docking station and turned it on -- File & Printer Sharing is again unchecked.I checked it and confirmed it's working fine.

    Then I rebooted and confirmed that Windows came up with File and Printer Sharing unchecked again.

    There's GOT to be something misconfigured somewhere . . . right?

    Bill

  10. #10
    watcher Guest

    Default Re: File & Printer Sharing Gets Unchecked Every Time I Reboot

    Dear btreloar:

    From the behavior, yes, and I think it is a service. The reason being is that if a needed service is not set to Automatic then it will fail to load at bootup. These settings also exist in the Registry, specifically HKLM\
    CurrentControlSet\Services. On mine, I have the minimum number of services running and, even with Server service disabled, my Local Area Connection still has File and Printer Sharing for Microsoft Networks enabled. I also have all my wireless services disabled as well as Wireless Network Connection disabled as I don't use it.

    I guess you'll have to continue doing your workaround unless someone on the forum would have an answer or you somehow figure it out using trial and error methods.

    WATCHER

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •