Results 1 to 10 of 10

Thread: Upgraded to latest free ZA firewall and now get Active X message on some pages

  1. #1
    janibeth Guest

    Default Upgraded to latest free ZA firewall and now get Active X message on some pages

    Yesterday, I upgraded to the latest ZA firewall.

    Now I'm getting a message about ActiveX in a yellow strip at the top of my screen:
    "Your security settings do not allow web sites to use ActiveX
    controls installed on your computer.
    This page may not display correctly.
    Click here for options....."

    I've clicked on the options block and "enabled" the settings I was directed to.....under Tools, Internet Options, etc....but that did no good.
    I still get the message.

    What did ZA change in my settings that has caused this message to appear?
    How can I fix it?
    Should I fix it?
    How can I disable that message if I choose not to make changes in my security settings?
    Thanks so much.

    Operating System:Windows XP Home Edition
    Software Version:6.0
    Product Name:ZoneAlarm (Free)

  2. #2
    watcher Guest

    Default Re: Upgraded to latest free ZA firewall and now get Active X message on some pages

    Dear janibeth:

    I have ZAPRO not ZA free. In ZAPRO, it is found in the Privacy panel, Main tab. Click the Custom button for Mobile Code Control. In the Custom Privacy Settings dialog box, make sure the 3rd option, Block embedded objects(java,
    ActiveX), is UNchecked and click OK. This is a global setting that affects all websites. To do it for your specific website only, go to the Site List tab in the Privacy panel, add the site here and give a green checkmark
    (Allow) under the Mobile Code column for this entry.

    The yellow strip at the top of your screen is an Internet Explorer(IE) warning. It, too, can block ActiveX. To allow ActiveX for your specific website, add it to the Trusted Sites. Click Tools menu, Internet Options, and from the Internet Options dialog box, click the Security tab. Click Trusted sites, then the Sites button, type in the URL, then click Add and OK. The global settings for IE are found in the same tab. Click Internet, then lower the slider control to Medium which will allow signed ActiveX controls but not unsigned ones. Click the Custom button and you will find the ActiveX settings on the 2nd category,
    ActiveX controls and plug-ins. Change your settings to your preference and click OK.

    Hope this helps.

    WATCHER

  3. #3
    Join Date
    Dec 2002
    Location
    Mikado Michigan
    Posts
    2,596

    Default Re: Upgraded to latest free ZA firewall and now get Active X message on some pages

    That yellow strip is a warning from the browser, not from ZA. ZA will give you a popup in the lower right hand corner when privacy settings interfear with something. Check your browser settings, they can be adjusted.
    My homes are SpywareHammer.com and DonHoover.net and BleepingComputer.com


    Consumer Security - 2011 & 2012

    Tilting at windmills hurts you more than the windmills.
    -From the Notebooks of Lazarus Long
    Senior of the Howard Families

  4. #4
    janibeth Guest

    Default Re: Upgraded to latest free ZA firewall and now get Active X message on some pages

    Thanks for your response.
    I've used ZA for some time now, and I'm familiar with the little pop-up boxes in the lower right hand corner of my screen.
    I also know that the yellow strip is a warning from my browser and not from ZA.
    HOWEVER....I did not get the yellow strip warnings until immediately after I upgraded to the latest version of ZA....so I think ZA changed a setting somewhere during the upgrade and I can't figure out which setting was changed or what to do about it!



  5. #5
    janibeth Guest

    Default Re: Upgraded to latest free ZA firewall and now get Active X message on some pages

    Thanks so much for taking time to reply to my post.
    I wish I could say that my problem is solved, but I'd be lying.
    I'm aware that the yellow strip warning is coming from my browser....and I'm certain that upgrading to the newest free version of ZA changed a setting somewhere in my browser that's causing the warning to appear.
    I "know" that because I started getting the warning immediately after the upgrade.
    I tried to follow your instructions....went to the list of ActiveX controls and changed most of them to disable...restarted my PC....still got the warning strip.
    Moved the little slider controler from Med Hi to Med and restarted my PC....still get the warning strip.
    Basically, I'd like to prevent ALL ActiveX activity on my PC, but I guess I don't know how.
    (The warning I'm getting is not about something I'd like to figure out how to allow.)

    So far, I've received the yellow strip warning only on one site....unfortunately it's a site I spend quite a bit of time on, and the warning and the sound that accompanies it are driving me nuts.

    So...thanks once again for your help.
    I'll keep trying to figure it out.....

  6. #6
    Join Date
    Dec 2002
    Location
    Mikado Michigan
    Posts
    2,596

    Default Re: Upgraded to latest free ZA firewall and now get Active X message on some pages

    Active X controls are accessed by going into the custom level in the security settings in Internet options in windows.But if you are wanting to stop all active X, then you are already setup. Or do you want to not get the warning at all? I guess I am confused on what you are wanting to happen.
    My homes are SpywareHammer.com and DonHoover.net and BleepingComputer.com


    Consumer Security - 2011 & 2012

    Tilting at windmills hurts you more than the windmills.
    -From the Notebooks of Lazarus Long
    Senior of the Howard Families

  7. #7
    janibeth Guest

    Default Re: Upgraded to latest free ZA firewall and now get Active X message on some pages

    Thanks for replying again.
    I'll try to be as plain as possible with my response.
    I'm very wary of ActiveX and would be happy to not have it activated
    at all
    on my PC.
    (I'm not sure what you mean when you say that if that's what I want I'm "already set up.&quot
    If that were the case, there'd be no warning....right?


    I really really really want to STOP that warning from popping up!

    If you can tell me how do to that, I'll be a happy camper.


  8. #8
    Join Date
    Dec 2002
    Location
    Mikado Michigan
    Posts
    2,596

    Default Re: Upgraded to latest free ZA firewall and now get Active X message on some pages

    OK now we are on the same page. Currently you have the setup that will prevent ActiveX scripts from running. If you had ZAISS or ZAP you could turn off the protection in the browser, and turn it on in the firewall and turn off its notification. I am not aware of any method that the notification bar can be turned off, but I will try and find one. If I do, I will post it up here for you.Sorry I couldn't help more.By the way, did you just upgrade to IE7 ?
    My homes are SpywareHammer.com and DonHoover.net and BleepingComputer.com


    Consumer Security - 2011 & 2012

    Tilting at windmills hurts you more than the windmills.
    -From the Notebooks of Lazarus Long
    Senior of the Howard Families

  9. #9
    janibeth Guest

    Default Re: Upgraded to latest free ZA firewall and now get Active X message on some pages

    Again....thanks for the reply. You're very kind to offer assistance.
    No, I did not upgrade to IE7....still using IE6 and sometimes Firefox.
    I think I may have solved the problem of the pop up warning in the yellow bar.
    I've been reading in Microsoft's support documents, and I went to Tools, Options, Security, Restricted Sites, Custom Level and selected Medium instead of High.
    Makes me a little nervous to do that, but it seems to have stopped the pop up warning about ActiveX.

    So...so you have any opinion or advice about the change I made?

    Do you mind telling me how you feel about ActiveX?
    I've read that it can be dangerous in some situations.
    I do my best to keep my PC secure, and am very conservative about risky behavior where it's concerned.


  10. #10
    Join Date
    Dec 2002
    Location
    Mikado Michigan
    Posts
    2,596

    Default Re: Upgraded to latest free ZA firewall and now get Active X message on some pages

    Active X's are one of those things that can be both bad and good. With the settings that you have, make sure that you have the settings set to prompt you about active x's, and also the setting so that the active X's have to be signed. I do allow some active X's to run on my machine, but I have control over which one's that do.
    My homes are SpywareHammer.com and DonHoover.net and BleepingComputer.com


    Consumer Security - 2011 & 2012

    Tilting at windmills hurts you more than the windmills.
    -From the Notebooks of Lazarus Long
    Senior of the Howard Families

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •