Results 1 to 4 of 4

Thread: ZA 7.0.462 not playing nice with Firefox 2.012

  1. #1
    rayramirez Guest

    Default ZA 7.0.462 not playing nice with Firefox 2.012

    I have been fighting this all afternoon.
    This seems to be a problem frequently when I update Firefox or ZA, that firefox can not access the internet.
    I have restarted the computer, and other things.I am using the free version, and to be honest, I have this much hassle every time I update this, and I am hesitant to use it for work.
    In the Program control>Programs section, firefox is set to trusted in all 4 categories, and I still can not have it find the internet (hooked up through our home setup)
    I tried removing firefox from that part, and it still would not help.
    I tried the Alerts & logs>Log View> and I can see all the times Firefox is trying to access the Internet, I try to right click, but the 'add to zone' is gray out so no option.
    Also in the window section at the bottom , the 'Add to Zone'
    button is grayed out also.
    Any suggestions would be appreciated.Thanks

    Operating System:Windows XP Home Edition
    Software Version:7.0
    Product Name:ZoneAlarm (Free)

  2. #2
    Join Date
    Dec 2005
    Posts
    9,057

    Default Re: ZA 7.0.462 not playing nice with Firefox 2.012

    Set the Program Control slider in the ZA Program Main panel to Medium. See if that makes a difference.

    Open the "Custom" button of the Main of the Program Control and open the "OSFirewall" tab. For the "Change which programs load at startup" entry, left click the value in the "State" column and set it either to "Ask" or "Use Program Setting".

    If you have just experienced this problem since updating the Firefox, then the ZA is still using the old Firefox and not the new Firefox . This often happens when upgrading software such as email clients, browser, security applications and windows updates.
    To resolve this, please delete the "old" Firefox entry in the ZA Program list and then close the ZA. Or any Firefox items listed. Now reboot. Now open the Firefox and the ZA should see the new Firefox, since it no longer has records of any Firefox - new or old. The "new" entry for the Firefox will now again need both access for the trusted and internet zones and server rights for the trusted zone.

    Cheers, Oldsod
    Best regards.
    oldsod

  3. #3
    rayramirez Guest

    Default Re: ZA 7.0.462 not playing nice with Firefox 2.012

    Thanks for the suggestions.The program control is set to medium (when I tried to set to high, it said that is a paid program option.
    In the Program control> Main> Custom> There is no OSFirewall tab - only
    an 'autolock'

    section with radio buttons on: "Lock whenever screensaver activates"
    AndWhen lock engages:"Allow pass lock programs to access the Internet"
    I also did try deleting the Firefox line in the: Program control
    > programs> Firefox, and restarting -
    And I still can't get any web sites with firefox - only IE.
    Interestingly, the check marks are the same on the
    IE line as they are in the Firefox line.
    And I'm still not able to get online with firefox.
    I did also just try shutting down zone alarm, starting firefox, and getting on some sites, and then restarting zone alarm, and once zone alarm was up, the access to the internet stopped.
    Thanks again for your help with this.

  4. #4
    Join Date
    Dec 2005
    Posts
    9,057

    Default Re: ZA 7.0.462 not playing nice with Firefox 2.012

    My mistake. I forgot you have the free and not a pro.

    Okay then. Your comments are helpful.

    The answer should be a database rest of the ZA.[*]Boot your computer into the Safe Mode[*]Navigate to the c:\windows\internet logs folder[*]Delete all of the files found inside the Internet Logs folder[*]Clean the Recycle Bin[*]Reboot into the normal mode[*]ZA will be just like new with no previous settings or data

    Then after the reboot to the normal mode, set the new network found as Trusted. After a few alerts and OK, then do this:

    Make sure your DNS and DHCP server IP's are in your Firewall's Trusted zone. Finding DNS and DCHP servers, etc

    1. Go to Run and type in command and hit 'ok', and in the command then type in ipconfig /all then press the enter key. In the returned data list will be a line DNS and DHCP Servers with the IP address(s) listed out to the side. Make sure there is a space between the ipconfig and the /all, and the font is the same (no capitals).
    2. In ZA on your machine on the Firewall, open the Zones tab, click Add and then select IP Address. Make sure the Zone is set to Trusted. Add the DNS IP(s) .
    3. Click OK and Apply. Then do the same for the DHCP server.
    4. The localhost (127.0.0.1) must be listed as Trusted.
    5. The Generic Host Process (svchost.exe) as seen in the Zone Alarm's Program's list must have server rights for the Trusted Zone.
    Plus it must have both Trusted and Internet Access.

    Extra help is found at Guru Hoov site for the DNS/DHCP.

    The Firefox should work okay now.
    Cheers, Oldsod
    Best regards.
    oldsod

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •