Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23

Thread: taskmgr.exe trying to connect to the Internet

  1. #11
    holtxa Guest

    Default Re: taskmgr.exe trying to connect to the Internet

    Thanks, Bill.

    I'll try it tonight and post what I find here.

    I haven't registered at Castle Cops before. When I do, I'll use holtxa... the same user name I have here.

    Cheers,
    Andrew

  2. #12
    holtxa Guest

    Default Re: taskmgr.exe trying to connect to the Internet

    I found at least part of the problem....By following the Malware Removal instructions at CastleCops... when I ran Ewido Security, it discovered and removed Backdoor.SdBot.aad, along with a file tkkc8l.exe which was the one that keep re-installing the fake taskmgr.exeThanks very much for the tips.It's frustrating that my up-to-date Norton Antivirus didn't prevent this infection... and indeed said my system was clean when it wasn't.Cheers,Andrew

  3. #13
    billc Guest

    Default Re: taskmgr.exe trying to connect to the Internet

    Hey Andrew. Thank you for reporting back; I was interested in what sort of nasty was causing this behavior. Unfortunately, a single program like Norton can't get all the stuff that is lurking on the internet. I too use Norton but practicing 'safe computing' is always the number one defense. Anyway, I'm glad it is resolved. Nice to know that if you do get an infection into your machine, Zone Alarm will not let it out.

  4. #14
    holtxa Guest

    Default Re: taskmgr.exe trying to connect to the Internet

    Thanks again for all your suggestions, Bill. I thought I was pretty savvy on this stuff... but you showed me some new resources.

    Unfortunately, while zapping that "taskmgr.exe" stopped it from trying to send info out... I'm still having trouble getting the (formerly) infected computer to allow file sharing with the other computer on the home network. I thought maybe the issues were related since they cropped up at the same time, but cleaning the infection hasn't restored the local network access issue.

    Both computers can access the Internet through the router just fine, and the ThinkPad can see shared folders on the Vaio desktop... but the Vaio suddenly can't access shared folders on the ThinkPad. I keep getting a logon error message.

    I've checked the firewall settings... workgroup... computer names, etc. No luck so far. arrgh.

    Cheers,
    Andrew

  5. #15
    billc Guest

    Default Re: taskmgr.exe trying to connect to the Internet

    Do you have your Trusted Zone security slider on 'Medium'? (It will not allow file-sharing on High)

  6. #16
    holtxa Guest

    Default Re: taskmgr.exe trying to connect to the Internet

    Yes... and I don't think I've made any recent changes to the network or file sharing. It's been working fine for the last couple of years... so I assumed the problem was related to the infection... but now it's looking more like maybe a coincidence.

  7. #17
    billc Guest

    Default Re: taskmgr.exe trying to connect to the Internet

    If you shutdown Zone Alarm, can you then file-share? Can I assume you have your LAN in the Trusted zone? And the IP of each computer in the Trusted zone of the other? And as strange as it may sound, do an ipconfig in a command prompt in each computer to confirm you have the right address.

  8. #18
    holtxa Guest

    Default Re: taskmgr.exe trying to connect to the Internet

    No, shutting down ZA doesn't affect it.

    I brought home my laptop from work. It has XP Home. It can connect to the Vaio desktop and the Vaio desktop can connect to it. But neither computer can see files on the ThinkPad... although the ThinkPad can access shared folders on both the other computers.

    All the computers are in the Trusted zone when ZA is on.

    I wonder if the infection changed some registry values related to network permissions? I've seen that issue mentioned on CastleCops.

    Should I try a System Restore to a time before I first saw signs of the infection two days ago?

    Cheers,
    Andrew

  9. #19
    billc Guest

    Default Re: taskmgr.exe trying to connect to the Internet

    System Restore is often a life saver. A couple questions. Were you able to file share at some point before the infection? Are you sure you've removed the infection in it's entirety and will not "restore" it with a system restore? If you can answer yes to both of these than there would be no harm in trying a system restore.

    If setup and testing purposes while you are on your home LAN behind a router, I'd suggest you uncheck the 'load Zone Alarm at startup' option in the Overview > Preferences panel of Zone Alarm, reboot, and then you are sure the firewall has not loaded. Just don't forget to turn the option back on. Before you bring ZA back into the mix, see if you can get the file sharing to work.

  10. #20
    holtxa Guest

    Default Re: taskmgr.exe trying to connect to the Internet

    Rebooting without ZA didn't change anything. I can see the ThinkPad listed on the Network, but can't access any of the shared folders. The ThinkPad has access to the other computers just fine.

    I went into the adminstrator settings of XP Pro on the ThinkPad and entered "Everyone" into the permission to access the compter from the network. But all that did was change the error message from can't use this logon type to "Access is denied."

    Then I tried System Restore... but it failed at every restore point from the day before the infection to the oldest one four days before the infection.

    - Andrew

Page 2 of 3 FirstFirst 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •