Results 1 to 8 of 8

Thread: WMI is trying to remove a driver or service

  1. #1
    oldshep Guest

    Default WMI is trying to remove a driver or service

    For the last couple weeks, I've been getting a warning on startup as follows: WMI is trying to remove a driver or service: Eventlog\Application\Microsoft H.323 Telephony service provider. Prior to this I had a problem with updating Zone alarm to the latest release (6.5.722.000) via the internet. I finally had to removeexisting Zone alarm softwareand reload the updated software (some of the old files weren't removable even in safe mode). The only other thing I've done is update MS Office at which time the "SQL Server ???" program was installed. Anyone have a clue as to what the problem might be? It doesn't seem to matter whether I allow or disallow the action. It reappears each time I restart. Another thing is that the windows music "skips" during startup - maybe unrelated. System particulars are Windows XP Pro, SP2, Zone alarm internet security suite 6.5.722.000. Thanks in advance for any suggestions. Oldshep

    Operating System:Windows XP Pro
    Product Name:ZoneAlarm Internet Security Suite
    Software Version:6.5

  2. #2
    flyyourway Guest

    Default Re: WMI is trying to remove a driver or service

    First off , lets try and narrow a few things down.Do you use a dial up connection?Do you use a Voice over IP provider at all? The reason I am asking is if you use DSL or Cable then the Telephony service should be disabled within your services as it isnt needed to startup with your PC,unless of course you do use a VOIP service provider as most may use the H.323 protocol.Now if your answer to this is you dont then I would recommend a system scan with a Virus scanner as something may have gotten onto your system and is causing havoc.Get back and let us know.

    Online scanner
    Trends Housecall

  3. #3
    oldshep Guest

    Default Re: WMI is trying to remove a driver or service

    FlyYourWay - Thanks for the response. I don't use dial up. I recently (2 months ago) changed from cable to Verizon Fios internet service. I guess since my phone lines are connected on the same fiber optic cable, maybe I do have VOIP. I never thought of that before. I ran the Trends Housecall Scan you recommended as well as an over the internet scan from Symantec. Both came back clean. One other bit of info... this morning (for the first time) I got an error message on startup saying something like "Antivirus/Antispyware panel failed to start". This was contained in a pop-up message box with no other identifying info. I thought it was a windows message. When I opened Zone alarm, sure enough the antivirus / Antispyware selection was unavailable on the left hand side of the overview panel. I restarted the computer and everything seems to be ok now. Any other suggestions would be appreciated.Oldshep

  4. #4
    flyyourway Guest

    Default Re: WMI is trying to remove a driver or service

    Sounds like ZA may be corrupted,have you tried re-installing the whole application yet? If not I would give that a try,switching Internet service provider can cause this at time,this can cause the ZA database to go corrupted,but it seems like the whole application may have been corrupted somehow.This is the first step I would take to see if it resolves the issue you been having.Get back to us and let us know if it resolves the issues at hand.

  5. #5
    oldshep Guest

    Default Re: WMI is trying to remove a driver or service

    FlyYourWay. I think maybe you're right about ZA being corrupted. When I had the original problem after updating to ZA 6.5 over the internet, I called the tech support people and they said I would have to go in and manually remove the existing ZA files in safe mode. While doing this, I found a couple of files couldn't be removed even in safe mode. After several calls to tech support (and some $35 later), they said "well remove everything you can then reinstall the software" which I did. So maybe the files I couldn't remove are still causing problems. But the question is how do I go about re-installing ZA this time? Do I use windows "ADD/Remove Programs" or do I need to try manually removing files in safe mode again... I might try giving ZA tech support another chance. The thought of reformatting and reloading windows is too terrible to face.Thanks again for your help.Oldshep

  6. #6
    flyyourway Guest

    Default Re: WMI is trying to remove a driver or service

    If ZA is installed now,which of course I believe it is then use this method first /CLEAN click on that link and it will take you to one of their pages which will walk you thru the clean uninstall,now after that is done you will need to probably follow the manual uninstalldirections.Following both instructions to a T will most likely clear up all your current problems.Make sure you do all this with your Internet connection being disabled,don't leave yourself vulnerable while following these steps.Get back and let us know if this works.

  7. #7
    kiddpeat Guest

    Default Re: WMI is trying to remove a driver or service

    I just went through that. I found that running the ZA uninstall will remove the troublesome files. After that, go in and perform the final clean up.

  8. #8
    oldshep Guest

    Default Re: WMI is trying to remove a driver or service

    FlyYourWay, kiddpeat. I went ahead and made an attempt before I had a chance to read your posts. This time, I used windows add/remove programs first. Then I started in safe mode and deleted the files per the instructions I had received from ZA tech support a few weeks ago. There were still several files in the windows/System32 folder which Ihad to deletealong with a couple registry entries. All the files deleted this time without problems. I then re-installed from my original CD (V6.0?). When it started up, it immediately went to update virus definitions. Immediately after this I got a warning on a windows component which I allowed then the computer locked up. I had to unplug to restart. After this, I restarted and downloaded the system update 65.722.000 and ran that. After restart again, it began a virus scan but again became locked up during the scan (it was checking 1 file for 5 minutes or so). While that was going on I tried to launch Internet explorer but that locked up my whole computer again and I had to unplug to restart. On the next restart, It successfully completed the virus scan and I am now able to access the internet. I restarted one more time andI don'tsee any more problems so far. No more "WMI is trying to remove a driver or service" warnings and as an extra bonus, the windows startup music is now playing normally. Thanks very much for your assistance with this issue. I'll post again if anything else noteworthy takes place.Oldshep

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts