Results 1 to 5 of 5

Thread: Generic Host Process Win32 Services blocked access to DNS service

  1. #1
    davidbassplayer Guest

    Default Generic Host Process Win32 Services blocked access to DNS service

    On the Zone Alarm Control Center, Alerts and Logs, Log Viewer tab, I have a full page of notices that svchost.exe using IP source 192.168.1.47:xxxx where xxxx is 1032, 1117, 1254, etc. tried to access 192.168.1.1 port 53 (The DNS server, according to ipconfig/all, is the router, 192.168.1.1)


    Operating system = Windows XP Professional, SP2, all updates installed,
    net access via Verizon DSL, modem/router Westel 327.
    Norton Corporate AV, System Mechanic 7 Professional for system maintenance, and free Zone Alarm firewall.


    I get lots and lots of notices like this.


    ZoneAlarm blocked Generic Windows services from access to port 53 on a DNS server.

    I clicked "more information" and gleaned this from that page:


    Source IP Address: 192.168.1.xxx (The DSL router)
    Source Port: 1254, also Source Port: 1331 and others
    Destination IP: 192.168.1.1
    Destination Port: 53
    Program Name: Generic Host Process for Win32 Services
    File Name: svchost.exe

    I would like to stop these notices, either by granting access, or once I know why access is a bad idea, then turn the notices off.

    Many thanks

    Operating System:Windows XP Pro
    Software Version:7.0
    Product Name:ZoneAlarm (Free)

  2. #2
    zaswing Guest

    Default Re: Generic Host Process Win32 Services blocked access to DNS service

    Your computer 192.168.1.47 wishes to speak to the router 192.168.1.1 which is your DNS server to get you to the internet. So, please put the router in the trusted zone and for Generic Host process give it 3 checks (2 access and one trusted server). Also add local host address 127.0.0.1 to the trusted zone. If you've done all that already, then the answer might be in the settings behind the zones, but I can't recall whether ZA free has that. Also, in ZA free, I assume ZA correctly detects the network with the subnet /255.255 ... and calls it network adapter or something like that, correct?

  3. #3
    davidbassplayer Guest

    Default Re: Generic Host Process Win32 Services blocked access to DNS service

    Your remark:

    Your computer 192.168.1.47 wishes to speak to the router 192.168.1.1 which is your DNS server to get you to the internet. So, please put the router in the trusted zone and for Generic Host process give it 3 checks (2 access and one trusted server). Also add local host address 127.0.0.1 to the trusted zone.

    If you've done all that already, then the answer might be in the settings behind the zones, but I can't recall whether ZA free has that.

    Also, in ZA free, I assume ZA correctly detects the network with the subnet /255.255 ... and calls it network adapter or something like that, correct?


    >> You say: Your computer 192.168.1.47 wishes to speak to the router 192.168.1.1 which is your DNS server to get >> you to the internet.

    Almost every thing works exactly as I expect. I have access to the internet from all my programs, but there is this notice that pops up from time to time about Generic Windows Services, svchosts.exe, being denied DNS service from the IP number of the router, port 53, which is the DNS service from the DSL router/modem. This does not seem to cause any difficulty with anything. I want to know why it is occurring and how to stop it.

    Specifically, windows generic services wishes to DNS service from the router.

    >> So, please put the router in the trusted zone and for Generic Host process give it 3 checks (2 access and one >> trusted server). Also add local host address 127.0.0.1 to the trusted zone.

    Both 127.0.0.1 and 192.168.1.1 are in the ZA Control Center, Firewall section, zones tab, in the trusted zone.

    I do not know how to give the DSL Router checks. That seems to be for programs, in the program control section. Please explain.


    >>If you've done all that already, then the answer might be in the settings behind the zones, but I can't recall >> whether ZA free has that.

    Where do I look? What does "behind the zones" mean?


    >>Also, in ZA free, I assume ZA correctly detects the network with the subnet /255.255 ... and calls it network >> adapter or something like that, correct?

    I didn't see anything like that, but I could easily have missed that, though I have looked carefully.

    Thanks for your reply and please help me further.

  4. #4
    zaswing Guest

    Default Re: Generic Host Process Win32 Services blocked access to DNS service

    You're close. Just see if what follows gets you there to the end.
    Generic host services permission to be a server in the trusted zone is done on the Program control panel. Just 3 green checks from the left. The alerts will stop when you do it, unless DNS values are not in the trusted zone.
    To find DNS values which the DSL modem gives, Press Start, then Run, then type cmd.
    On the black command window type ipconfig /all - don't miss the space before the slash.
    The listing will show one, but more likely two, IP numbers for DNS. Just copy those numbers into the Trusted zone. So find the Add button, and for each DNS, select IP address, type one in, call it anything you want. DNS1, DNS2 are as good as anything.
    The last cryptic advice from me was about the adapter. Most likely it's working just fine and the entry is already there in the trusted zone, as that's your current network. Very likely it says something like Adapter...subnet 192.168.1.47/255.255.255.xxx (where I don't recall whether they do 255
    or zero where xxx is). The common local network number is 192.168.1.0/255.255.255.0 but ZA free does something slightly different.
    If it doesn't do the job, please post the entire output from the ipconfig command, so we can take a look.

  5. #5
    davidbassplayer Guest

    Default Re: Generic Host Process Win32 Services blocked access to DNS service

    You write

    You're close. Just see if what follows gets you there to the end.

    OK, thanks.


    You write:
    Generic host services permission to be a server in the trusted zone is done on the Program control panel. Just 3 green checks from the left. The alerts will stop when you do it, unless DNS values are not in the trusted zone.


    Ahh It is RIGHT THERE in the programs section. I gave it a green check as a server in the trusted zone, a ? in the internet zone. OK?

    You write:
    To find DNS values which the DSL modem gives, Press Start, then Run, then type cmd.
    On the black command window type ipconfig /all - don't miss the space before the slash.
    The listing will show one, but more likely two, IP numbers for DNS. Just copy those numbers into the Trusted
    zone. So find the Add button, and for each DNS, select IP address, type one in, call it anything you want.
    DNS1, DNS2 are as good as anything.


    I have done that, and the IP numbers are in the Firewall section, trusted zone.


    You continue:
    The last cryptic advice from me was about the adapter. Most likely it's working just fine and the entry is already there in the trusted zone, as that's your current network. Very likely it says something like Adapter...subnet 192.168.1.47/255.255.255.xxx (where I don't recall whether they do 255 or zero where xxx is). The common local network number is 192.168.1.0/255.255.255.0 but ZA free does something slightly different.


    The adapter is in there, but it is in the Firewall Section, not the programs section, with the ip number you give here.


    You continue:
    If it doesn't do the job, please post the entire output from the ipconfig command, so we can take a look.

    I'll see if putting the checks on the "Generic Windows Services" as server won't fix the message.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •