Results 1 to 6 of 6

Thread: Corruption of BACKUP.RDB - any advice please.

Hybrid View

  1. #1
    randygaus Guest

    Default Corruption of BACKUP.RDB - any advice please.

    I seem to, fairly regularly, get a popup appearing on my Windows XP SP2 machine.
    I get multiple occurrences of:
    Event Type: Information
    Event Source: Application Popup
    Event Category: None
    Event ID: 26
    Date: 30/10/2007
    Time: 5:10:38 PM
    User: N/A
    Computer: PIII
    Description:
    Application popup: Windows - Corrupt File : The file or directory G:\WINNT\Internet Logs\BACKUP.RDB is corrupt and unreadable. Please run the Chkdsk utility.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    I do schedule and run the chkdsk and allow Windows to do whatever it has to but, sooner or later (at least once a fortnight) I'll get this to happen again and I have no idea why.

    I've got 1.25 GB free on the drive with the files.

    Do I simply boot to safe mode and delete the files in that Internet Logs directory and start again or does anyone have any better suggestions for trying to debug and capture the causes.

    I THINK that the updclient program is running but can't say for sure. I'll have to wait for this to happen again.

    Oh well. Send this off, reboot, let chkdsk do its thing and away we go again.

    Thanks for any helpful suggestions.

    Operating System:Windows XP Pro
    Software Version:7.0
    Product Name:ZoneAlarm Internet Security Suite

  2. #2
    watcher Guest

    Default Re: Corruption of BACKUP.RDB - any advice please.

    Dear randygaus:

    Open ZAISS, navigate to Overview panel, Preferences tab, and in the General section uncheck load at startup.

    Reboot into Safe Mode. Open Windows Explorer or another file manager, navigate to C:\WINDOWS\Internet Logs. Delete all resident files with these extensions: .RDB, .ldb, and .tmp. If you deleted these to the Recycle Bin, empty that now. This will reset the ZA configuration database removing all your custom settings. Reboot back into Normal mode. Open ZAISS and it will have its default settings as it was when you first installed it.

    Navigate back to Overview panel, Preferences tab, and put back the checkmark for it to load at startup.

    Hope this helps.

    WATCHER

  3. #3
    randygaus Guest

    Default Re: Corruption of BACKUP.RDB - any advice please.

    Hi Watcher,

    Thanks for this info, however, I've done this before and this "corruption" seems to have happened again.

    It isn't difficult to re-customise ZISS but it would be nice to stop the corruption from happening in the first place.

    I guess I'll have to keep track of what's happening if/when it happens again and see if there is a pattern to it.

    Thanks again for your input/feedback.

  4. #4
    watcher Guest

    Default Re: Corruption of BACKUP.RDB - any advice please.

    Dear randygaus:

    You're welcome and you are right that it would be nice to prevent this from happening in the first place. Yours is not an isolated occurrence and there are numerous posts where the configuration database was corrupted. There has been speculation that BSODs and other crashes cause this but nothing definitive. I have ZAPRO and have never experienced this(yet), despite having experienced many BSODs and other crashes/lockups.

    It's a good idea to keep track of this. Keep a written log and, if you find a solution, please post it.

    WATCHER

  5. #5
    randygaus Guest

    Default Re: Corruption of BACKUP.RDB - any advice please.

    Hi WATCHER,

    I may have found something related to the corruption problem but I'm not sure why this is happening, if, indeed, this is a cause.

    I occasionally run a tool called FILEMON from www.sysinternals.com. I SEEM to get the "corruption" of backup.rdb when this tool is running and "monitoring" file usage. I see from the sysinternals webpage that filemon was replaced by procmon so I'll try to use this instead and see if the problem occurs again.

    Unfortunately, it isn't something that happens EVERY time I run filemon so itmust be in combination with something else. For example, I'm also backing up the contents of a 2GB SD chip, connected via a chip reader, to my hard drive via simple copy/paste. I've got an external disk drive, a PDA and a satnat connected via a USB hub so it could also be something to do with this as well.

    I'll have to do some further "debugging" to see exactly what is going on at the time but thought I'd mention this to keep the thread alive.

    Regards.

  6. #6
    jamworld Guest

    Default Re: Corruption of BACKUP.RDB - any advice please.

    Is this thread still alive?
    I have been going out
    of my mind.
    Everytime I restart, WinXP wants to run CHKDSK - after running it with /R
    switch, things
    should be fixed - but within a short while DISKEEPER 2008 stops running because it says a program has enabled CHKDSK
    on the drive.
    Sure enough checking the Event Viewer:
    <blockquote>Source: Ntfs
    Category Disk
    Type: Error
    Event ID 55The file system structure on the disk is corrupt and unusable. Please run the chkdsk utility on the volume C:.</blockquote>
    And everytime I simply run chkdsk in a Command Prompt to see what the trouble is...
    It's the index entry for BACKUP.RDB!
    Believe me, this drive is in good shape.


    I've run every test available.
    CHKDSK should fix it - but the fix will last only as long as I can organize my thoughts.
    The next time I run any program that cares, like Diskeeper, it says I need to run chkdsk.


    In addition to this corruption notice everyday I see a string of errors like this in the Applications section of Event Viewer from the indexing service:
    <blockquote>Source: CiCategory Ci ServiceError ID 4101
    The content index filter for file &quot;c:\windows\internet logs\zalog2008.01.22.txt&quot; generated content data more than 8 times the file's size.</blockquote>

    The actual zalog file is of course different each time.
    On any given day there will be a string of 8 to 10 of these errors right after one another - I guess - until the indexing service gives up and marks the drive as dirty.
    I have completely wiped ZAPro off the disc and reinstalled several times
    Though I have always gotten the Ci error with a ZALOG content 8 times the file's size for years now (which I was told to ignore)

    not until now has it
    ever triggered any problems or a
    chkdsk repair.



    What's the fix.
    What more can do but delete the logs or completely remove and reinstall ZAPro?
    None of that works.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •