I keep getting "ZoneAlarm Security Alert" "Protected" message popups bearing the IP of another computer (or is it the router?) of my small home network. Here's the exact message:

================================================== =====================

ZoneAlarm Security Alert
Protected

The firewall has blocked Internet access to your computer (NetBIOS Session) from 192.168.1.101 (TCP Port 1138) (TCP Flags: S)

(then it gives the time and date)

at the bottom it has a checkbox: "Don't show this dialog again".

================================================== =====================

I'd LIKE to just check that checkbox, but I'm afraid it will then no longer show me any alerts, no matter what the IP address is, and I don't want that. I want to block the message for just the one IP (or a range of IPs). Can I do that, and how?

TIA

Operating System:Windows XP Pro
Software Version:7.0
Product Name:ZoneAlarm Pro