Results 1 to 9 of 9

Thread: Hi, My problem is with the TrueVector Service. I have see...

  1. #1
    kennygman Guest

    Default Hi, My problem is with the TrueVector Service. I have see...

    Hi, My problem is with the TrueVector Service. I have seen several post with this same problem and am wondering is this is happing with a lot others. I at first thought I was going crazy and see that others have the same problem. For some reason, TrueVector stops letting me access the internet and places a red box, Yellow X' and says TrueVector Service has stopped. Opening the program it says "System error, please reboot". I have changed nothing, nor added anything to my system. Any suggestions would be helpful. Thx.


    KennyGman

    Operating System:Windows XP Home Edition
    Software Version:7.0
    Product Name:ZoneAlarm Internet Security Suite

  2. #2
    scared_again Guest

    Default Re: Hi, My problem is with the TrueVector Service. I have see...

    That makes 2 of us. Mine started doing the same thing this morning.

  3. #3
    hammernu Guest

    Default Re: Hi, My problem is with the TrueVector Service. I have see...

    First, try a database reset. You will lose all the settings changes that you've made:
    Strange behavior in ZoneAlarm: reset database



    New way (starting with 7.0.462.0) (doesn't require Safe Mode)

    1) Ctrl + Shft right-click (ZA System Tray icon)

    2) Click Reset in popup box

    3) Click Yes in Reset Settings dialog box

    4) Click OK when prompted to reboot

    5) Follow onscreen prompts



    OR (old way):

    1) Boot computer into Safe Mode

    2) Navigate to "C:\Windows\Internet Logs" folder

    3) Delete BACKUP.RDB, IAMDB.RDB, *.ldb, tvDebug.log files

    4) Empty Recycle Bin

    5) Reboot into Normal Mode

    6) Reapply all settings that had previously been changed

    If that doesn't work, you will need to download the latest version and do a clean uninstall followed by a re-install:
    Download ZASS 7.0.473.000 from here:
    http://download.zonealarm.com/bin/fr...473_000_en.exe
    UNINSTALL
    --------------
    Append " /clean /rmlicense" (without quotes) to ZoneAlarm uninstall shortcut target
    Reboot Safe Mode (without networking)
    Uninstall ZoneAlarm from shortcut
    Reboot Safe Mode (without networking): reboot requested by ZoneAlarm
    Create file ZADelete.bat and edit with Notepad
    Copy and paste the following lines into ZADelete.bat, then save and exit:
    RMDIR /S /Q "%PROGRAMFILES%\Zone Labs"
    RMDIR /S /Q "%SYSTEMROOT%\Internet Logs"
    RMDIR /S /Q "%SYSTEMROOT%\system32\ZoneLabs"
    ECHO Y | DEL /F "%TEMP%\*"
    ECHO Y | DEL /F "%SYSTEMROOT%\Temp\*"
    ECHO Y | DEL /F "%SYSTEMROOT%\Prefetch\*"
    ECHO Y | DEL /F "%SYSTEMROOT%\system32\vsconfig.xml"
    ECHO Y | DEL /F "%SYSTEMROOT%\system32\vsdata.dll"
    ECHO Y | DEL /F "%SYSTEMROOT%\system32\vsdata95.vxd"
    ECHO Y | DEL /F "%SYSTEMROOT%\system32\vsdatant.sys"
    ECHO Y | DEL /F "%SYSTEMROOT%\system32\vsinit.dll"
    ECHO Y | DEL /F "%SYSTEMROOT%\system32\vsmonapi.dll"
    ECHO Y | DEL /F "%SYSTEMROOT%\system32\vspubapi.dll"
    ECHO Y | DEL /F "%SYSTEMROOT%\system32\vsregexp.dll"
    ECHO Y | DEL /F "%SYSTEMROOT%\system32\vsutil.dll"
    ECHO Y | DEL /F "%SYSTEMROOT%\system32\vswmi.dll"
    ECHO Y | DEL /F "%SYSTEMROOT%\system32\vsxml.dll"
    ECHO Y | DEL /F "%SYSTEMROOT%\system32\zlcomm.dll"
    ECHO Y | DEL /F "%SYSTEMROOT%\system32\zlcommdb.dll"
    ECHO Y | DEL /F /AH "%SYSTEMROOT%\system32\z?lictbl.dat"
    ECHO Y | DEL /F "%SYSTEMROOT%\system32\zpeng24.dll"
    :
    PAUSE
    Double-click ZADelete.bat
    Create file ZADelete.reg and edit with Notepad
    Copy and paste the following lines into ZADelete.reg, then save and exit:
    REGEDIT4
    [-HKEY_CLASSES_ROOT\ZAMailSafe]
    [-HKEY_CURRENT_USER\Software\Zone Labs]
    [-HKEY_LOCAL_MACHINE\Software\Zone Labs]
    [-HKEY_USERS\.DEFAULT\Software\Zone Labs]
    [-HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\vsmon]
    [-HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\vsdatant]
    [-HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\VXD\vsdata95]
    Double-click ZADelete.reg
    Empty Recycle Bin

    INSTALL (SAFE MODE BOOT)
    -----------------------------------
    Install ZoneAlarm
    Reboot Normal Mode: reboot requested by ZoneAlarm
    Anti-virus / Anti-spyware > Update Now (repeat until no further updates)
    Run virus/spyware scan: requested by ZoneAlarm (enables automatic signature updates)

  4. #4
    kennygman Guest

    Default Re: Hi, My problem is with the TrueVector Service. I have see...

    Hi, Thank you VERY much for the info and assist. I have redownloaded ZA Security Suite w/ the new version and have incorporated your advice (Strange behavior in ZoneAlarm: reset database) into my thinking for now on.
    Keep up the gr8 work for helping us lost souls.

  5. #5
    hammernu Guest

    Default Re: Hi, My problem is with the TrueVector Service. I have see...

    I was a lost soul once, too!

  6. #6
    andywharfe Guest

    Default Re: Hi, My problem is with the TrueVector Service. I have see...

    Ok Guys no idea what going on here because this all started for me at about 23:00 last night... Goy up this morning and everything has gone totally mental... TrueVector service had restarted over 500 times!!

    It done it 3 time during the day... Antivirus is now dropping out... Not a happy bunny. Seems to be all related to an update that occurred around 23:00 last night...

    Just had to do a total set up of everything this is not a good state to be... Noted Im not alone but that not the point is it...

  7. #7
    loveyouforever Guest

    Default Re: Hi, My problem is with the TrueVector Service. I have see...

    Hi AndyWharfe,

    Correct, the problem might have been caused by a pattern update for the ZA anti-spyware engine in combination with an older ZoneAlarm version. Please follow user HammerNU's advice and install the latest version 7.0.473.000. Get it from here:

    ZoneAlarm Pro 7.0.473.000:
    http://download.zonealarm.com/bin/fr...473_000_en.exe

    ZoneAlarm with Antivirus 7.0.473.000:
    http://download.zonealarm.com/bin/fr...473_000_en.exe

    ZoneAlarm Security Suite 7.0.473.000:
    http://download.zonealarm.com/bin/fr...473_000_en.exe

    ZoneAlarm Free 7.0.473.000:
    http://download.zonealarm.com/bin/fr...473_000_en.exe

    ZoneAlarm AntiSpyware 7.0.473.000:
    http://download.zonelabs.com/bin/fre...473_000_en.exe

    Best regards,

    loveyouforever

    Message Edited by loveyouforever on 04-26-2008 01:42 AM

  8. #8
    Join Date
    Jun 2006
    Location
    The 3rd Coast - South Central Texas
    Posts
    10,473

    Default Re: Hi, My problem is with the TrueVector Service. I have see...

    The ONLY difference between ZA version 7.0.470.000 and 7.0.473.000 is the following <P class=headblack2><A id=7.0.473.000 target=_blank name=7.0.473.000></A>ZoneAlarm Internet Security Suite version 7.0.473.000<UL class=body><LI>Compatibility improvements: <UL class=body><LI>Fixed compatibility issue with public beta of ForceField </LI>[/list]<LI>Other improvements: <UL class=body><LI>Various stability improvements. </LI>[/list]</LI>[/list]

    Sometime Erasing the old Database and Letting ZA create a New Database will fix problems caused by a Corrupted Database..

    ZA has incorparated a new way to Reset DataBase files so users don't need to go into Safe mode.


    To repair this problem, please follow the steps below. Please note that
    this will remove your program permission settings (so you may want to make
    note of them), but re-establishing them is a simple process.

    1.) Hold down the Ctrl and Shift keys together
    2.) Right click on the ZA icon near your clock in the system tray lower right corner
    3.) Choose 'Reset' from the box that comes up
    4.) Choose Yes on the Reset Settings dialog box
    5.) When prompted, choose OK to restart your system
    6.) Follow the on screen configuration prompts after reboot

    ------------------------------------

    Probably the best Tip is to have a full manual remove of ZASS and reinstall.

    Please note that ZASS does not always play nice with many security tools. For example, ad-aware, spybotS&amp;D, spyware doctor, spysweeper. For sure it cannot be installed if you have still another antivirus software or firewall installed or active.

    To troubleshoot ZASS issue is highly recommended to remove all the above and install back (if you really need to) after your ZASS works as it should. If you have not installed any of the above ensure that NO left overs are in the system (they can conflict).

    First re-download the latest ZASS version here:
    http://download.zonelabs.com/bin/fre...ory_vista.html

    Then : Remove your current ZASS from the control panel --&gt; uninstall a program

    Then follow the steps below to ensure NO ZA left over are on your system before reinstalling
    The instruction are for XP, they are basically the same for VISTA (e.g. start --&gt; VISTA search box --&gt; and write the command)

    01.) Restart your computer
    02.) When you see the screen go black and it starts booting back up keep
    tapping the "F8" key (at the top of your keyboard)
    03.) This should bring up a menu. Choose Safe Mode off the menu by
    using the arrow keys on the keyboard to highlight Safe Mode and press
    Enter
    04.) If you get a message asking to go to Safe Mode, choose Yes. If you
    get a help and support window, close this.
    05.) Once you are at the desktop, Click Start, My Computer
    06.) Click Tools, Folder Options, View Tab
    07.) Place a dot next to "Show Hidden Files and Folders"
    08.) Remove the check from "Hide Protected Operating System Files
    (Recommended)"
    09.) Choose Yes to the warning
    10.) Click OK
    11.) Double click C:

    Note: In the future steps if you do not see any files or folders, please click
    the "Show Files" link to view them.

    12.) Double Click the Program Files Folder
    13.) Right Click the Zone Labs Folder, click Delete, and choose Yes

    NOTE: If you cannot delete the entire folder, please open the Zone Labs -
    &gt; ZoneAlarm folder and delete out as many of the files listed here as
    possible.

    14.) Close this window
    15.) Click Start, My Computer
    16.) Double Click the C:
    17.) Double Click the Windows Folder (It may also be WinNT)
    18.) Right Click the Internet Logs Folder, click Delete, and choose Yes
    19.) Double Click the System32 Folder
    20.) Right Click the Zone Labs Folder, click Delete, and choose Yes

    NOTE: If you cannot delete the entire folder, please open the Zone Labs
    folder and delete out as many of the files listed here as possible.

    21.) Locate and delete the following files in the System32 folder if they are
    present:

    - vsconfig.xml
    - vsxml.dll
    - vsregexp.dll
    - vsdata.dll
    - vsdata95.vxd
    - vsdatant.sys
    - vsmonapi.dll
    - vspubapi.dll
    - vsinit.dll
    - vsutil.dll
    - vswmi.dll
    - zlcommdb.dll
    - zlcomm.dll
    - z llictbl.dat
    - zpeng24.dll

    22.) Clear your Temp Directory per the instructions below.

    - Go to Start -&gt; Run
    - Type %temp% and click OK
    - Select all of these files and delete them

    23.) Clear the Prefetch folder per the instructions below.

    - Go to Start -&gt; Run
    - Type Prefetch and click OK
    - Select all of these files and delete them

    24.) Remove the following registry entries by going to Start -&gt; Run and
    typing in regedit. Use the folders on the left side of the window to navigate
    to the specified directories.

    HKEY_LOCAL_MACHINE\Software\Zone Labs
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\vsmon
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\vsdatant

    *Important Advisory: Deleting registry entries incorrectly may cause
    serious problems to your operating system, which may necessitate the
    need to reinstall it. Please make sure you are able to perform these
    deletions correctly before you decide to edit the entries. If you are not
    sure, you should seek help from someone who is familiar with editing the
    registry.

    For information about how to edit the registry in Windows, from your
    desktop, click Start &gt;&gt; Run &gt;&gt; and type regedit. Click on Help &gt;&gt; Help
    Topics. Under the Contents tab, click Change Keys and Values (this may
    be found under the How to... section).

    Also, you should always make a backup of the registry before editing it.
    You can find this in the same section of the Help files.

    25.) Close this window, then empty your recycle bin.
    26.) Restart the computer.
    27.) Install back..



    Message Edited by GeorgeV on 04-25-2008 07:54 PM
    GeorgeV
    ZoneAlarm® Extreme Security


    Click here for ZA Support
    Monday-Saturday__ 6am to 10pm Central time
    Closed Sundays and Holidays

  9. #9
    andywharfe Guest

    Default Re: Hi, My problem is with the TrueVector Service. I have see...

    Hi All

    Heres a small update...

    Carried out the suggested 'reset'. The first time I did this everything went well up to the point where I had finished configuration of ZASS - the system then informed me I had no antivirus! So checking the antivirus I discovered that antivirus was all grayed out!!

    Carried out a second 'reset' - didn't want to go through the pain of a total reinstall - all seems to be sorted now!

    Will monitor the situation and if it happens again I will do the total reinstall.

    Thanks for you help

    Andy Wharfe

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •