Whenever the alert shows, it changes the focus of Firefox to an inactive screen. You have to click on the windo to scroll, etc.

Did I miss a setting somewhere, or is this just an annoying quirk?

Operating System:Windows XP Pro
Product Name:ZoneAlarm Internet Security Suite