Any help would be appreciated:
Two desktops (A, B) networked via Linksys Wireless G router.
Also on the network, a Buffalo Linkstation 25GB storage device.
The Linkstation has a USB port for print-sharing, which I thought would be great to link up my wife's computer as well.


Computer A (wife's computer).
No ZoneLabs, connection to the printer worked perfectly, took two minutes, per instructions.
(Right click on lp, connect, load driver, etc.)
Computer B (mine, where I usually set everything up).
With ZoneLabs (free version), after adding the Linkstation IP address
to Trusted Zone, I can now easily access my files on the device... However, I cannot get the print sharing to work on this device.
They have set up a default printer called 'lp' for easy setup... each time I right-click and select 'Connect' it says, 'Windows cannot connect to the printer.
Either the print name was typed incorrectly, or the specified printer has lost its connection to the server...'
For Computer A, when I right-clicked the lp (Printer) icon, it simply connected straight away and went on to install driver, etc.
In trusted Zone, I haveAdapter Subnet) Linksys router in there set on 'Internet'..the LinkStation storage device IP address in there, 'Trusted', as well as the(Loopback Adapter) on 'Trusted'
I have gone in and checked green checkmark for spooler...I have it set on Medium like everyone says...

Any other idea?
Could it be related to the LinkStation naming the Workgroup as 'Workgroup'?
I tried to view my workgroup under Control Panel, and it said something about 'MsHome not being accessible b/c of name change or something'
btw, when I connect the printer directly to my computer, all works fine.
Thanks everyone...Scott

Operating System:Windows XP Home Edition
Product Name:ZoneAlarm (Free)
Software Version:6.0