Results 1 to 8 of 8

Thread: Internet lock not working correctly

  1. #1
    lablover Guest

    Default Internet lock not working correctly

    Sometimes after having the internet lock engaged for several hours and then disengaging the lock (the lock icon shows open) i can't connect to the internet. I can update programs like my AV, they connect just fine. This happens with both IE and Firefox browsers. If i simply shut down my ZA firewall then immediatly turn it back on, my connection is just fine. It doesn't happen all the time but sporadicly. It's a pain when it does, enough to make me want to change firewalls. Can anybody shed some light on to what the problem is? Thanks much

    Operating System:Windows XP Home Edition
    Product Name:ZoneAlarm (Free)

  2. #2
    billc Guest

    Default Re: Internet lock not working correctly

    When you engage your Internet Lock, programs given pass-lock permission can continue accessing the Internet. Access permission and server permission for all other programs is revoked until the lock is opened. The problem comes when your DHCP server is not allowed to confirm you are still online. After an amount of time passes where your computer does not contact the server, the server puts the TCP/IP address of your computer back into the pool to be assigned to that you or any other machine requesting a TCP/IP address. In Zone Alarm Free, you can't grant individual programs pass-lock permission. The behavior you are seeing is expected. If you loss connection, just shutdown Zone Alarm for 30 seconds then open it again.

    My personal opinion is that if your programs are properly configured, the Internet Lock doesn't really add additional security in Zone Alarm Free.

  3. #3
    mapair Guest

    Default Re: Internet lock not working correctly


    <blockquote><hr>BillC wrote:
    When you engage your Internet Lock, programs given pass-lock permission can continue accessing the Internet. Access permission and server permission for all other programs is revoked until the lock is opened. The problem comes when your DHCP server is not allowed to confirm you are still online. After an amount of time passes where your computer does not contact the server, the server puts the TCP/IP address of your computer back into the pool to be assigned to that you or any other machine requesting a TCP/IP address. In Zone Alarm Free, you can't grant individual programs pass-lock permission. The behavior you are seeing is expected. If you loss connection, just shutdown Zone Alarm for 30 seconds then open it again.

    My personal opinion is that if your programs are properly configured, the Internet Lock doesn't really add additional security in Zone Alarm Free.
    <hr></blockquote>
    Hi My name is Marcus I also have a similar type problem. But With the WOW game

    I use the free Zone alarm ATM. When I start playing my world of warcraft game for some time then close the game and try and access the internet for either a browser IE or Firefox or emails I cannot get access. I to need to close Zone alarm and then it all works . The interseting issue is that the game still has an internet connection. Please help. Thanks Marcus

  4. #4
    billc Guest

    Default Re: Internet lock not working correctly

    Marcus your situation I think is perhaps different. Have you put both your DNS and DHCP server IP's into the Trusted zone? If you don't know your server IP's, here's what to do to find DNS and DCHP servers, etc

    1. Go to Run type in command , hit 'ok', and type ipconfig /all then press enter. In the returned data list will be a line DNS and DHCP Servers with the IP address(s) listed out to the side.
    2. In ZA on your machine on the Firewall>Zones tab click Add and then select IP Address. Make sure the Zone is set to Trusted.
    3. Click OK and then Apply and see if that works to fix it..

  5. #5
    mapair Guest

    Default Re: Internet lock not working correctly

    Will do thank you Marcus

  6. #6
    mapair Guest

    Default Re: Internet lock not working correctly

    Bill thanks I have found the IP and inserted as you advised around 3 weeks ago I was attacked by a very new and very powerful Keylogger called trojan.lineage.ahv which really caused me trouble especailly as they hacked into me special game account on WOW and took everything. This was the reason to install zone alarm are you sure that after adding my IP setting and selecting trusted I will still have max protection. It my top priority. Marcus


    Im so paraniod I run ewido spyware zona alarm and AVG anti virus and fire wall as well as spyblaster.

  7. #7
    billc Guest

    Default Re: Internet lock not working correctly

    Yes. It is safe to add your DNS & DHCP server IP's to your Trusted zone. Only data packets from those servers will be allowed into your machine. These packets, by the way, are required for your machine to resolve URL's to an IP and for your ISP to grant & renew your own IP. Over my 4 years here, there has never been an issue arriving from putting one's ISP's DNS & DHCP servers in the Trusted zone.

    BTW, if you were blessed with joy of having a Trojan, do you happen to know how you got it in the first place? I'm guessing but most nefarious programs of that nature arrive via an e-mail attachment or via file-sharing. I mention this because you need to be careful about what you allow into your machine on purpose.

  8. #8
    mapair Guest

    Default Re: Internet lock not working correctly

    Bill I have no idea where I got then virus but it was bad.

    I have folowed you instructions andm set my ip address 1**.1.** BUT im still hiavingthen problem any ideas ??

    Marcus


    HAng on is it theIp address Im insterting Or the DNS as there diffent the route seems to have the Ip and sub net already listed

    Message Edited by mapair on 10-14-200601:54 AM

    Message Edited by mapair on 10-14-200602:05 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •