Results 1 to 6 of 6

Thread: Generic Host problem

  1. #1
    intellspec Guest

    Default Generic Host problem

    Hi,

    I installed Zonealarm and am having a problem. The internet connection is fine but when I go away from the computer and come back I can't connect to the internet and have to reboot the computer to get back on the server.I tried reinstalling Zonealarm and it seems it fixed it for a day, then the same thing happened. I think it has something to do with Generic Host process win32 since I remmember seeing this somewhere on the internet.Any help would be appreciated.

  2. #2
    ad_hock Guest

    Default Re: Generic Host problem

    Add the ip' s of the DHCP and DNS servers to the trusted zone of ZA.Hit start-run-cmd-OK and in the black command window that opens type ipconfig /all .You'll see several lines among them the ip's of the DHCP and DNS servers (can be more then one).Take note of this ip's and then go to tab firewall page zones, and in the box at the bottom (entry detail) click add. Choose ip address and in the new window enter the ip addresses you found, enter a brief description and ensure the zone is setted to trusted (that should be at medium security level). You need to do this one by one.See also the settings for GHPWin32 (svchost.exe),full access in both trusted and internet and server rights but only in trusted zone.Deny server rights in internet zone (three green ticks and a red cross below internet server).Best regards

  3. #3
    intellspec Guest

    Default Re: Generic Host problem

    Hi Ad-Hock,

    I did what you suggested and added DHCP and DNS to autozone and put Firefox in the description box.I am not sure what you mean that I have to do this one by one,
    do you mean every program that is shown? Also I have a router does this make a difference in your suggestion.


    Thanks

  4. #4
    ad_hock Guest

    Default Re: Generic Host problem

    Hi intellspecI said one by one has normally there are more then one ip from the DNS servers and you must, when clicking add in tab firewall zones and choosing ip address,enter those ip addresses in the text box and enter a brief description in the other text box (something like DNS server). You only can add one at a time. I don't get what you mean when you say you putted firefox in the description.What you need to add to trusted zone are the ip's you found with the ipconfig /all command for the DHCP and DNS servers.The reason of doing this is to make easier the dialog with the DHCP and DNS servers that may be causing you loose internet if the computer is iddle for a certain time.Now you say you are behind a router, the difference is that the ip of the DHCP server may be the internal ip of the router (and the default gateway)if you have DHCP enabled in the router. Add it in the same way and you should add to trusted zone your network something like 192.168.1.0/255.255.255.0.I give you a link that says basically what I suggested first but as there are more posts may help you.Click HERE .Best regards

  5. #5
    intellspec Guest

    Default Re: Generic Host problem

    Hi AD hock,

    Thank You

  6. #6
    ad_hock Guest

    Default Re: Generic Host problem

    You're welcomeBest regards

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •