Results 1 to 8 of 8

Thread: Have to turn off Program Control to connect to mail server sometimes

  1. #1
    zwinkiekater Guest

    Default Have to turn off Program Control to connect to mail server sometimes

    Hi,
    what can be the cause that ZoneAlarm Pro sometimes blocks Thunderbird (TB) and MailWasher (MW) from connecting to my eMail server?

    Measures taken so far:
    - reset ZoneAlarm database

    My configuration:
    - Firewall - Main: Internet Security: High. Trusted Zone Security: Medium
    - Firewall - Zones: All Zones except private WLAN and Loopback adapter (127.0.0.1) in "Internet" Zone
    - Privacy - Main: Cookie Control: medium; Ad Blocking: High; Mobile Code Control: on
    - Privacy - Site List: eMail server registered and all options unchecked.
    - in Program Control - Programs: set Mozilla Thunderbird to Trust Level "Super", allowed "Trusted" and "Internet" access and "Send Mail".
    - in Program Control - Options - Security (for Mozilla Thunderbird): "Outbound eMail protection" enabled, "Authenticate components" enabled.
    - in Program Control - Options - Expert Rules (for Mozilla Thunderbird): none.
    - Program Control - Main: medium

    After starting checking eMails with TB it takes about 30s, then TB states: Could not connect to server.
    Turn Program Control from "medium" to "off": no problem connecting the server.
    It is remarkable, that ZoneAlarm only SOMETIMES block access to the eMail server. In most cases I can connect to the server with Program Control set to "medium". Any idea, what is happening?

    Operating System:Windows XP Pro
    Product Name:ZoneAlarm Pro
    Software Version:6.5

  2. #2
    Join Date
    Dec 2005
    Posts
    9,056

    Default Re: Have to turn off Program Control to connect to mail server sometimes

    Hi

    Make sure the mail servers are listed in the Privacy section of the ZA and have the Mobile Code set to allow all instead of blocking. If they are not listed, then Add them manually.


    Oldsod
    Best regards.
    oldsod

  3. #3
    zwinkiekater Guest

    Default Re: Have to turn off Program Control to connect to mail server sometimes

    <blockquote><hr>Oldsod wrote:
    Hi

    Make sure the mail servers are listed in the Privacy section of the ZA and have the Mobile Code set to allow all instead of blocking. If they are not listed, then Add them manually.

    Oldsod
    <hr></blockquote>

    Stated that in my configuration description:
    - Privacy - Site List: eMail server registered and all options unchecked.

    Means that:
    - eMail servers are in Privacy list.
    - all Privacy options are unchecked for eMail servers.

    I am curious why connecting to eMail servers is blocked only SOMETIMES.

    Zwinkiekater

  4. #4
    Join Date
    Dec 2005
    Posts
    9,056

    Default Re: Have to turn off Program Control to connect to mail server sometimes

    Ooopppsss.


    Okay are the DNS servers included in the Zones of the Firewall and listed as Trusted?

    Is the Generic Host Process (svchost.exe) listed in the Program Control with server rights for the Trusted Zone as well as for the access to the Trusted and Internet Zones?

    What happens when the email client has server rights for the Trusted Zone?

    What about using an Expert Rule for the email? A good description is found at

    http://www.donhoover.net/expertrules.html


    Oldsod ( this time I am awake, so maybe this helps)
    Best regards.
    oldsod

  5. #5
    rgrstan Guest

    Default Re: Have to turn off Program Control to connect to mail server sometimes

    I am having the same difficulty as Z+. Sometimes I have to disable ZA to get my e-mail to download. I'm using Outlook.Despite the fact that this is annoying, I'd like to learn how to deal with it.You mention the DNS servers being in the Trusted Zone. How do I do that? Do I want to do that?Thanks.

  6. #6
    Join Date
    Dec 2005
    Posts
    9,056

    Default Re: Have to turn off Program Control to connect to mail server sometimes

    Hi

    Open the Start > Run >type in "command" and OK > in the command prompt type in "ipconfig /all" and hit the enter key. Do not use the quotation marks and leave a space between the "ipconfig" and the "all".

    Look for the DNS servers and the DHCP or gateway. Write these down and just enter manually into the Zones of the Firewall of the Zone Alarm. List them as Trusted.


    This is done to ensure that your providers servers are connected properly to help your connection and to help prevent DNS spoofing. The connection of the PC and the internet will be correct and possibly smoother in operation and performance.

    This done for all software firewalls and even in Windows itself, especially if using the Windows XP firewall.
    The Properties of the Network connection then the Properties of the selected Internet ProtocolTCP/IP and then Advanced button in the General and the Alternate Configuration tab.

    Oldsod

    Message Edited by Oldsod on 10-21-2006 09:00 PM

    Operating System:Windows XP Home Edition
    Product Name:ZoneAlarm Anti-Spyware
    Software Version:6.1
    Best regards.
    oldsod

  7. #7
    rgrstan Guest

    Default Re: Have to turn off Program Control to connect to mail server sometimes

    Thank you Oldsod. I have added the DNS Server and the DHCP Server to the trusted zones. We'll see how it goes. Appreciate your help.

  8. #8
    zwinkiekater Guest

    Default Re: Have to turn off Program Control to connect to mail server sometimes

    Hi Oldsod, thank you very much for your reply.
    I checked out your suggestions so far.


    -------------------------------------------------------------------------
    Oldsod wrote:
    Ooopppsss.
    Okay are the DNS servers included in the Zones of the Firewall and listed
    as Trusted?
    -------------------------------------------------------------------------

    ipconfig /all lists 3 IP adresses under the area of my provider
    (=Cable DSL). The first IP adress is the adress which is used when
    Cable DSL is inactive. It is set up in the control utility of Cable DSL.
    I did put it into the Trusted Zone, but this network is inactive, so I
    deleted the entry.

    I assume that the second adress is the current active connection, although
    it is different from the adress ZoneAlarm assigned to &quot;Firewall&quot;
    - &quot;Zones&quot; when I started the internet connection (ZoneAlarm
    opened the &quot;New network found&quot; - window).



    -------------------------------------------------------------------------
    Is the Generic Host Process (svchost.exe) listed in the Program Control
    with server rights for the Trusted Zone as well as for the access to the
    Trusted and Internet Zones?
    -------------------------------------------------------------------------

    Generic Host Process for Win32 Services is listed in &quot;Program Control&quot;
    - &quot;Programs&quot;. &quot;Trust level&quot; is &quot;Super&quot;, &quot;Access&quot; is &quot;Allow&quot; for &quot;Trusted&quot;
    and &quot;Internet&quot;; &quot; Server rights&quot; are &quot;Allow&quot; for &quot;Trusted&quot;, but
    &quot;Block&quot; for &quot;Internet&quot;. Changed that to &quot;Allow&quot;.
    When doing so, ZoneAlarm warned me about applying a custom setting to a
    system program.



    -------------------------------------------------------------------------
    What happens when the email client has server rights for the Trusted Zone?
    -------------------------------------------------------------------------

    Set &quot;Server&quot; to &quot;Allow&quot; at &quot;Trusted&quot; for Thunderbird. At the moment I could
    connect to my mail server with &quot;Program control&quot; - &quot;Main&quot; set to &quot;medium&quot;.
    Set &quot;Server&quot; to &quot;Allow&quot; at &quot;Trusted&quot; for MailWasherPro as well. Will
    watch both programs.


    -------------------------------------------------------------------------
    What about using an Expert Rule for the email? A good description is
    found at

    http://www.donhoover.net/expertrules.html
    -------------------------------------------------------------------------

    Haven't worked with expert rules so far. I think, ZoneAlarm should allow
    the basics without using expert rules. I am a more experienced user and
    you see what problems I encounter.

    The description does not help me that much, because it does not say, what
    effects the settings really have.



    -------------------------------------------------------------------------
    Oldsod ( this time I am awake, so maybe this helps)
    -------------------------------------------------------------------------


    Having changed the settings, I will watch a few days if everything is working.

    Ciao, Zwinkiekater

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •