See solution at end of this post ..

I am on Windows XP using ZoneAlarm Pro (7.0.337).
Broadband, direct connection via cablemodem, no router in the way.

I am trying to troubleshoot "connection timeouts" from accounts I have setup.

When I launch a dyndns URL ..
no connection is made to my localhost server on port 80 (or any other port) so dyndns routes instead to the offline URL's.

I am using a dyndns client which echoes back my IP address to


In ZoneAlarm Pro I started by enabling custom TCP/UDP ports(80, 8090) ..

Internet Zone .. high security .. custom settings ..
Allow incoming UDP ports: 80, 8090
Allow outgoing UDP ports: 80, 8090
Allow incoming TCP ports: 80, 8090
Allow outgoing TCP ports: 80, 8090

but still no connection from dyndns accounts.


Then I tested connection to my localhost:80 using only my current IP address ..
e.g. this echos back IP address ..

then tried using that echoed IP address to access my localhost in browser.

but again I get a connection timeout .. ?????


A ShieldsUp!! port probe ( gives this report ..

Results from scan of ports: 0, 21-23, 25, 79, 80, 110, 113,
119, 135, 139, 143, 389, 443, 445,
1002, 1024-1030, 1720, 5000

0 Ports Open
0 Ports Closed
26 Ports Stealth
26 Ports Tested

ALL PORTS tested were found to be: STEALTH.

TruStealth: PASSED - ALL tested ports were STEALTH,
- NO unsolicited packets were received,
- NO Ping reply (ICMP Echo) was received.


Why can't I make connection to my localhost with just my IP address in browser URL?

This is the case even if ZoneAlarm zones (Firewall > Main > Internet/Trusted/Block Zone Security) are set to Off (for testing). So this failure to connect might not be a ZoneAlarm issue.

Port Detective gives a different result to ShieldsUp!! and shows port 80 in use.

__________________________________________________ ________________
__________________________________________________ ________________


I have, at last, solved the above problem which was puzzlng me.

I uninstalled Norton using advice here to use Symantec Norton Removal Tool ..

Norton Removal


My ZoneAlarm > Firewall > Zone Security levels are set to Medium

My dyndns accounts now work with the authorised ports.

And I can now access localhost using my IP address.


Message Edited by alphabeta on 04-18-200710:40 AM