Page 1 of 2 12 LastLast
Results 1 to 10 of 29

Thread: All TCP/IP Connections unuseably slow

Hybrid View

  1. #1
    drmartin Guest

    Default All TCP/IP Connections unuseably slow

    To start, I need to say that I have been a computer programmer for almost 30 years so I have some experience with these kinds of issues. And, no, DR doesn't mean Doctor, it's the initials of my first and middle name ( Daniel R ) :-)

    Anyway, starting a few days ago ( I'm not sure exactly when ), it appears that ALL TCP/IP connections have been so badly slowed by ZA that it's no longer usable. I've been using ZA for about 5 years and have had the security suite installed for about a year. All of a sudden, it started doing this. It might have done an automatic update in the last few days, but I didn't really notice. I have searched this forum for many hours and tried every suggestion I've seen to no avail.

    When I terminate ZA, everything works fine. When it's running, every TCP/IP connection including FTP, Email and HTTP takes about 10 to 30 seconds. As you can imagine, a web page that requires 20 TCP/IP connections can take as long as 10 minutes. That's obviously unusably slow. The download speed also appears to be a bit slower but I haven't done extensive testing.

    I have Comcast cable with a Linksys wireless router and a 5 mbs connection.

    Other computers on the router, without ZA, do fine with both an Ethernet cable connection and wireless connection. I've switched cables, router ports, etc. so it's definitely none of those. Besides, when I terminate ZA, even this computer works fine. The only thing I've installed recently is Second Life and I've since uninstalled it and done a system restore to a few days ago when it was working fine. I have also ended every startup program, everything in the system tray and used Task Manager to terminate every process that it's possible to terminate without forcing a reboot. Nothing haa helped. I've even started ZA and turned off EVERY single protection including the anti-virus, anti-spam, firewall, etc.

    I've followed all the suggestions in all the forums that I could find including adding my DHCP, DNS and 127.0.0.1 TCP/IP addresses manually as "trusted", looked for an lspconflict.txt file (it wasn't there), run the majorgeeks TCP/IP and (I forget the other one) repair programs, rebooted many times, etc. When I looked at task manager, vsmon.exe is using 50% (exactly...every time) of the CPU but it also massively interferes without everything I do from switching windows, to loading other programs, to bringing up the start menu, etc. Basically, everything slows to a crawl while it's trying to make a TCP/IP connection.

    I'm stumped. Any ideas?

    Operating System:Windows XP Pro
    Product Name:ZoneAlarm Internet Security Suite
    Software Version:7.0

  2. #2
    Join Date
    Mar 2004
    Location
    Brisbane, Australia
    Posts
    645

    Default Re: All TCP/IP Connections unuseably slow

    It might be Windows doing the slowing down. As a start, open Task Manager and see if any one program or process is hogging the CPU time.

    Although this doesn't fit all the symptoms, you might be low on free disk space, or the hard disk might be too fragmented making memory swapping very slow. Try defragmenting it. One other thing that can slow things down is a program trying access a network resource (like drive on another PC) that is not available.

    Check these first.

  3. #3
    alphabeta Guest

    Default Re: All TCP/IP Connections unuseably slow

    Process Explorer from http://www.sysinternals.com is a useful free tool for performance analysis.

    Processes and threads utilities

    Download and run processexplorer to view running processes.

    right click on any running process > properties > to inspect

    Go to View > System information to see CPU usage .. click on CPU Usage History graph and move cursor over graph to see processes eating CPU cycles.

    ...

    For defrag use Contig tool here ..

    Contig

  4. #4
    drmartin Guest

    Default Re: All TCP/IP Connections unuseably slow


    <blockquote><hr>FrereOP wrote:
    It might be Windows doing the slowing down. As a start, open Task Manager and see if any one program or process is hogging the CPU time.

    Although this doesn't fit all the symptoms, you might be low on free disk space, or the hard disk might be too fragmented making memory swapping very slow. Try defragmenting it. One other thing that can slow things down is a program trying access a network resource (like drive on another PC) that is not available.

    Check these first.
    <hr></blockquote>

    As I mentioned in my original post, I have been programming computers for almost 30 years so I know a fair bit about checking task manager, defragging, low disk space, etc.

    It's none of those. I have plenty of disk space, I've defragged recently, I don't have any other security products installed etc. In fact, as I mentioned in the original post, I've used Task Manager to kill EVERYTHING else that can possibly be killed and it hasn't helped. Besides, none of that would come close to explaining 10 to 30 seconds to make a TCP/IP connection.

    I'll try process explorer but I think there's little chance it will do any good since I've used Task Manager to kill ALL other processes that can possibly be killed. The only process that shows any appreciable CPU usage is vsmon.exe itself (for those who don't know, that's a ZA process).

    The idea about it's trying to access a network resource that is not available is a good one. I've seen that happen before with Windows Explorer but MS has sinced fixed that BUG. If ZA is doing something similar, then they need to fix that BUG as well. It shouldn't be trying to access any network resources, much less one that isn't there anymore, every time it makes a TCP/IP connection. Besides, I'm pretty sure I've had all computers that share drives turned on at the time I was experiencing the problems and I don't have any other shared network resources. In addition, I believe doing a system restore to a time when it was working properly would have solved it if that were the case. I'll try some stuff out when I get home though, just in case.

    I suppose there is also a theoretical possibility that it's still trying to access a USB drive that isn't turned on. That would also be a BUG. I thought of those things on the way to work today so I'll try them out when I get home. I do have a lot of USB drives, thumb drives etc.

    The only other option I can see at this point is to try un-installing ZA and re-installing it or re-installing a previous version. I'll have to do some searching to find my product key (or whatever it needs) though.

  5. #5
    alphabeta Guest

    Default Re: All TCP/IP Connections unuseably slow

    If you do try Process Explorer note that VSMON is a system process .. there are system processes and user processes which all show up in Task Manager list .. but with little information on individual performance footprint.

    ...

    In Process Explorer I can inspect VSMON like this ..

    Toolbar &gt; View &gt; Show processes from all users

    Expand System in process tree

    go down to VSMON.EXE

    there might be sub-processes

    ScanningProcess.exe
    Monitor.exe

    Right click on VSMON

    Set priority (my setting is normal 8)

    Open properties &gt; switch through properties tabs ..

    Message Edited by alphabeta on 04-18-200710:29 PM

  6. #6
    drmartin Guest

    Default Re: All TCP/IP Connections unuseably slow


    <blockquote><hr>alphabeta wrote:
    If you do try Process Explorer note that VSMON is a system process .. there are system processes and user processes which all show up in Task Manager list .. but with little information on individual performance footprint.

    ...

    In Process Explorer I can inspect VSMON like this ..

    Toolbar &gt; View &gt; Show processes from all users

    Expand System in process tree

    go down to VSMON.EXE

    there might be sub-processes

    ScanningProcess.exe
    Monitor.exe

    Right click on VSMON

    Set priority (my setting is normal 8)

    Open properties &gt; switch through properties tabs ..

    Message Edited by alphabeta on 04-18-200710:29 PM
    <hr></blockquote>


    Ok, I downloaded Process Explorer and checked out vsmon.exe. I don't know exactly what all this means but the number of &quot;reads&quot; looks extraordinarily high. If that's the number of disk reads then ZA is definitely going crazy. After accessing perhaps 20 web sites with Firefox, the number of reads is over 400,000,000. When I'm actually trying to access a web page, the &quot;Read Delta&quot; is in the 120 MB to 130 MB range. I don't know exactly what that means either but it looks extremely high. It also has 34 Threads running which seems a bit excessive. Also, after having booted up about 2 hours ago, most of my time has been spent watching TV and I've probably only visited abou 20 web sites yet the Kernel time is 19:07.062. That seems extremely excessive for just a few web pages as well.

  7. #7
    Join Date
    Mar 2004
    Location
    Brisbane, Australia
    Posts
    645

    Default Re: All TCP/IP Connections unuseably slow

    Hi DRMartin,

    I hesitate to use the name Doc given your original post. LOL. I do have PhD and my name is Philip, so guess what I get!

    On behalf of all the people who have tried to help you, I just wanted to say thanks for your patience and understanding. Many people get really upset when we can't solve their problems immediately. Remember, we are just users like you and we are doing our best. I'm sure you are very frustrted but your attitude and patience has been exemplary and we appreciate it greatly!

    I really hope we can help you sort out your problems. We are doing our best so please bear with us. It will give us immense satisfaction if we are able to play even small part.

    Have a great day, best regards

    FrereOP

  8. #8
    alphabeta Guest

    Default Re: All TCP/IP Connections unuseably slow

    Something very strange about those readings .. 400,000,000 ??

    Topic: what is read delta and read byte delta ?

    My static VSMON Performance .. for comparison ..

    Reads: 356,865
    Read Delta: 0
    Writes: 21,519
    Write Delta: 0
    Other: 515,626
    Other Delta: 0

    These do fluctuate. But nowhere near your figures.

    You could try posting a question at the sysinternals / process explorer forum.

    Or .. dare I say it here .. try a different firewall like **bleep**.

    I have not tried **bleep** yet but I intend to, for comparison.

    ..

    oops .. **bleep** has been censored! Sorry.

    Message Edited by alphabeta on 04-19-200704:03 PM

  9. #9
    Join Date
    Dec 2005
    Posts
    9,056

    Default Re: All TCP/IP Connections unuseably slow

    I'm a little vague in this area. Can the Performance of the AdminTtools be used to help debug the vsmon.exe?

    Just my extra two cents.

    Oldsod
    Best regards.
    oldsod

  10. #10
    Join Date
    Nov 2004
    Location
    localhost
    Posts
    17,290

    Default Re: All TCP/IP Connections unuseably slow

    Hi!may be killing processes with Task Manager is not the best way to troubleshoot, have you tried to start your machine clean from anything else then ZA and see if you still experience the problem?1.) Click Start -&gt; Run
    2.) Type MSConfig in the run box and click OK
    3.) Once in MSConfig, click the Startup Tab
    4.) Remove the checks from everything except ZLClient
    5.) Click the Services Tab
    6.) Place a check in "Hide All Microsoft Services"
    7.) Now remove checks from everything other than TrueVector Internet
    Monitor and click OK.
    8.) Restart your computerFax

    Click here for ZA Support
    Monday-Saturday 6am to 10pm Central time
    Closed Sundays and Holidays

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •