Results 1 to 10 of 10

Thread: Resetting the ZA Batabase

  1. #1
    wcollier Guest

    Default Resetting the ZA Batabase

    I've been having trouble loading websites so I found this link here explaining how to reset the entire ZA database (http://forums.zonealarm.com/zonelabs...ssage.id=31863)

    Anyway, I'm trying to add my DHCP and DNS IPs in my firewall's trusted zone, but the OK button to save the IP address is grayed out. Can anyone tell me what I'm doing wrong?

    Operating System:Windows XP Pro
    Software Version:7.0
    Product Name:ZoneAlarm Internet Security Suite

  2. #2
    Join Date
    Dec 2005
    Posts
    9,057

    Default Re: Resetting the ZA Batabase

    If the Ok is shaded out and the IP has been correctly entered along with the Description and the Trusted is selected in the drop-down, then something is wrong.
    A ZA database reset may be a solution.


    Usually the default new network found sucha as the 192.168.0.0 with a subnet or the 10.0.0.0 with a subnet should be designated as Trusted.

    Oldsod.
    Best regards.
    oldsod

  3. #3
    wcollier Guest

    Default Re: Resetting the ZA Batabase

    Thanks for replying, Oldsod.

    Sorry, I'm a bit slow this morning. I just reset my database so I should reset it again? Also, I'm not having trouble accessing the internet. If that IP address info weren't entered, would I have trouble?

  4. #4
    Join Date
    Dec 2005
    Posts
    9,057

    Default Re: Resetting the ZA Batabase


    <blockquote><hr>wcollier wrote:
    Thanks for replying, Oldsod.

    Sorry, I'm a bit slow this morning. I just reset my database so I should reset it again? Also, I'm not having trouble accessing the internet. If that IP address info weren't entered, would I have trouble?
    <hr></blockquote>


    Aren't we all slow? Maybe I read and answered incorrectly.
    Hmm.. if using the latest ZA, then during the installation process, the set automatic network configuration should have been enabled and the DHCP and the DNS should have been entered as Trusted in the Zones. If not then the database reset should have fixed any issues with the ZA.
    Most often the DNS and DHCP are not entered and the ZA works okay, but it is always preferred to have these listed as Trusted.


    However if the Ok shaded out problem is still there, then do a clean uninstall and install the ZA fresh.
    This way:

    - Click on Start -> Programs -> Zone Labs
    - RIGHT-click on Uninstall ZoneAlarm, then select Properties
    - Under Target you will see the following line (the actual drive may
    be different on your system):

    "C:\Program Files\Zone Labs\ZoneAlarm\zauninst.exe"

    Change it to:

    "C:\Program Files\Zone Labs\ZoneAlarm\zauninst.exe" /clean

    (first add a space and then type in the /clean )

    Use the Apply and OK in that window.

    Open the Zone Alarm and disable the "Load Zone Alarm .. at startup" in the Preferences of the Overview. Then reboot. Now the Zone Alarm is completely off andnone of it's driver have not been started.

    -Return to the Uninstall ZoneAlarm in the Zone Labs of the All Programs
    - Click OK to run the uninstaller, and OK any security alerts that
    pop up.
    - say "Yes when being prompted for the removal of all files.
    - Reboot
    - manually remove the files found inside these folders:

    WINDOWS\ Internet Logs
    Program Files\Zone Labs
    WINDOWS\system32\ Zonelabs
    WINDOWS\Temp
    and the Temp folders found in the Document and Settings


    - reboot

    - install the latest version
    download the ZAISS from here


    - re-enter license key if needed (copy and paste the license into the ZA firewall from a previously created .txt file placed on the desktop is usually the easiest).

    -enter the new network found as trusted, answer the first few alerts.

    If needed now the DHCP and DNS server IPs can be entered or it should work okay now:

    1. Go to Run and type in command and hit 'ok', and in the command then type in ipconfig /all then press the enter key. In the returned data list will be a line DNS and DHCP Servers with the IP address(s) listed out to the side. Make sure there is a space between the ipconfig and the /all, and the font is the same (no capitals).
    2. In ZA on your machine on the Firewall, open the Zones tab, click Add and then select IP Address. Make sure the Zone is set to Trusted. Add the DNS IP(s) .
    3. Click OK and Apply. Then do the same for the DHCP server.
    4. The localhost (127.0.0.1) must be listed as Trusted.
    5. The Generic Host Process (svchost.exe) as seen in the Zone Alarm's Program's list must have server rights for the Trusted Zone.
    Plus it must have both Trusted and Internet Access.

    Cheers.
    Oldsod.
    Best regards.
    oldsod

  5. #5
    wcollier Guest

    Default Re: Resetting the ZA Batabase

    Thanks Oldsod:

    I finally figured out what I did wrong. When adding an IP address as Trusted, you have to type in a description. Until then, you can't click OK.

  6. #6
    wcollier Guest

    Default Re: Resetting the ZA Batabase

    ..... except I'm noticing that after doing a clean re-install, my ZoneAlarm won't minimize to the taskbar. I've checked my startup in msconfig and there is only one occurrence of zlclient.

  7. #7
    Join Date
    Dec 2005
    Posts
    9,057

    Default Re: Resetting the ZA Batabase

    Try this:

    Open the Run and type in "regedit" (no quotation marks please) and ok and in the regedit look for this key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Run

    in the right panel there should be only one mention of the Zone Labs Client. It should have the under the Datat column, this listed:
    C:\Program Files\Zone Labs\ZoneAlarm\zlclient.exe

    If there is another mention of the Zone labs, then please repost with what it says - both under the Name column and under the Data column.

    At the same time. look for this key:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Run

    again as before, look in the right side panel and this time just post what is listed concerning any mention of the Zone Labs.


    Also, check the All Programs under the Start and open the Startup - is there any mention of any Zone Labs here?

    Oldsod.
    Best regards.
    oldsod

  8. #8
    Join Date
    Dec 2005
    Posts
    9,057

    Default Re: Resetting the ZA Batabase

    Ok good to hear!
    Oldsod.
    Best regards.
    oldsod

  9. #9
    wcollier Guest

    Default Re: Resetting the ZA Batabase

    Thanks for your help, Oldsod.

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Run
    There's only one occurrence of Zone Labs here.

    HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Run
    There's nothing listed here.

    Also, nothing listed in the startup menu.

  10. #10
    Join Date
    Dec 2005
    Posts
    9,057

    Default Re: Resetting the ZA Batabase

    <blockquote><hr>wcollier wrote:
    Thanks for your help, Oldsod.

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Run
    There's only one occurrence of Zone Labs here.

    HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Run
    There's nothing listed here.

    Also, nothing listed in the startup menu.
    <hr></blockquote>


    What else is running on the PC in terms of other security applications?If nothing else, I would suspect a bad installation- first caused by other interferring security applications or by a bad windows or bad hardware.

    Okay. Try this:

    1.Download the CCleaner and install it.Run it immediately.

    2. Uninstall the ZA but this time in the safe mode. Do not uninstall in the Normal mode. Do the clean uninstall as before, but do the uninstall in the safe mode not the normal mode.

    3. After the reboot, run the CCleaner and let it remove any files and registry keys. Do not install the ZA just yet.
    Then reboot into the safe mode and run the CCleaner once again.

    4. Do a Disk Check. "In the Check Disk dialog box, select the "Scan for and attempt recovery of bad sectors check box, click "Start" and have it repair anything it finds. As you use your hard drive, it can develop bad sectors which slow down hard disk performance and make data writing difficult. Check Disk scans the hard drive and verifies the logical integrity of a file system by checking for system errors, lost clusters, lost chains, and bad sectors. When encountering logical inconsistencies in file system data, it will perform the necessary actions to repair the file system data."

    See http://it.cas.psu.edu/Training/HowTo...disk_check.htm for extra help.

    5. Do a System File Check. " If SFC discovers that a protected file has been damaged, altered or missing, it restores the correct version of the file from the cache folder. You must be logged on as an administrator or as a member of the Administrators group to run sfc and it may ask you to insert your XP Installation CD so have it available."

    See http://dwightblackburn.com/winxp/ for extra help.

    6. Do a disk defrag. See http://www.bleepingcomputer.com/tuto...utorial55.html.
    "Disk fragmentation slows the overall performance of your system. When files are fragmented, the computer must search the hard disk when a file is opened. Disk Defragmenter consolidates fragmented files and folders on the hard disk so that each occupies a single space on the disk. This speeds up reading and writing to the disk."

    7. Remove any third party memory manager or optimizers.

    8. Update your drivers. See:

    http://support.microsoft.com/kb/283658

    http://www.bleepingcomputer.com/tuto...torial119.html

    9. OK. The PC has been now properly maintained and any fixable issues have been fixed. Run the CCleaner once again - again cleaning with both the files and registry options in the CCleaner.

    10. Now download the ZAISS from here.

    Please do not use any web accelerators or any download managers!
    These will always corrupt the ZA installers.

    11. Finally, and last but not least, install the ZAISS.

    Quotes are from http://www.castlecops.com/t175258-Sl...e_malware.html

    Oldsod.

    *fixed broken link*

    Message Edited by Oldsod on 03-10-2008 10:24 PM
    Best regards.
    oldsod

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •