Results 1 to 5 of 5

Thread: Unable to print now that I have zone alarm

  1. #1
    jerrywilliams Guest

    Default Unable to print now that I have zone alarm

    I have LEXMARK 5000 series printer. I am unable to print now that I have zone alarm. It will start the printing process and then just go idle and never complete. I have looked at the program access settings on zone alarm and have "allowed" everything I can see related to printing access, but maybe I am missing something. Could it be a port that is being blocked? I tried reinstalling the printer drivers to be complete and that did not help. This is my first time working with a firewall so may need help.

    Another question is the "server access" What server is Zone Alarm referring to when I have the option to allow a program server access?

    Operating System:Windows XP Home Edition
    Software Version:
    Product Name:ZoneAlarm (Free)

  2. #2
    zaswing Guest

    Default Re: Unable to print now that I have zone alarm

    ZA free doesn't have provisions for blocking specific ports.

    Server access - your computer might act as a server. It'll sit waiting for something to connect and might talk back out.
    From ZA help screen:
    "Server permission allows a program on your computer to "listen" for connection requests from other computers, in effect giving those computers the power to initiate communications with yours. This is distinct from access permission, which allows a program to initiate a communications session with another computer"
    "Granting a program permission to act as a server
    Exercise caution when granting permission for programs to act as a server, as Trojan horses and other types of malware often need server rights in order to do mischief. Permission to act as a server should be reserved for programs you know and trust, and that need server permission to operate properly."

    Generic Host process needs trusted server.
    A scanner needs trusted server.
    An application accepting logs from the router need to act as a trusted server.
    Some games may need it.

    As far as your printing goes. Spooler SubSystem app(spoolsv.exe) may need 3 green checks from the left. Try 2 and one "?". If doesn't work, try all 3. If it is a network (not USB) printer, you may want to put its IP in the trusted zone on the Zones tab in ZA, together with all the other standard things. It sounds to me like your connection is ok, and times out before it should (could be a USB issue). Again, if it's a network printer, can you ping it? Is it visible in Printers and Faxes?

  3. #3
    jerrywilliams Guest

    Default Re: Unable to print now that I have zone alarm

    It is visible in the printers/faxes. It is an all-in-one printer. There are two listed in printers window. The Lexmark Fax 5000 series and Lexmark 5000 Series. It is a USB connection. Last night I tried to print again, it printed one line, then just froze. I will try the item you mentioned by putting the 2 then 3 checkmarks next to the spool? thing.

  4. #4
    zaswing Guest

    Default Re: Unable to print now that I have zone alarm

    I'm not clear about few things, sorry.
    Were you able to print with no trouble before installing ZA-free?

    Back to your first post: If it is a USB printer, "port" is not relevant. If it is a network printer, port may be relevant. Turn on ZA alerts and read off what it says. I took a quick look at some pdf about this printer and it appears to be a network printer, they do discuss pinging it etc.

    Your second post says "Last night I tried to print again, it printed one line, then just froze". What froze? The computer or the printer?

    If, as I suspect, it's a normal network printer, I'd uninstall the USB drivers. Connect the printer to the router. Reboot the computer and let Windows set it all up for you. If that fails, I'd contact the manufacturer and ask for details.

    Perhaps if you describe the "USB connection" someone else can offer better help. What is exxactly connected to what? When you click on the printer properties in Printers and Faxes what do you see? Do they talk ports? any other details?

  5. #5
    jerrywilliams Guest

    Default Re: Unable to print now that I have zone alarm

    Sorry for the confusion. It is a regular USB connection from my laptop to the printer. It worked fine before using zone alarm. The printer is what freezes. I get the message that document is printing, and then it just doesn't do anything.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts