Results 1 to 9 of 9

Thread: Connection at second attempt

  1. #1
    cedricdawnhawk Guest

    Default Connection at second attempt

    I connect to the internet via an ADSL modem attached to a USB port on the computer. If a program requires internet access and I am not connected, the ADSL network connection is activated, and the connection icon appears in the notification area with a message indicating a successful connection. The ZoneAlarm icon then shows some activity for a few seconds. After about 15 seconds the program that requires access reports a failure (page cannot be displayed in the case of a browser or unable to connect to server in the case of Outlook Express). Any subsequent attempts to connect eg by refreshing the web page is immediately successful and from then on things are fine.

    If I establish the connection manually first, wait for about 20 seconds before using the browser or e-mail program there isn't a problem.

    This has been happening for some time possibly starting when I installed version 8 of ZoneAlarm.

    Operating System:Windows XP Pro
    Software Version:8.0
    Product Name:ZoneAlarm Antivirus

  2. #2
    zaswing Guest

    Default Re: Connection at second attempt

    That icon can be misleading, because it doesn't tell which "connection" is activated.
    Most likely it's between your PC and the modem.
    As a president once almost said 'it depends what the meaning of connection is'

    In my opinion thre are two points of possible failure.
    (1) the modem itself disconnects during lack of activity. If you can get into the modem's setup page, check it out. It might be called 'keep alive' or 'do not disconnect' or ...
    and make sure to tell it somehow not to disconnect from your ISP.
    (2) on the computer:
    a. I have absolutely no experience with modem via USB. But one thing I'd check is the power management of that USB port. Is it permitted to be shutdown by the system? If so, that would disrupt connections.
    b. Related to ZA: On the zones tab do you have DNS servers, DHCP server listed as TRUSTED? If not, that's enough to cause trouble. Somewhere in computer properties > hardware > device manager find that modem and click on everything till you find about power management.

    The advice given on this forum is invariably this, and I quote:

    " Make sure your DNS and DHCP server IP's are in your Firewall's Trusted zone. Finding DNS and DCHP servers, etc:

    1. Go to Run and type in command and hit 'ok', and in the command then type in ipconfig /all then press the enter key. In the returned data list will be a line DNS and DHCP Servers with the IP address(s) listed out to the side. Make sure there is a space between the ipconfig and the /all, and the font is the same (no capitals).
    2. In ZA on your machine on the Firewall, open the Zones tab, click Add and then select IP Address. Make sure the Zone is set to Trusted. Add the DNS IP(s) .
    3. Click OK and Apply. Then do the same for the DHCP server.
    4. The localhost (127.0.0.1) must be listed as Trusted.
    5. The Generic Host Process (svchost.exe) as seen in the Zone Alarm's Program's list must have server rights for the Trusted Zone.
    Plus it must have both Trusted and Internet Access.

    Extra help is found at Guru Hoov site for the DNS/DHCP.

    Oldsod."

    If it all worked for you before changing to version 8, can you recall your settings from then?

  3. #3
    cedricdawnhawk Guest

    Default Re: Connection at second attempt

    I think I have sorted out the cause, but haven't found a solution.

    As described in my previous post, when the program requires internet access the ADSL network connection is activated and I am successfully connected to my ISP and assigned an IP address. The program uses this IP address to attempt to communicate to eg the pop3 mail server. Zone Alarm intercepts this, looks at the IP address and doesn't recognise it as the IP address of my computer and blocks it, interpreting it as a routed message from some other computer. It is only after a delay that Zone Alarm realises that there is a new network (the connection to the ISP) and adds it to the internet zone. Subsequent messages from programs are then recognised as coming from my computer and are passed.

    Because the IP address assigned to me by my ISP is different every time I connect, I can't add a fixed IP address to my internet zone. I can add a range of addresses but these can only be put in the trusted zone which I don't want to do as I may be including unwanted addresses.

    I'm also not sure why ZoneAlarm is not alerting me when the new network appears when I connect, even though I select the "Ask which Zone to place networks in..." option.

  4. #4
    zaswing Guest

    Default Re: Connection at second attempt

    Hmmm,
    I understand you getting different IP from your ISP. Your IP doesn't need to be in the trusted zone. DNS, DHCP do need it.
    If you add DHCP server address to the trusted zone, does it not work? I have a feeling it has to work and doubt ZA would see it as a new network. Did you do the items in the list I quoted and are you suggesting that didn't do the job?

    Some people need to add their mail server IPs to trusted zone. I don't, but you could try that as well.

    Message Edited by zasuiteuser on 03-19-2009 09:24 PM

  5. #5
    cedricdawnhawk Guest

    Default Re: Connection at second attempt

    Thanks for your interest in my problem.

    I don't think the DNS servers need to be in the trusted zone. They never have been and I don't have any problems. Similarly DHCP is not enabled for my PPP dial up connection so I can't add the DHCP server as I don't have one. I have not tried the other items you suggested as they don't seem relevant to my problem. This is a consistent fault on first connection which does not occur subsequently.

    I have found that other users are suffering the same problem - see http://forum.zonelabs.org/zonelabs/b...ssage.id=36615 I have therefore raised it with technical support but would still welcome any suggested solutions from other users.

  6. #6
    Join Date
    Nov 2004
    Location
    localhost
    Posts
    17,288

    Default Re: Connection at second attempt


    <BLOCKQUOTE><HR>CedricDawnhawk wrote:
    I don't think the DNS servers need to be in the trusted zone. <HR></BLOCKQUOTE>Hi!at install ZA will add the DNS and DHCP to the firewall trusted zone.If you do not have the DNS in the trusted zone it means that you either prevented at install (autoconfiguration) or removed it after or you have a dial up connection that is off at boot.DNS in the trusted zone is needed for the correct functioning of ZA. It may work without but if you have issue of connection then it may be the source of your problems.See here how to determine your DNS IPs and how to add it/tehm to the trusted zone:http://zonealarm.donhoover.net/dnsdhcp.htmlhttp://zonealarm.donhoover.net/adding.htmlCheers,Fax

    Click here for ZA Support
    Monday-Saturday 6am to 10pm Central time
    Closed Sundays and Holidays

  7. #7
    acheshirecat Guest

    Default Re: Connection at second attempt

    I seem to have found my own version of a solution ( http://forum.zonelabs.org/zonelabs/b...ssage.id=36952 ) a question I would ask that I did not see addressed was 'have you checked iexplorer add ons?', I found an add on that was added by a third program (AVG) that when I shut it off my problems went away. In iexplorer under 'Tools, Manage Add-ons' is the place to check that option. I have not had any problems with that add-on turned off. In future updates of other third programs the Add-on tool might give a hint about which program is messing with the iexplorer/ZoneAlarm relationship.

  8. #8
    dj_earl Guest

    Default Re: Connection at second attempt

    Noticed another thing when looking at the Firewall/Zones window, before I connect, this is what I see :
    http://www.image4u.org/scinet/za1.jpg
    I then make connection and have to wait the obligatory 25 'ish seconds before I can see Google on Explorer or before Outlook Express starts to receive e-mail. (A pop-up message down by the time bar tells me I am immediately connected however)
    As soon as the waiting period is up (I counted about 24 seconds) everything comes alive
    and a new entry simultaneously
    appears
    in the Firewall/Zones window :
    http://www.image4u.org/scinet/za2.jpg
    What is taking the time here?? I know 25 seconds isn't long but it seems an eternity before ZA will let me on, especially
    if I'm on the 'phone to somebody and they ask me to check something on the 'net.
    Here is the &quot;ipconfig /all&quot; screen, don't know what all this means but this is what I get :
    http://www.image4u.org/scinet/za3.jpg
    Does this tell anyone anything??
    Windows XP SP3, Zone Alarm Version 8.0.065.000

  9. #9
    zaswing Guest

    Default Re: Connection at second attempt

    Good, useful, screen shots
    According to ipconfig data
    1. You have a static IP 91.110.204.231 in Birmingham UK. If it's really static, next time ZA detects this, I'd make it trusted, as it seems to be your private line with the orange network.
    2. The DNS servers are 193.36.79.100 (Orange PCS...in Bristol), and 80.10.246.1 (PFS-Orange) in France, both should be in ZA as trusted. You might call your provider to make sure your list of the DNS servers is really what it should be. The reason I mention it is the discrepancy between what you have in ZA and in ipconfig data.
    3. PPP inteface is direct Point to Point tunneling broadband connection which might be doing 'heartbeat' in order to stay connected, so if you add these things in, it might be better. Also in the modem, I'd find a place to keep the connection alive always.

    Add 127.0.0.1 loopback to your list, and put in the trusted zone.
    Make sure Generic Host Process has 3 green checks from the left (not internet server)
    Also IE needs two green checks from the left.

    I hope I haven't missed anything
    Do read the references that Fax provided above. They're good.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •