Results 1 to 9 of 9

Thread: ZASS 7.0 with Logitech QuickCam -- memory errors

  1. #1
    rvonder Guest

    Default ZASS 7.0 with Logitech QuickCam -- memory errors

    I'm posting this to hopefully save someone else the many hours of grief I've just been through.
    There is apparently an incompatibility if you have Logitech QuickCam software installed along with ZASS 7.0 (more specifically, with the Kaspersky engine that is now part of ZASS 7.0).
    At some point after booting (sometimes within a few minutes or even several hours later), the system starts getting memory errors.
    Every time you open any new program you'll get a popup with "The instruction at "0x7c8edf9c" referenced memory at "0x7c8edf9c". The memory could not be "written".
    You may also get a second popup from DRWWIN, which is Microsoft's Dr. Watson debugging tool.
    Eventually you will have to reboot because nothing will work anymore.

    The problem occurs whenever Logitech's ProcMon process is running (c:\program files\common files\logitech\lvmvfm\LVPrcSrv.exe).
    This gets installed with the QuickCam software, and is automatically started up when you boot.
    I have the Logitech Communicate STX, but understand this also applies to most other QuickCam models.
    The workaround is to be sure this process never runs.
    First, go into Control Panel / Administrative Tools / Services and find the 'LVSrvLauncher service.
    Right-click, open its properties, and change the Startup Type to 'Disabled'.
    That will ensure that it won't be loaded at boot time.
    Be aware, however,
    that this process is also started up if you invoke the 'Logitech QuickCam' application (usually a desktop icon).
    So in the ZASS Program Control / Programs tab, I've changed the trust level for "Logitech LVPrcSrv Module" from 'super' to 'kill' -- meaning it will never be allowed to start.
    I haven't completely figured out how lack of this process impacts use of the QuickCam, but my understanding is that the camera will still work fine when called from other applications.
    It's only Logitech's own app that uses this process.
    All I know for sure is that I haven't had a single memory problem as long as LVPrcSrv is not running.
    FYI, I finally discovered this information from an August 2006 posting on the Kaspersky user forum - see:
    Hope this helps some of you - and at least now it's archived here for future reference!


    Operating System:Windows XP Pro
    Product Name:ZoneAlarm Internet Security Suite
    Software Version:7.0

  2. #2
    mawi Guest

    Default Re: ZASS 7.0 with Logitech QuickCam -- memory errors

    Thanks! This is type of info I've been waiting for! I have been having these exact same problems, I knew it had to do with the Kaspersky engine, but I didn't know with which program it was conflicting with. I made a work around by unchecking the start on startup under preferences, and my problem was solved, but today when I was using my webcam in a videocall with my dad, my computer crashed for no reason! This explains why! DUDE THANKS!!
    I hope that they will come out soon with a patch or updated version of 7.0.302, cause this really **bleep**s big time!!!

  3. #3
    beekken Guest

    Default Re: ZASS 7.0 with Logitech QuickCam -- memory errors

    Nice tip, been getting the same errors myself! Hopfully now its been identified it will be fixed

  4. #4
    rvonder Guest

    Default Re: ZASS 7.0 with Logitech QuickCam -- memory errors

    I obviously can't speak for ZA, but since this appears to be a Kaspersky issue I suspect the fix would have to come from them.
    And from their forums, I can't see any mention of a fix since the postings about the problem surfaced back in August.
    Also, in all fairness, this may stem from "bad manners" on the part of the Logitech drivers vs. the Kaspersky engine -- in which case, we should be beating on Logitech for a fix.
    I'm not hopeful, however.
    Usually, I find that whenever two vendors are involved, there's a lot of finger-pointing and things seldom get resolved.
    Maybe we'll be pleasantly surprised on this one?
    Anyway, it's possible that Logitech may have some older drivers that don't have as much functionality but also don't cause the conflict.
    I know that I'd recently downloaded and upgraded mine to the "latest greatest", so I may see if I've got the older install disk that came with the camera and/or check online to see if I can work around this without losing use of the camera altogether.
    Not a high priority for mej, though, because I rarely even use the QuickCam...


  5. #5
    steve257 Guest

    Default Re: ZASS 7.0 with Logitech QuickCam -- memory errors

    Thanks for the tip...When I first installed ZAS 7.0, I got the tons of app error messages, so I reverted to 6.5.
    Then an automatic
    'virus update' resulted in a system that wouldn't even boot in safe mode!!!
    I just finished re-building my disk, and instaleld ZAS 7.0 fresh, and had no problems until I loaded up my Logitech QuickCam software.
    I first tried the 'latest and greatest' download from Logitech, but got so many errors, that I un-installed it and tried my older 9.5 version.
    It loaded just fine, but after re-booting, I got memory and application errors, so I've removed it too.
    Maybe I'll try re-loading it and disabling the service to see if that works...or maybe not.
    I might wait for an update from either ZA or Logitech.

    What has me worried is that there may be other bombs like this waiting to happen as I re-install my other apps.
    Time will tell.

  6. #6
    roybrock Guest

    Default Re: ZASS 7.0 with Logitech QuickCam -- memory errors

    Brilliant, I am now back in business and it just shows how important it is to make a note of the exact pop-up messages before doing a search.
    Has anyone told ZA Labs people?

  7. #7
    ppmartin Guest

    Default Re: ZASS 7.0 with Logitech QuickCam -- memory errors

    Many thanks, Rob, that was an extremely useful tip!

    I had installed ZA 7.0 on a laptop with no webcam last Friday, and when I thought all was safe, I installed it also on my home desktops (after having checked-off the autostart / rebooted / uninstalled version 6.5 - just to improve the odds of a painless install which is never obvious with the latest ZA releases).

    As you described, the problems didn't start right away, but - after a while - became so frequent as to make both my home desktop pretty useless.

    Your tip was the exact solution to my problem (I have Logitech Webcams on my two desktops), and fixed it for good.

    I also hope that Logitech and / or Kaspersky will get their act together, and that ZoneAlarm will add this information to a "readme.txt" file which would recap the "known incompatibilities" and be displayed at the start of the installation for the benefit of their customers.

    Thanks again,
    Hong Kong

    Message Edited by ppmartin on 03-26-200707:33 AM

  8. #8
    heavikevi Guest

    Default Re: ZASS 7.0 with Logitech QuickCam -- memory errors

    You are my new hero.

  9. #9
    naivemelody Guest

    Default Re: ZASS 7.0 with Logitech QuickCam -- memory errors

    written and you went the extra mile by getting a link to Kaspersky. All forum users appreciate your efforts here.NaiveMelody NYC 4-29-07~12:23am e.s.t. - Some kind of wonderful - Grand Funk Railroad

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts