Results 1 to 2 of 2

Thread: "Validation Failed" messages after removing USB Wireless Adaptor

  1. #1
    joeser Guest

    Default "Validation Failed" messages after removing USB Wireless Adaptor

    This drove me crazy until I could figure out what caused it - I thought I had a corrupt installation and kept uninstalling and reinstalling (safe mode, hidden files, cleaning registry).

    I have zonealarm suite trial 7.0.408.000 loaded, and it was working fine.

    I plugged in a wireless USB network adapter to my desktop to try it out, then unplugged it later.

    Now, every time I reboot without the USB network adapter plugged in I get an error message as the desktop comes up like (the file sometimes changes):
    Validation failed for c:\windows\system32\zonelabs\vsmondll.dll

    This message keeps returning when acknowledged, and zonealarm never starts up.

    If I plug the USB adapter in before I boot, then everything is fine.

    I tried going to the hardware tree and uninstalling the USB adaptor before rebooting, but the error messages still comes up if I reboot without the adapter.

    I made sure to use the "Safely Remove Hardware" to stop the wireless adapter before unplugging.

    How can I remove this dependency on having the USB adapter to get zonealarm start up and work properly?

    Message Edited by joeser on 09-27-2007 04:13 PM

  2. #2
    Join Date
    Dec 2005
    Posts
    9,057

    Default Re: "Validation Failed" messages after removing USB Wireless Adaptor

    Maybe a ZA database reset will work and fix the issue. Trty this and see if this works.

    Boot your computer into the Safe Mode

    Navigate to the c:\windows\internet logs folder

    Delete the backup.rdb and iamdb.rdb files in the folder

    Clean the Recycle Bin

    Reboot into the normal mode

    ZA will be just like new with no previous settings or data


    (How to get into the safe mode)

    After the reboot if the ZA seems normal, then set the new network found as Trusted. Then follow any new popups and do this:

    Make sure your DNS and DHCP server IP's are in your Firewall's Trusted zone. Finding DNS and DCHP servers, etc

    1. Go to Run and type in command and hit 'ok', and in the command then type in ipconfig /all then press the enter key. In the returned data list will be a line DNS and DHCP Servers with the IP address(s) listed out to the side. Make sure there is a space between the ipconfig and the /all, and the font is the same (no capitals).
    2. In ZA on your machine on the Firewall>Zones tab click Add and then select IP Address. Make sure the Zone is set to Trusted.
    3. Click OK and then Apply and see if that works to fix it.
    4. The localhost (127.0.0.1) must be listed as Trusted.
    5. The Generic Host Process (svchost.exe) as seen in the Zone Alarm's Program's list must have server rights for the Trusted Zone.
    Plus it must have both Trusted and Internet Access.

    Extra help is found at Guru Hoov site for the DNS/DHCP.

    Hope this helps, Oldsod
    Best regards.
    oldsod

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •