Results 1 to 5 of 5

Thread: 7.0.462.000 disables USB wireless keyboard

  1. #1
    dresdner Guest

    Default 7.0.462.000 disables USB wireless keyboard

    As soon as I had loaded ZoneAlarm 7.0.462.000 (as a fresh install, not as an upgrade), my Microsoft USB Wireless Keyboard fails to be loaded by Windows. To overcome the problem I am obliged to unplug the Wireless Receiver from its USB socket and plug it in again. The MS Wireless Mouse that shares the same Wireless Receiver with the keyboard is not disabled. Anybody any ideas?

    Operating System:Windows 2000 Pro
    Software Version:7.0
    Product Name:ZoneAlarm Pro

  2. #2
    forum_moderator Guest

    Default Re: 7.0.462.000 disables USB wireless keyboard

    HiI suspect you got an alert about suspicious behavior from the driver or something for this keyboard saying it was monitoring your keystrokes or something like that. You probably accidentally denied it and that why its not working.I would suggest the following if you have another keyboard. Unplug the MS wireless unit plug in wired keyboard. Now un-install any software that was installed to support this keyboard.Then shutdown, unplugged wired kb, plug in wireless unit but into a different USB port than last installed into. Turn on computer and see if it detect new hardware installed and install the drivers. Watch for a ZA alert(s) and allow these processes the proper access if they are related to the KB.Forum Moderator

  3. #3
    dresdner Guest

    Default Re: 7.0.462.000 disables USB wireless keyboard

    Thanks for the idea, but I don't use any special software for the wireless keyboard. The wireless keyboard/mouse set is a Microsoft product and it uses the default drivers in Windows 2000 Pro.
    I recently installed the program "What's Running" (www.whatsrunning.net) which reports the following keyboard-, USB- and HID-related items when the USB wireless keyboard isn't working (i.e. before I unplug & replug it to force it to work):
    Service: HID Input Service (hidserv.exe): running
    Module: HID Input Service (hidServ): running
    Driver: Microsoft HID Class Driver (hidusb): running
    Driver: i8042 Keyboard and PS/2 Mouse Port Driver (i8042prt): stopped
    Driver: Keyboard Class Driver (kbdclass): running
    Driver: Keyboard HID Driver (kbdhid): running
    Driver: Microsoft USB 2.0 Enhanced Host Controller Miniport Driver (usbehci): running
    Driver: Microsoft Standard Hub Driver (usbhub): running
    Driver: USB Hub Support (usbhub20): running
    Since all the above drivers are running, this suggests to me that as far as Windows is concerned, the USB wireless mouse should be working properly.
    Two further comments:
    - when the USB wireless keyboard isn't working (i.e. before I unplug & replug it to force it to work), the LED in the wireless receiver shared with the mouse (which is working properly) flashes whenever a key is pressed even though there's no reaction to the key press on the monitor screen
    - I have no external USB hub connected; the PC has 4 USB sockets on the rear and two on the front and I presume the hub mentioned in some of the "What's Running" entried listed above is an internal one
    Are there settings in ZoneAlarm related to the above that I could check and/or change?

  4. #4
    Join Date
    Jun 2006
    Location
    The 3rd Coast - South Central Texas
    Posts
    10,465

    Default Re: 7.0.462.000 disables USB wireless keyboard

    I agree with the Moderator.. You have probably gotten a ZA Alert pop up and failed to Check approved and Remember my choice on that Alert Pop up related to the Wireless Keyboard driver monitoring your keystrokes. I've owned several HP Computers that came with Wireless Mouse/Keyboard setup and had no problem with ZoneAlarm as long as approved the Keyboard/Mouse driver.Unpluging the Wrireless receiver for the Keyboard/Mouse and Plugging into another USB Port may activate the New Device detected and give you a new Alert pop up, if so check OK and Remember action..Here is something else to try..Right Click on the ZA Tray icon, Click on Program control, Click on the Program Tab, Scan down the list of (Programs) that have RED X's in the "Access" column, if you high-lite that program there is an "Entry Details" Block at the Bottom of the List that describes what the program is.. if the program or driver is related to your Computer or Windows or Microsoft, it is most likely save to change the Access Red X in the Trusted Column to ? or Green check mark.Post back with your progress..---------------------------------------
    My XP Configuration:
    ZoneAlarm Security Suite version:7.0.462.000
    TrueVector version:7.0.462.000
    Driver version:7.0.462.000
    Anti-virus engine version:3
    Anti-virus signature DAT file version:931491974
    Anti-spyware engine version:5.0.162.0
    Anti-spyware signature DAT file version:01.200712.2955
    AntiSpam version:5.0.0.8843

    Message Edited by GeorgeV on 12-05-2007 07:37 AM
    GeorgeV
    ZoneAlarm® Extreme Security


    Click here for ZA Support
    Monday-Saturday__ 6am to 10pm Central time
    Closed Sundays and Holidays

  5. #5
    dresdner Guest

    Default Re: 7.0.462.000 disables USB wireless keyboard

    Thanks for the input GeorgeV. I accept that the Moderator's idea is logical, sensible and a good thing to try, but sad to say, it brings me no luck. Plugging the wireless receiver into another USB port makes no difference (except that Windows immediately detects the keyboard as already described). Specifically, no 'new device detected' process occurs, so in the past I must have had the receiver plugged into all of the ports at some time or another. Within the Program Control, Programs, Access column none of the red Xed items come close to being associated with keyboard or USB functions.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •