I have ZA free,
version 6.5 and have been having trouble with vsmonapi.dll.
For ages ZA was perfect, but suddenly, as soon as anyone on this computer logged in, an error message telling me that "vsmonapi.dll" is not a valid windows image pops up and ZA control center doesn't start. The firewall is still functional, but I can't access any settings and it can't update itself or change settings on whether or not to block programs, which is a problem considering I have Firefox set to update itself. Now, ZA blocks Firefox from accessing the internet, because it's updated itself. I do still have internet access though, since I'm using the diseased computer to write this post, just through Internet Explorer (*gag*).
The reson for this I think is a hard drive error. I had to reinstall windows once on this computer, so it's dying and we have a new one, but I'd still like to keep this running as long as I can, considering the other computer
is a Vista laptop. I figure that both the problem I mention in the next paragraph and the vsmonapi.dll (as well as a completely unrelated to ZA problem with Directx (solved)) have been caused by a similar C:\ drive meltdown.
I could easily remedy this by simply doing a system restore to before Firefox updated itself and setting it to not update itself, but A. I still couldn't access controls to ZA, and B. when I try to do a system restore, I get 2 error messages, one saying that the system restore could not continue and the other says "The file or directory C:\System Volume Information\_restore{1E1CD5D2-F88D-4569-B1B4-46BC5949BCA}\rp143 is corrupt and unreadable. Please run chkdsk utility." Well this is all fine and dandy, I run chkdsk and it solves nothing.
A way to solve both of these problems would be to completely remove ZA from my system and reinstall. But of course, there's a problem with vsmonapi.dll again when I try to uninstall, clean or not clean, therefore I try to do a clean uninstall in safe-mode as directed to by this post http://forums.zonealarm.com/zonelabs...message.id=103. Now of course, something is causing my computer to not run in safe-mode. I try to reboot in safe-mode and the list of files scrolls down the screen as usual, but gets stuck and the hard drive is whizzing away, but it gets no where. I have no clue why this happens.
Now that you know what a pain in the *** this is, I'm asking:IS THERE A WAY TO DO A CLEAN UNINSTALL WITHOUT THE CONTROL CENTER AND WITHOUT SAFE-MODE?!?!?!?!
-He who has many patients, is a busy doctor

Operating System:
Windows XP Home Edition
Software Version:
6.5
Product Name:
ZoneAlarm (Free)


Message Edited by Ugh on 05-15-2008 04:39 PM