Results 1 to 8 of 8

Thread: Anti-Spyware will not update after ZA 7.0.483 upgrade

  1. #1
    dosvet Guest

    Default Anti-Spyware will not update after ZA 7.0.483 upgrade

    Hi -

    Until yesterday I had been using ZASS 7.0.473.00 without any problems, but I thought it was wise(?) to upgrade to 7.0.483.00 even though I have not been rushing to install the problem MS security update. I first updated my anti-virus and anti-spyware settings, ran a scan for both, backed up my settings, and backed up my harddrive. I downloaded the program from this site using Firefox, which has never caused me a problem in prior upgrades (including my updgrade from ZA 6.5 about two months ago). Following the procedure in GorgeV's recent posting, I unchecked "Load Zone Alarm on Startup" and rebooted before running the installer. I did an upgrade install rather than clean install because I was changing from the most recent version, and then rebooted. All seemed to go smoothly, and I can access the internet. Then I ran a manual check for anti-virus/anti-spyware updates. The download of new anti-virus DAT files took took a few minutes, but the update box said it was successful. However it then said that the anti-spyware update failed because:

    Cannot parse XML file C:\Windows\system32\Zonelabs\\ZoneAlarm.xml [The double \\ is not a typo.]

    I tried rebooting and trying again, and having ZA automatically check for updates in an hour, both without success.

    When one tries to open ZoneAlarm.xml in a firefox window one gets (with the opening less-than sign and closing greater-than sign around "\Server" deleted):

    XML Parsing Error: not well-formed
    Location: file:///C:/WINDOWS/system32/ZoneLabs/ZoneAlarm.xml
    Line Number 1, Column 4:

    ---^

    In DOS, I find the file has has the archive bit set and has 346 bytes, as compared to the .69 Kbytes in the file in the harddrive backup I made earlier. I hesitated to reset the archive bit and restore the old 7.0.473 version from the backup, because I didn't know if that would foul up anything elsewhere in ZA or in the registry.

    When opening my current ZoneAlarm.xml in DOS or Wordpad, one gets (with the less-than and greater-than signs that enclose each line deleted, because the posting program considers it to create invalid HTML):

    /Server
    Identity
    Platform Value="x86"/
    OS Value="win.nt.xp"/
    Language Value="en.US"/
    /Identity
    Features
    Feature Name="System" Version="7.0"/
    Feature Name="Firewall" Version="7.0"/
    Feature Name="Anti-Spyware" Version="7.0"/
    /Features
    Client Repository="Updates"/
    /Product

    I also notice that the ZA alert logs do not show the scans that I ran yesterday before the upgrade.
    Clicking on About provides:

    ZoneAlarm Security Suite version:7.0.483.000
    TrueVector version:7.0.483.000
    Driver version:7.0.483.000
    Anti-virus engine version:3
    Anti-virus SDK version:5.0.1.85
    Anti-virus signature DAT file version:957460824
    Anti-spyware engine version:5.0.189.0
    Anti-spyware signature DAT file version:01.200808.4385
    AntiSpam version:5.0.6.8903

    Help!

    Thanks

    Operating System:Windows XP Pro
    Software Version:7.0
    Product Name:ZoneAlarm Internet Security Suite

  2. #2
    hammernu Guest

    Default Re: Anti-Spyware will not update after ZA 7.0.483 upgrade

    Your update files may be corrupted. Do the following:
    1) Boot into Safe Mode

    2) Go to C:\Windows\System32\ZoneLabs\Updates

    3) Delete all files & folders

    4) Boot into Normal Mode

    5) Re-run Update

    If that doesn't work, try a database reset:
    1) Ctrl + Shift right-click on ZoneAlarm System Tray icon

    2) Click Reset in popup box

    3) Click Yes in Reset Settings dialog box

    4) Click OK when prompted to reboot

    5) Follow onscreen prompts after reboot

    And if still no success, re-download ZASS 7.0.483.0 from here using ONLY Internet Explorer:
    http://download.zonealarm.com/bin/fr...483_000_en.exe
    I realize that you've successfully downloaded ZASS from Firefox before, but you've been lucky. It's caused problems for many others. Why tempt fate?
    Do a clean uninstall follwed by a reinstall of ZASS that you just downloaded:
    1) Reboot into Safe Mode (repeatedly tap F8 as computer restarts)

    2) Append " /clean" (without quotes) to ZoneAlarm uninstall shortcut Target field




    modified Target field: "C:\Program Files\Zone Labs\ZoneAlarm\zauninst.exe" /clean

    3) Uninstall from shortcut;




    when ZoneAlarm requests a reboot, reboot into Safe Mode with Networking

    4) http://forum.zonelabs.org/zonelabs/b...message.id=103




    (begin after the 2nd *REBOOT in the webpage)

    5) Install ZoneAlarm in Safe Mode with or without Networking;




    when ZoneAlarm requests a reboot, reboot into Normal Mode

    Is Safe Mode really necessary? No. Does it guarrantee a successful reinstall every time? Yes, barring other circumstances (conflicts from other security products, etc.).

  3. #3
    dosvet Guest

    Default Re: Anti-Spyware will not update after ZA 7.0.483 upgrade

    Thanks, HammerNU, for your detailed response.

    I tried without success the instructions first for deleting the update files and then for doing a database reset. Neither technique resulted in an overwrite the Zonealarm.xml file and I continued to get the "cannot parse xml file" message when ZA tried to do an anti-spyware update.

    Next I used Internet Explorer to download ZASS 7.0.483.00, from the link that you provided, to a different folder than the one I used when downloading with Firefox. I then did two binary file compares at a command prompt, the first using the "comp" command and the second (after a reboot to clear the memory) using the "fc /b" command. Both compares reported no differences between the files. So I guess that my original mistake was doing an update install instead a clean install.

    Before I tackle a clean uninstall and clean install, per your instructions and message 103, is it safe to try replacing the corrupt ZoneAlarm.xml file with the ZA 7.0.473 version from the harddrive backup that I made just before installing the upgrade? Or might that mess up the ZA uninstaller or the registry. If the upgrade had gone properly, would the file have been the same?

  4. #4
    hammernu Guest

    Default Re: Anti-Spyware will not update after ZA 7.0.483 upgrade

    Good question about replacing the XML file. Personally, I wouldn't.

    Although not necessary, I always do a clean uninstall (the converse is a normal uninstall followed by a clean install). You can still preserve your settings (with a clean uninstall or install) by backing them up before uninstalling and restoring after the install. Of course, if your settings are corrupted, then you'll just be bringing the corruption into the new version.

    Try the clean uninstall / reinstall instructions that I gave you. Doing them in Safe Mode, though not necessary, guarantees a trouble-free experience since there will be no services or system routines running to cause conflicts.

  5. #5
    dosvet Guest

    Default Re: Anti-Spyware will not update after ZA 7.0.483 upgrade

    Problem now overcome, after clean uninstall and then install (both in safe mode), using your instructions and those in message 103. Also had to use GeorgeV's tip (in message 78551) for how to boot into safe mode when pressing the F8 key doesn't do anything.

    Many thanks.

  6. #6
    hammernu Guest

    Default Re: Anti-Spyware will not update after ZA 7.0.483 upgrade

    Glad it worked for you!

  7. #7
    tripplec Guest

    Default Re: Anti-Spyware will not update after ZA 7.0.483 upgrade

    I just attempted an upgrade of my 7.0.483 on my daughters PC. I had been reluctant to do it earlier since she is 500km away at University. While there I decide to do the update to the latest 8.0.059 suite since it was prompting her regularly for the update. While the install went smooth something went wrong. Same as you documented above. I cannot get any updates at all manually selecting update now. "cannot parse Zonealarm.xml" at the location as stated above in you detailed entry. I tried an reinstall, went to safe mode and deleted the update folder. But no success.
    I can't understand why new files being written are done so corruptly via a product bent on maintaining security. I now have to attempt to fix this remotely or use another firewall/spyware product.

  8. #8
    Join Date
    Jun 2006
    Location
    The 3rd Coast - South Central Texas
    Posts
    10,473

    Default Re: Anti-Spyware will not update after ZA 7.0.483 upgrade

    -------------------------------Updating problems can be caused by corrupted update definitions files. Please follow the steps below to remove an invalid update signature, then run the update again. Please proceed with the following:

    You will need to restart your pc in "Safe Mode". This can be accomplished by restarting your pc and pressing the F8 key as the PC starts up (BEFORE the first Windows screen with the black background) and then Select Safe Mode. If you have trouble restarting in safe mode please use this alternate method:
    - While in Normal Windows mode, Close all programs.
    - Click Start, Run and type MSCONFIG in the box and click OK
    - In the System Configuration Utility, on the BOOT.INI Tab and tick the "/SAFEBOOT" option in the Boot Options section.
    - Now click the OK button. After pressing the button you will be presented with an option to Restart or Exit Without Restart. Please choose the Restart option and the computer will now boot up into Safe Mode.
    Note: If you get a message asking to go to Safe Mode, choose Yes. If you get a help and support window, close this.

    When you are in safe mode make sure hidden files and folders are shown.
    To enable viewing of hidden files open My Computer/Computer. Depending on your OS click Tools or View and then Folder Options > View. Choose "Show Hidden Files and Folders", uncheck "Hide Protected Operating System Files" (Windows 2000/XP/2003 only) and click OK.
    NOTE: If you cannot see the menu bar with the Tools menu on it, you have to press the Alt-key on the keyboard and the menu bar should then be visible.

    Note: In the future steps if you do not see any files or folders, please click the "Show Files" link to view them.

    1. Click Start and open My Computer/Computer
    2. Double click the Windows folder
    3. Double click the System32 folder
    4. Double click the ZoneLabs folder
    5. Double click the Updates folder
    6. Delete ALL files and folders inside this "Updates" folder
    7. Close My Computer/Computer

    Close this window, then empty your recycle bin.


    You will need to start the pc in normal Windows mode. If you did not use the MSCONFIG program to enter Safe Mode then just restart your pc in the normal manner.
    IF and ONLY IF you used the MSCONFIG program to enter Safe Mode, please run it again and uncheck the "/SAFEBOOT" option on the BOOT.INI tab and click OK choose the option to restart your computer.

    When you restart your computer you may see a prompt from the Windows System Configuration Utility. Please tick the box for "Don't show this message or launch the System Configuration Utility when Windows start:" and then click OK.

    If you prefer not to always view "Hidden Files and Folders" and "Protected Operating System Files", you can reverse the steps explained earlier to disable this option.

    Open ZoneAlarm and go to AntiVirus/AntiSpyware on the left and the Main tab near the top right and click Update Now.--------------------------------------------------------
    My XP SP3 :
    ZoneAlarm Security Suite version:8.0.059.000
    TrueVector version:8.0.059.000
    Driver version:8.0.059.000
    Anti-virus engine version:6.0.2.678
    Anti-virus signature DAT file version:964190370
    Anti-spyware engine version:5.0.202.0
    Anti-spyware signature DAT file version:01.200811.4885
    AntiSpam version:5.0.61.9957
    -------------------------------------------------
    GeorgeV
    ZoneAlarm® Extreme Security


    Click here for ZA Support
    Monday-Saturday__ 6am to 10pm Central time
    Closed Sundays and Holidays

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •