Results 1 to 7 of 7

Thread: ZA 8.0.059.000 blocks Eclipse 3.3, have to disable ZA to start Eclipse, then turn on again

  1. #1
    dreng Guest

    Default ZA 8.0.059.000 blocks Eclipse 3.3, have to disable ZA to start Eclipse, then turn on again

    I just installed 8.0.059.000 upgrade, and in order to run Eclipse 3.3 (the Java IDE) I must completely shut down ZA. Eclipse reports "JVM terminated. Exit code=-1". After shutdown, I can start Eclipse, then start ZA and use Eclipse to run/debug as usual.

    This behavior never happened with my ZA 7.xxx. ZA logging and alerts are at highest levels, but absolutely no log or alert entries appear.

    None of my Java platform programs are blocked, they are all given either Super or Ask trust levels. Eclipse is given Super trust.

    Can someone please tell me what is happening?

    Operating System:Windows XP Pro
    Software Version:8.0
    Product Name:ZoneAlarm Internet Security Suite

  2. #2
    sal_e_mander Guest

    Default Re: ZA 8.0.059.000 blocks Eclipse 3.3, have to disable ZA to start Eclipse, then turn on again

    I have the same problem only the problem seems to be 6 months old now.

    Since I install the 8.0.3 version of ZoneAlarm extreme I cannot run Eclipse IDE without unloading ZoneAlarm. I have used one of the previous version since 2000 so I am familiar with the ZoneAlarm firewall.

    Someone have a resolution?

    Sal

  3. #3
    dreng Guest

    Default Re: ZA 8.0.059.000 blocks Eclipse 3.3, have to disable ZA to start Eclipse, then turn on again

    Sal, it looks like we need to try to get somebody's attention. This is a ridiculous problem. I had to revert to ZA 7.x to fix the problem. Today I upgraded to ZA 8.4xx and the problem is still there, 6 mos. later. Are we supposed to pay $50 to talk to someone about a deficient software program?

    If you learn anything new, please write in.

  4. #4
    Join Date
    Jun 2006
    Location
    The 3rd Coast - South Central Texas
    Posts
    10,465

    Default Re: ZA 8.0.059.000 blocks Eclipse 3.3, have to disable ZA to start Eclipse, then turn on again


    <BLOCKQUOTE><HR>dreng wrote:
    Sal, it looks like we need to try to get somebody's attention. This is a ridiculous problem. I had to revert to ZA 7.x to fix the problem. Today I upgraded to ZA 8.4xx and the problem is still there, 6 mos. later. Are we supposed to pay $50 to talk to someone about a deficient software program?

    If you learn anything new, please write in.
    <HR></BLOCKQUOTE>There are Over 60 Million Users of ZoneAlarm world Wide.. and Very Few People ever log onto a Support Forum to say how Great the Program is, This Forum exist to help the Few Users who encounter a problem and need to be guided in the right direction..http://s118.photobucket.com/albums/o...h_1welcome.gif to the Zone Alarm User Forum..It looks like your Have Corrupted your Installed ZA files..The simplest procedure is to :1.Download the Latestinstallerpreferably with IE Browserand no Download Manager/accelerator like Get-Right, Livewire, BitTorrent) (MultiPlatform,installer will install on Both WinXP and Vista)ZASS http://download.zonealarm.com/bin/fr...seHistory.html2. On your current ZA, UNcheck "Load ZA... at startup" (under Overview --&gt; Preferences tab)3. Reboot the Computer. So that vsmon.exe/TrueVector will be removed from Memory4.) Now use the new ZoneAlarm Removal Tool: Click here &gt; http://download.zonealarm.com/bin/fr...cpes_clean.exeSave to desktop, right click and "run as administrator"This tool will remove all ZoneAlarm products from your system.

    Please just download and run the tool, following the instructions.
    (you can un-install without net connections)5.) Install the new update (clean or upgrade) and Accept the default Setting, Auto-Learn Mode and Choose Trusted Zone, not Internet Zone..NOTICE:Please note that ZASS and ZAXSdo not play nice with many overlapping security tools (even if disabled). To troubleshoot ZASS/ZAXS issues removethe other Security programsand install them back once you see that ZA works as it should. For example,Norton/Symantec, McAfee,AVG, Spyspweeper, Spyware Doctor, trojan hunter, adware, SpyBotS&amp;D, PC tools Threat Fire, any otherAnti-virus, Anti-spyware, Registry Guard or locking tools, etc...
    =================================If the Above Solution does not work, then as a Licensed user you can contact Checkpoint Customer Service or Tech Support Free of chargeThis User Forum exist to help the Few Users who encounter a problem and need to be guided in the right direction by Other more Experienced Users..
    ZoneAlarm Tech Support and Customer Service do notRead or Monitor this Forum..There arethree Seperate Web-links for these Services..Live Chat mode : http://www.zonealarm.com/security/en...ce-support.htmCustomer Service www.zonealarm.com/csformZA Tech Support (Requires Valid ZA License Key) www.zonealarm.com/tsform---------------------------------------

    http://i118.photobucket.com/albums/o...4990GV_sig.jpg
    ----------------------------------------------------------------
    ZoneAlarm Extreme Security version:8.0.400.020
    TrueVector version:8.0.400.020
    Driver version:8.0.400.020
    Anti-virus engine version:6.0.2.678
    Anti-virus signature DAT file version:986226117
    Anti-spyware engine version:5.0.209.0
    Anti-spyware signature DAT file version:01.200906.6065
    AntiSpam version:6.0.0.1429
    ZoneAlarm ForceField 1.3.153.0
    ZoneAlarm ForceField Anti-Phishing Database 1.2.95.0
    -----------------------------------------------------------------
    2nd Computer WinXP SP3 32-Bit
    ZoneAlarm Security Suite version:8.0.400.020
    TrueVector version:8.0.400.020
    Driver version:8.0.400.020
    Anti-virus engine version:6.0.2.678
    Anti-virus signature DAT file version:986226117
    Anti-spyware engine version:5.0.209.0
    Anti-spyware signature DAT file version:01.200906.6065
    AntiSpam version:6.0.0.1429
    ----------------------------------------------------------------------
    GeorgeV
    ZoneAlarm® Extreme Security


    Click here for ZA Support
    Monday-Saturday__ 6am to 10pm Central time
    Closed Sundays and Holidays

  5. #5
    dreng Guest

    Default Re: ZA 8.0.059.000 blocks Eclipse 3.3, have to disable ZA to start Eclipse, then turn on again

    The cause of the Eclipse crash was not corrupt ZA files.

    The cause was most certainly in the way ZA interprets the Eclipse configuration in the Windows user account's settings. If I logged in as an administrator on my machine, with the latest ZA ES, I discovered I can run the very same Eclipse version that fails under my normal user account. I run under regular user privileges almost all the time, for security reasons.

    I also discovered that under my regular user account, an older version of Eclipse (3.2) runs just fine. Therefore, something about my Eclipse 3.3 configuration (and I have installed/uninstalled several plugins) was not acceptable to ZA ES, causing failure.

    Many thanks to Kelly on the ZA tech support Live Chat feature for helping to discover all this. Kelly (s/he?) spent much time with me, even downloading Eclipse (~90MB!!) and demonstrating it actually worked on his/her machine. This led me to more testing. I must say I am impressed with this level of committment to reproducing a problem! And, it didn't cost a dime (except for significant time).

    Rather than pinpoint the exact configuration problem, which the error messages indicate is likely in the osgi or equinox.launcher modules, I ultimately resolved the issue by upgrading to Eclipse 3.4.2 (I had been trying to avoid the potential pain of changing my development environment). ZA can now apparently coexist with this clean install of Eclipse. I'm guessing I could have reinstalled 3.3 with a clean plugin setup and it probably would have worked, too.

    Hope this helps someone, and maybe Sal.

  6. #6
    Join Date
    Nov 2004
    Location
    localhost
    Posts
    17,286

    Default RESOLVED: ZA and Eclipse conflicts--> Upgrade to 3.4. + ZA technical support --> THUMBS UP!

    Hi!thank you for taking the time to report how you resolved the issueas well as the good experience with ZA official support.Cheers,Fax

    Message Edited by fax on 06-11-2009 11:10 PM

    Click here for ZA Support
    Monday-Saturday 6am to 10pm Central time
    Closed Sundays and Holidays

  7. #7
    Join Date
    Jun 2006
    Location
    The 3rd Coast - South Central Texas
    Posts
    10,465

    Default Re: ZA 8.0.059.000 blocks Eclipse 3.3, have to disable ZA to start Eclipse, then turn on again

    Thank you for your progress Report..
    GeorgeV
    ZoneAlarm® Extreme Security


    Click here for ZA Support
    Monday-Saturday__ 6am to 10pm Central time
    Closed Sundays and Holidays

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •