Results 1 to 2 of 2

Thread: Solution to upgrade install error

  1. #1
    maromanphd Guest

    Default Solution to upgrade install error

    I have struggled with the "c\Docume~1\[username]~1\Locals~1\Temp\121208124759\vsutil.dll ... configuration is incorrect: error after updating to ZA AV 8.0. I have tried EVERY solution proposed on this forum and on other forums. Clean install, manual removal, registry changes, etc. I thought I would have to trash using ZA - a real shame because I believe it to be the best firewall on the market. The solution that finally worked (which appears nowhere on this forum to my knowledge) was to go to the very directory and run Microsoft_VC90_ReleaseCRT_x86.msi. This produced a message that the windows installer service was not working. Following this Microsoft link http://support.microsoft.com/kb/315353 leads to a solution, essentially unregistering and reregistering the installer service. After this, I went back to the directory and reran Microsoft_VC90_ReleaseCRT_x86.msi (by double clicking) and voila! ZoneAlarm installs when I click on the update. I must admit that this last step, running Microsoft_VC90_ReleaseCRT_x86.msi again, may be unnecessary, but after hours of trying to solve this and getting to the point of despair that ZoneLabs could not fix this. it turns out it was a Windows problem and not a ZoneAlarm problem. This may explain why many people have NOT had this problem while clearly some have. I hope this helps.

    Operating System:Windows XP Pro
    Software Version:8.0
    Product Name:ZoneAlarm Antivirus

  2. #2
    naivemelody Guest

    Default Re: The Windows Installer Service could not be accessed...

    Thanks for posting back your solution; interesting.
    -
    Click here >
    http://support.microsoft.com/kb/315353<hr>&quot;The Windows Installer Service Could Not Be Accessed&quot; error message when you install a program in Windows XP
    This can occur if you are running Windows in safe
    mode, or if the Windows Installer is not correctly
    installed.
    To resolve this issue, follow these steps:
    1. Log on to your computer as an administrator.
    2. Click Start, and then click Run.
    3. In the Open box, type cmd, and then click OK.
    4. At the command prompt, typemsiexec.exe /unregister, and then press ENTER.
    5. Type msiexec /regserver, and then press ENTER.
    6. Verify that the SYSTEM account has full control access permissions to the HKEY_CLASSES_ROOT hive in the Windows registry. In some cases, you may also have to add Administrator accounts. To do so:Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:<div class="indent">322756
      (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows
      1. Click Start, click Run, type regedit in the Open box, and then click OK.
      2. Click the following registry hive:<div class="indent">HKEY_CLASSES_ROOT
      3. On the Edit menu, click Permissions.
      4. If SYSTEM is not listed in the Group or user names list, click Add, make sure that the local computer name appears in the From this location box, type system in the Enter the object names to select box, click Check Names, and then click OK.
      5. Click SYSTEM in the Group or user names list, and then select the Full Control check box under Allow in the Permissions for SYSTEM box.
      6. Click Apply, click OK, and then quit Registry Editor.
    7. Restart the computer...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •