I realize that this fix has been posted elsewhere in bits and pieces and in various forms.
I'm reposting it here in its entirety.

NOTE: This fix applies to users of Toshiba Laptops.
It may also apply to any other Laptop users with Atheros security.
The culprit for Toshiba laptop users is an installation known as "Atheros Wi-Fi Protected Setup Library".
This program does NOT provide Wi-Fi security; instead, it allows the user to more easily set up Wi-Fi
security features.

It is not necessary for the operation of your Wi-Fi or your computer, and it can be safely uninstalled without any adverse effects.
Here is the procedure to follow:

1) Go into Programs and Features and locate the entry "Atheros Wi-Fi Protected Setup Library".

Uninstall this.
2) Uninstall your ZoneAlarm software.
3) Go into Services (Start/Run, and type in services.msc) and disable both Windows Defender and Windows Firewall.
Don't just turn them off.
Disable them by right-clicking on the service names, choosing Properties, and in the dropdown box by "Service Type", choose "Disabled", then "Apply"
.
4) Turn off Protected Mode in Internet Explorer.
You can do this in Internet Options/Security by unchecking the box next to "Enable Protected Mode"
(You can try turning it back on later).
5) Run the ZoneAlarm Removal Tool found here: http://download.zonealarm.com/bin/fr...cpes_clean.exe
.
It will ask you to reboot your computer.

7) When your computer reboots,
reinstall ZoneAlarm and follow the prompts.
This should allow ZoneAlarm to function normally when your computer restarts.


It may take a couple of minutes to initialize.
At this time, you can try to turn "Protected Mode" back on in Internet Explorer, although I personally don't recommend it.
If problems occur, you can turn it back off.
I recommend that you leave Windows Defender and Windows Firewall disabled, as they may interfere with
ZoneAlarm, and ZoneAlarm will be providing the same (and more) protection as they did.
I hope that this helps.