Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Zone Alarm Acting Strange

  1. #1
    weatherologist Guest

    Default Zone Alarm Acting Strange

    Any help or suggestions would be appreciated.

    Today I started having problem with my Zone Alarm Firewall. It would only let a very few websites through. When I shut zone alarm off and used the windows xp firewall...everything was fine. On the firewall settings I am using the High Setting on both the Internet Zone Security and Trusted Zone Security. I have used these both like this for over a year now with no problems. I also tried signing on with AIM. AIM has Zone Alarm privledges and if I sign on AIM, start Zone Alarm, AIM gets booted...its like Zone Alarm is blocking everything all of a sudden.

    Please help.

    Operating System:Windows XP Home Edition
    Product Name:ZoneAlarm (Free)

  2. #2
    billc Guest

    Default Re: Zone Alarm Acting Strange

    This sounds to me like some ZA Pro features have been turned on by a corrupt database. Although you will lose your ZA settings and need to 'allow' program access anew, I'd suggest you reset your database to see if that helps.

    1. Boot your computer into the Safe Mode. {Instructions if needed}
    2. Navigate to the c:\windows\internet logs folder.
    3. Delete the backup.rdb and iamdb.rdb files in the folder.
    4.Reboot into the normal mode.

  3. #3
    weatherologist Guest

    Default Re: Zone Alarm Acting Strange

    Bill:

    I'll let you know if that works. I'll be back!

    Chad

  4. #4
    weatherologist Guest

    Default Re: Zone Alarm Acting Strange

    Bill:

    That seemed to work. Thanks. There were numerous version of both of those files. Is that normal?

    Example:

    backup(2)(2).rdb
    iamdb(3)(2).rdb

    There were about 8 or 9 types of these files with different numbers. I deleted the two that had no numbers.

    Also...after I rebooted...Zone Alarm alerted me that the Generic Host Process for Win32 Services had been blocked. I went to the programs and allowed it access in the Server - Internet. Was this the right thing to do? That has never happened before either.

    Thanks.

    Chad

  5. #5
    billc Guest

    Default Re: Zone Alarm Acting Strange

    Strange, I would only expect to find one of each which leads me to think that the multiple copies could be causing you problem. It will not hurt to remove them all, but the ones you did remove where the correct ones.

    About Generic Host Process. You should grant it 'access' in both zones but 'server' rights only in the Trusted Zone column and not the Internet zone.

  6. #6
    weatherologist Guest

    Default Re: Zone Alarm Acting Strange

    Bill:

    Interesting...Zone Alarm only started working when I granted the Generic Host Process access in the Internet Server Zone.

    Should I reboot in safe...and delete all those files?

    Chad

  7. #7
    billc Guest

    Default Re: Zone Alarm Acting Strange

    It is OK to grant GHP 'access' to both the Trusted and Internet zones. But do not grant 'server' rights to the Internet zone.

  8. #8
    weatherologist Guest

    Default Re: Zone Alarm Acting Strange

    Bill:

    Just to make sure I have this right and there is no confusion these are my current settings for GHP that do not work:

    Under Access:
    Trusted: Allowed
    Internet: Allowed

    Under Server:
    Trusted: Allowed
    Internet: Blocked

    Under that config I get basically no movement on the net.

    It only works when:

    Under Access:
    Trusted: Allowed
    Internet: Allowed

    Under Server:
    Trusted: Allowed
    Internet: Allowed


    Is this a problem?

    Thanks for all your help.

    Chad

  9. #9
    billc Guest

    Default Re: Zone Alarm Acting Strange

    You should not need to great GHP 'server' rights in the Internet Zone as you indicated. Do you have your DNS server IP in the Trusted Zone of your Firewall > Zones panel? It could be you have it in the Internet Zone. In case you don't know, here is how to find the DNS IP.

    1. Go to Run type in command , hit 'ok', and type ipconfig /all then press enter. In the returned data list will be a line DNS and DHCP Servers with the IP address(s) listed out to the side.
    2. In ZA on your machine on the Firewall>Zones tab click Add and then select IP Address. Make sure the Zone is set to Trusted.
    3. Click OK and then Apply and see if that works to fix it..

    If you do that, are you then able to access the internet without Internet server rights granted to GHP?

  10. #10
    weatherologist Guest

    Default Re: Zone Alarm Acting Strange

    Bill:

    Thanks, I think that did it. My IP was listed but not "trusted". Everything seems fine now. I have now clue how that "magically" changed. Must have been the lucky charms I had this morning.

    Thanks.

    Chad

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •