Results 1 to 3 of 3

Thread: Front task pain

  1. #1
    lawd Guest

    Default Front task pain

    Why does zone alarm always jump in front of a task ?
    Like here, i am typing away and dont notice the firewall has jumped up, my typing on here stops and the firewall reacts to the A in "reacts" and accepts that as a response.
    How can we stop this ?????

  2. #2
    st_john_clark Guest

    Default Re: Front task pain



    Hello Lawd

    What you are saying is typing the key "A" prompts program access?



  3. #3
    mkp Guest

    Default Re: Front task pain

    >>What you are saying is typing the key "A" prompts program access?
    Not quite, if what he's seeing is what I've seen.
    I don't see this very often, partly because I try to configure as many of my programs ahead of time as possible, and partly because I'm usually looking at my monitor when I'm typing
    ; )
    1.
    You're typing in the current foreground application.
    It has the keyboard focus right now.2.
    A background task begins to do something, such as access the Internet.3.
    You haven't told ZA what to do about that before, or you haven't told ZA to "remember" it.4.
    ZA pops up an alert, with "Allow" (notice the underlined indicator) as one of the options.
    This window is now in the foreground and has the keyboard focus.5.
    All keystrokes except the hotkeys are ignored, and the hotkey that "randomly" occurs first in your typing stream (in Lawd's case, 'A') is taken as input to ZA, causing action on the background task, such as allowing it to access the Internet Zone.
    This may have been a bad thing.
    Note that I personally oppose the idea of getting rid of the hotkeys, since I actually use them frequently.
    (I'm not a big fan of the mouse.)
    You also shouldn't just tell it not to bring the alert to the front, since then you won't know about it, most likely.
    The correct choice, I think, is to require Alt+A, etc., just like Windows does with its own underlined letters.

    Why this "standard" wasn't emulated in the first place is anyone's guess.
    As a temporary workaround, if you don't mind answering all alerts with, e.g., "deny," you can use "Game Mode" while you're typing.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •