Results 1 to 2 of 2

Thread: Firefox and Zone Alarm Problems

  1. #1
    dramagirl Guest

    Default Firefox and Zone Alarm Problems

    I recently downloaded the newest version of Mozilla Firefox, which I use as my internet browser.
    Now, when I open firefox, it won't detect that I am connected to the internet.
    I have tried uninstalling and re-installing Firefox, but to no avail.
    I also tried this solution which I found on the Firefox User Forum:
    "There have been many reports about this problem since the release of ZoneAlarm version 3. There is a bug in ZA that will cause its database to become corrupt. This usually happens after you upgrade to a new ZA release, but it can also happen after you restart your computer, etc.

    ZoneLabs recommends that you uninstall ZoneAlarm, delete all files in the Internet Logs folder and reinstall ZoneAlarm. But, the problem has been narrowed down to one specific file (IAMDB.RDB). Here is an easier way to solve the problem:<ul>[*]Shut down ZoneAlarm[*]Open the folder C:\Windows\Internet Logs
    (or C:\WinNT\Internet Logs if you're running Windows NT or 2000).[*]Delete the file IAMDB.RDB[*]If the file BACKUP.RDB exists delete that file as well[*]Restart your computer[*]Start ZoneAlarm (the file IAMDB.RDB will automatically be recreated)&quot;[/list]

    *BUT* my computer will not let me delete these files.
    I have Zone Alarm updated and will all the right settings - I deleted and added Firefox under the Program Control Tab, and gave Firefox trusted access to the internet.
    Is there anything else I can do?
    I can't find any more help on the Firefox website...

    Thanks!

    DramaGirl

    Operating System:Windows XP Home Edition
    Product Name:ZoneAlarm (Free)
    Software Version:

  2. #2
    critterjoe Guest

    Default Re: Firefox and Zone Alarm Problems

    Don't worry about the database reset right now--you can do it if the following fails (those instructions you listed are incorrect anyway (you don't have to shutdown ZA, and the remainder has to be done in Safe Mode). Upgrading Firefox does not commonly corrupt ZA's database. Usually after a new version of Firefox is installed, the most common problem is failure to set the firewall to the proper configuration. Be sure you have the access permissions configured as below.

    I see you are using the free version of ZA. Here are the settings Firefox needs when using ZA:

    trusted access - checkmark
    internet access - checkmark
    trusted server - ?
    internet server - ? or X

    Some people will need generic host (svchost.exe) set this way:
    trusted access - checkmark
    internet access - checkmark
    trusted server - checkmark or ? (some people have connectivity problem with a ?, others don't)
    internet server - ? or X

    If everything still fails with the above settings, you could then try the database reset. It can't hurt anything, except be aware that you will lose all your customized security settings and all customized settings for the programs in the program list; i.e., you will be starting over with ZA choosing configurations that you can customize again, similar to its &quot;virgin&quot; configuration after a new install. But if you do the reset use these instructions:

    Look at your firewall settings for your network so you can restore them after the reset if necessary. Go to the Control Panel to Firewall|Zones tab and write down the settings. If you've customized other areas, also write down any of those settings that you might need help to remember.

    Reboot into Safe Mode. (to get to Safe Mode, tap the F8 key during bootup and choose &quot;safe mode&quot; )
    Find the c:\windows\internet logs folder.
    Find and delete these 2 files: iamdb.rdb and backup.rdb (these will only delete in safe mode)
    Empty the Recycle Bin.
    Reboot into Normal Mode. (this is a routine reboot, no need to tap F8 again).

    ZA will rebuild the iamdb.rdb and backup. rdb files from square one. Now you can customize all the programs like you want.

    Note: ZA will likely identify your network as a &quot;new network&quot;, which is normal. You may need to tell it what zone you want it in, or it will default to one. A reset also won't automatically put the loopback adapter into the trusted zone. You have to manually put the loopback adapter 127.0.0.1 if one was there previously. (Look at the firewall settings you wrote down before the reset.)

    Good luck. Post back on your results or any continued problem.

    Message Edited by Critterjoe on 01-09-200702:38 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •