Results 1 to 10 of 10

Thread: vsmon 100% CPU usage

Hybrid View

  1. #1
    huku Guest

    Default vsmon 100% CPU usage

    After upgrading the ZoneAlarm Pro from version 7.0.337.000 to 7.0.408.000 vsmon.exe began to use 100% of CPU, so my notebook became unusable. Restarting doesn't help. I leaved the program for a few hours (in case that it has something to finish). The only result was the increasing of the CPU temperature up to 70 C. Shutting down the ZoneAlarm Pro was the only helpful solution. I don't think that the downgrade to v.7.0.337.000 is an option. Waiting for next version - too. Now I am without any firewall. How can I find what cause vsmon.exe to use such a CPU resources?

    My machine is HP Compaq nx6110
    CPU Pentium M 1.7 Ghz
    RAM 512 MB
    OS Windows XP Pro SP 2

    Operating System:Windows XP Pro
    Software Version:7.0
    Product Name:ZoneAlarm Pro

  2. #2
    watcher Guest

    Default Re: vsmon 100% CPU usage

    Dear Huku:

    I have not seen or experienced your specific problem but there have been many forum members, including myself, that have experienced CPU spikes by vsmon.exe when first starting the Internet session. On systems such as your laptop, and mine, the CPU utilization goes to 100%. On mine, this used to last for about 30 seconds-1 minute. For desktops with CPUs double the clock speed of ours, the CPU utilization was 50%, with similar duration.

    Forum member darkkronos posted a fix for a slow bootup which I tried, to see if it resolved that problem, but it didn't work. What it did do, however, was eliminate the CPU spike when first connecting to the Internet. I'm not sure if this will work for you but there is no harm in trying. Click Anti-spyware panel, then Spy Site Blocking tab, and set Spy Site Blocking to Off. Reboot if this is a broadband connection. Please post your results. You can always set this back to On.

    Hope this helps.

    WATCHER

  3. #3
    naivemelody Guest

    Default Re: vsmon 100% CPU usage

    Other options: not just re-start, but a re-boot.<hr>Sometimes an upgrade does not go clean, with the old ZA (leftover files/corrupted) with the new install. Suggestion -1- un-install your current ZA with the following - http://www.nohold.net/noHoldCust25/P...n_install.html
    .2 -
    Then download the latest 7.0.408 -http://download.zonealarm.com/bin/fr...seHistory.html
    . You can enter your current active paid key when asked. Tips: better to use Internet Explorer 6/ 7 to download ZA (instead of Firefox, or others), don't use web accelerators nor download managers, temporarily shut-off/shutdown or uninstall other security software like anti-spyware (Spysweeper, SpywareDoctor, CounterSpy, etc.)<hr>Question - what anti-virus are you using?? Please post back on that, too. Many of today's popular anti-virus software include firewall-like capabilities - which does conflict with ZA. Little known and hard to recognize these conflicts. It may be recommended, just prior to downloading/installing the new ZA, as outlined above - to temporarily shut off the anti-virus. You may want to list not only your anti-virus but other security/ monitoring/ performance software, as these too, can be sources of conflict with ZA = high CPU.<hr>:8}NaiveMelody NYC 10-24-07 - We Just Disagree - Dave Mason

  4. #4
    huku Guest

    Default Re: vsmon 100% CPU usage

    I am using NOD32 anti-virus and no resident anti-spyware. All my programs are the same - befor and after the installing of a new (7.0.408) version.
    For monitoring I am using Process Explorer v.11.02. (www.sysinternalc.com). There's no conflict between ZA and Process Explorer. I closed the PE, but the CPU still was 100% used by vsmon.exe.

  5. #5
    britisher Guest

    Default Re: vsmon 100% CPU usage

    I've experienced this and found a fix that works for me. My details are somewhat different to the orginal poster's so I'll give you some background and see if this helps someone:
    I have Zonealarm Free Edition version 7.0.462.000. Since installing it I noticed that vsmon uses 100% CPU for
    around 6 seconds approximately once every 60 seconds. There is a corresponding small rise in the size of my page file.
    This has being going on all day every day ever since I
    upgraded ZA to the latest version - about two weeks ago.
    Although not as damaging as some in this thread, the regular slowing of my other programs due to vsmon was annoying.
    I can reliably fix the problem by:
    Switching to the Anti-Virus Monitoring tab and switching OFF monitoring of anti-virus security status. As both Windows and my anti-virus software monitors this anyway, I don't see the point in it. It was turned on by default.
    A little more detail that might help: I use SOPHOS Anti-Virus version 7.0.6. When ZA's anti-virus security status monitoring is switched on, ZA identifies 'sophos.icm' as being the installed anti-virus software but wrongly states that it is not running. It does, however, report that it is up to date.
    I can only guess that the problem is something to do with ZA not recognising my anti-virus software correctly. Perhaps it is searching or scanning regularly?
    I don't know about you guys, but I would happily pay a small fee for a
    fast, lean and junk-free
    version of Zone Alarm which uses few resources but has the brilliant Zone Alarm firewall engine. I don't want it to monitor my anti-virus,
    check for spyware
    or come with all the extra junk that can be activated as a secondary revenue stream needed to pay for the free version. Free normally comes at a price!

  6. #6
    dgschoc Guest

    Default Re: vsmon 100% CPU usage

    Try this:
    Double click the
    ZA icon in the tray so that the application window is displayed.
    Without first closing the ZA window, reboot.
    The ZA application should remember its state from the previous session and remain visible after the reboot.
    At this point, you can close the ZA window and your system should behave normally for the rest of the session -- without the CPU hogging issues.
    I leave my PC on 24x7, but I've gotten into the habit of simply opening ZA
    before rebooting and I've had no problems since.
    If I reboot without first opening ZA, my CPU usage spikes upon
    opening IE and the machine is basically useless for a couple of minutes.

  7. #7
    huku Guest

    Default Re: vsmon 100% CPU usage

    Unfortunately it doesn't work for me. My CPU usage raises to 100%, no matter what program or process I close or kill.

  8. #8
    dgschoc Guest

    Default Re: vsmon 100% CPU usage

    Don't close or kill anything...
    Simply open ZA by double clicking on its system tray icon and then while ZA is still open, reboot.
    Once the machine has rebooted and ZA comes up, you can close the window, which minimizes it back to the system tray.
    It works on all three of my computers, hopefully it will work on yours as well.

  9. #9
    huku Guest

    Default Re: vsmon 100% CPU usage

    Thanks, dgschoc.

    I tried to do things the way you recommended.

    Vsmon still continued to use 100% of CPU resources (and 72 MB of RAM, and 800 MB I/O Bytes - on the average) after this way of rebooting.

    Unfortunately it doesn't work for me, but I noticed the following: this way of rebooting forces vsmon.exe to run as an ordinary program, not as a windows service (it's standard behavior). In my opinion, most of the software that can be started as a service and as a program, works better when it is started as a service. (You can inspect running services and programs using Sysinternals Process Explorer.) That's why I thing that the ZoneLabs programmers have still work to do with this version.

    At the time when I struggled with ZoneAlarm, I found a more simple way to force vsmon.exe to run as an ordinary program, but not as a service (the same effect as rebooting with ZoneAlarm Control Center restored/maximized).

    First restore/open ZoneAlarm Control Center.
    Choose &quot;Overview&quot;, &quot;Preferences&quot; tab.
    Uncheck &quot;General&quot; - &quot;Load ZoneAlarm Pro at startup&quot;.
    Create a shortcut to zclient.exe (from ZoneAlarm folder) and put it in your startup folder.
    Reboot.
    Voila!

    After finishing this, every time you start your computer zclient.exe will start vsmon.exe as a program (not as a service). ZoneAlarm will display a message &quot;ZoneAlarm is starting ... ... to shut it down click &quot;Cancel&quot; ...&quot; (or something like this) for a few seconds and then will stay at the tray. After this you don't have to reboot your computer with ZA restored any more.

  10. #10
    huku Guest

    Default Re: vsmon 100% CPU usage

    I didn't find a conflict of ZAPro v.7.0.408.000 with any other software on my notebook. I closed (or killed) all active programs and processes (except Windows core process) one by one with no use, the vsmon activity remained 100% after couple of seconds.

    Finally I uninstalled ZAPro v.7.0.408.000 with options, recommended by NaiveMelody (&quot;C:\Program Files\Zone Labs\ZoneAlarm\zauninst.exe&quot; /clean /rmlicense), installed the ZAPro v.6.0.631.002 (notwithstanding that the I can't activate the anti-spyware protection on it. Anyway the 7.0 anti-spyware finds only my RealVNC after 20 minutes scanning with 99% CPU usage. I won't miss it.)

    Now my machine boots up twice faster and works apparently faster too.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •