Results 1 to 3 of 3

Thread: Zonealarm trying to access router, blocking webpage access

  1. #1
    crashtest Guest

    Default Zonealarm trying to access router, blocking webpage access

    Hello. I've been using Zonealarm for years and have periodically encountered the problem of it preventing access to webpages, even though the settings show that nothing is blocked. This has frequently led me to have to shut off zonealarm to access the web and lessen the frustrations of those around me, as well as my own, at the expense of much needed security. I will try to give as much info as possible, if anything is unclear I can clarify.

    Basically what I'm noticing during recent blockage of webpage access is a popup alert for generic host process. I always allow generic host processes access, but this one gets blocked on its own, and it appears to be trying to access a router. It also seems to happen randomly. Sometimes it allows access, sometimes it blocks, but most of the time it's blocked. The message is something like "firewall has blocked internet access to "192.168.1.1" (or whatever that router type addy is) and that generic host process is trying to access it. Also there is mention of "DNS" in the message. I'm not using a router and there is nothing being blocked in the "programs" list. It also still happens if i clear the "programs" list and manually set all the permissions again. If anyone knows off the bat what the problem is, I'd greatly appreciate some help, if not I can be more specific and post the exact message. Thanks.

    Zonealarm Free 7.0 Windows XP Home (wouldn't allow menu choices on edit)

    Message Edited by crashtest on 12-09-2007 01:31 PM

  2. #2
    Join Date
    Apr 2004
    Location
    East Coast of Florida - Lightening/Shark Bite Capital of the World
    Posts
    2,477

    Default Re: Zonealarm trying to access router, blocking webpage access



    Hi,

    Welcome to the Forum!

    PLEASE give Generic Host Process Server Rights in the Trusted Zone and full Access rights. And yes, a red cross for Internet in the Server section. PLEASE empty the Trash folder in FireFox or empty the cache from your current browser. Then empty your recycle bin. PLEASE reboot and try it again.

    Make sure your DNS and DHCP server IP's are in your Firewall's Trusted zone. Finding DNS and DCHP servers, etc

    1. Go to Run type in command , hit 'ok', and type ipconfig /all then press enter. In the returned data list will be a line DNS and DHCP Servers with the IP address(s) listed out to the side.
    2. In ZA on your machine on the Firewall>Zones tab click Add and then select IP Address. Make sure the Zone is set to Trusted.
    3. Click OK and then Apply and see if that works to fix it.
    4. The loopback or localhost (127.0.0.1) must be listed as Trusted.
    5. The Generic Host Process (svchost.exe), in the Program Control Program list, must have server rights for the Trusted Zone.
    Plus it must have both Trusted and Internet Access and three green bars.

    PLEASE keep me posted on your results, THANKS.

    SlyFox
    "Politeness costs nothing and gains everything".

    Click here for ZA Support

    Avail. 24x7 - Excl. Holiday













  3. crashtest Guest

    Default Re: Zonealarm trying to access router, blocking webpage access

    Thanks for the quick response. It seems to be working now that I've given generic host process automatic access, but if the problem persists I will try the ipconfig method. Thanks for the advice.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •