Results 1 to 8 of 8

Thread: ZASS 7.0.x locks computer

  1. #1
    joem Guest

    Default ZASS 7.0.x locks computer

    ZASS appears to lock portions of the computer for multiple minutes at somewhat random times. This has been gradually getting worse. First noticed in build 470. Updated in place to 483 with no major symptom change, just a continued worsening in what is starting to look like an exponential curve.

    During the lockups there is low CPU utilization, but vsmon.exe shows heavy disk I/O with bytes read often in excess of 1GB during each halt. During these times the mouse pointer moves. I cannot do much else. Often happens when starting a program (the start menu stays up during the halt). Sometimes I can restore the Windows Task Manager (from minimized), sometimes I cannot. It eventually clears itself if I wait long enough (varies, at times 5 to 15 minutes).

    The problem stops if I shut down ZASS.

    Dell Latitude D620, 2GB RAM, 100GB disk. WinXP Pro SP2 "current" (KB951748 installed without symptoms and then uninstalled before updating to build 483 -- all this had no noticeable affect on lockups).

    Any ideas what's going wrong and how to fix it? I tried ZA email tech support before realizing how slow it will be.

    Thanks,

    Joe M

    Operating System:Windows XP Pro
    Software Version:7.0
    Product Name:ZoneAlarm Internet Security Suite

  2. #2
    dslchiphead Guest

    Default Re: ZASS 7.0.x locks computer

    Exact same condition here. Very high Read I/O with the VSMON.EXE process. No CPU usage by VSMON. System crawling due to the disk contention.

  3. #3
    dslchiphead Guest

    Default Re: ZASS 7.0.x locks computer (Maybe Firefox V3.0.1 as cause)

    Looks like the problem is related to Firefox V3.0.1. If Firefox has never run since the system has rebooted, ZoneAlarm VSMON stays quiet. Once the high I/O starts with VSMON, Firefox is running and you can't even kill the Firefox process even across logoffs and login. ZoneAlarm show Firefox (under Programs) as "Active".

    Once I rebooted and did not start Firefox, I went in to ZoneAlarm Program Control and the Programs tab. I removed all the Firefox related entries. I was surprise to find very old versions (including the V3 betas I tried) and Firefox Helpers. (ZA needs a cleanup function that can go through these Programs and remove the entries that no longer exist.) One version was still installed and some where removed a long time ago. Once I removed them from ZA, they seem to keep coming back even though the path no longer exists (and verified by right-clicking on one of the old entries and select Properties. It promptly said it could not be found). I went through the Registry looking for old Firefox entries (pre-3.0.1). I found some and I deleted them (when it made sense). But still I get ZA Firefox entries reappearing right in front of my eyes such as V1.8 of Firefox at an non-exiting path along with V2 of Firefox Helper at an non-existing path. The Firefox version 3.0.1 shows that it's always "Active" in ZA. Some of the entries did not come back. Weird.

    The question is why do these old Firefox entries come back? Is the database corrupt?

    -Dave

  4. #4
    dslchiphead Guest

    Default Re: ZASS 7.0.x locks computer (Maybe Firefox V3.0.1 as cause)

    Update: I removed the Firefox Prefetch file from C:\Windows\Prefetch and it seem to stop the older versions of Firefox and Firefox Helper from showing up in ZA PC Programs. Consequence? Maybe. But so far so good and VSMON is behaving itself.

    -Dave

  5. #5
    joem Guest

    Default Re: ZASS 7.0.x locks computer (Maybe Firefox V3.0.1 as cause)

    Thanks for the idea, Dave. It seems my problem is different. I followed your suggestions and did not get any noticeable improvement.
    I still had Firefox 2 installed along with Firefox 3.0.1. I uninstalled FF2, renamed the Firefox.exe.......pf file in C:\windows\prefetch, and deleted all ZA program entries that started with Firefox. So far ZA has only added back the one entry for Firefox which is shows as version 1.9.0.1 (a little strange for an external version of 3.0.1, but FF's help about shows 1.9.0.1 and the Windows file info shows version 1.9.0.3105).

  6. #6
    joem Guest

    Default Re: ZASS 7.0.x locks computer - update

    The delays are getting much worse. This morning I started my computer and did some timing. It took 31 minutes for the ZA icon to appear in the system tray. At that point vsmon.exe had read about 72GB. It was a total of 47 minutes before the desktop was up the disk activity light starts showing periods of inactivity. At that point vsmon.exe has read about 94GB.

  7. #7
    dslchiphead Guest

    Default Re: ZASS 7.0.x locks computer (Maybe Firefox V3.0.1 as cause)

    Joe,

    Try moving that renamed Firefox .PF file that you made out of the Prefetch directory (in my case I actually deleted the file). Then delete all the FF program entries in ZA. That worked for me. Version 3.0.1 will be added as soon as you use FF. You should not see any older versions. Since I did that, no old entries of FF show up under ZA and the correct FF V3.0.1 is the only entry. The Read I/O went back to normal too.

    -Dave

  8. #8
    joem Guest

    Default Re: ZASS 7.0.x locks computer (Maybe Firefox V3.0.1 as cause)


    <blockquote><hr>dslchiphead wrote:
    Joe,

    Try moving that renamed Firefox .PF file that you made out of the Prefetch directory (in my case I actually deleted the file). Then delete all the FF program entries in ZA. That worked for me. Version 3.0.1 will be added as soon as you use FF. You should not see any older versions. Since I did that, no old entries of FF show up under ZA and the correct FF V3.0.1 is the only entry. The Read I/O went back to normal too.

    -Dave
    <hr></blockquote>


    I tried all that with no improvement. Note that the single FF entry in ZASS programs shows version 1.9.0.1 which seems to be the Windows Properties version for FF 3.0.1. The locks happen sometimes with FF usage, but also with no FF usage.

    ZA email support suggested cutting all the auto-starts and seeing if that helped. Then adding them back in again to find a source of incompatibility. The start time did get faster with no other auto-starts. It slowed when the auto-starts were added back, but remained much less than it had been. The random lockups of 5 to 10 minutes did not abate.

    I finally gave up and completely uninstalled FF, did the suggested file and reg cleans, and installed ZASS again. So far that has helped. The vsmon reads are way down. I have not seen any noticeable lockups. The single FF entry in ZASS programs still shows version 1.9.0.1. Does yours actually show Version 3.0.1?

    Thanks for your suggestions.

    Joe

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •