Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: vsmon trouble in version 8

  1. #1
    jrmerrill Guest

    Default vsmon trouble in version 8

    Hi folks
    vsmon is driving me nuts.
    Using 50% of CPU (an entire core of my Intel e7200) and have tried about everything I have read on the web and forums already.

    Any help appreciated.

    Version of ISS and truevector is

    Windows XP SP3.
    This is a fresh install on a new computer with high quality components with all updated drivers.
    Downloaded ZAISS from
    the regular CheckPoint site and installed.

    I have already tried, to no avail:
    - a complete reinstall
    - bumped up program protection to Max from 'learning' to eliminate the learning-curve issue
    - making sure the XP firewall and anti-virus are OFF, and NO other similar programs are running- I've tried turning off MailSafe protection
    - I've done complete, deep virus scans etc to make sure ZA isnt 'fighting' anything
    - comparing settings to my other computer, which still has a version 7 of ZAISS, which does not have the problem
    - probably a bunch of other things
    I notice under 'alerts and logs' that there are some items under the Firewall tab that have been blocked in the 'trusted' zone, in my home network.
    The network is clean, run by a Linksys router, with only my other ZA-protected computer.
    I havent tried turning off the firewall in the 'trusted' network zone, but why would I have to do that?

    Are there settings on the firewall screen I can change so that my computer deals with the network differently ?
    I also have not tried going into the OS registry and monkeying around as some have suggested.
    Why would vsmon purposefully consume half my CPU?
    If this was an older CPU I'd be dead in the water.

    I just re-upped my subscription to ZAISS for another year and am beginning to regret it.

    Thanks for your assistance.

    Yes I did send this to tech support at ZA also.

    Operating System:Windows XP Home Edition
    Software Version:8.0
    Product Name:ZoneAlarm Internet Security Suite

  2. #2
    jrmerrill Guest

    Default Re: vsmon trouble in version 8

    So far I've heard once from tech support - encouraged me to do the usual line by line off & on of services and startup items using msconfig to see if there is a conflicting program.

    3 hrs later, no luck at all.
    vsmon still fires itself back up to 50% of my dual core CPU with normal use even with a bare bones background (just system/hardware drivers commonly used by zillons of people).

    Worse, when I turned off the ZA firewall, vsmon still pops back up !

    Of course, after every reboot, vsmon is using 0% CPU, but if the wind blows, if jumps right back up again, even when the ZA firewall is off...

    I suspect this has something to do with the shutdown problem many folks are having with 8.0 also.
    So for now I uninstalled ZA until I can get some relief.
    This is a bare-bones, clean new computer.
    My other computer with gobs of junk on it is running version 7 of ZAISS just fine, same operating system, same hardware and drivers, etc etc etc.
    No interfering 2nd virus blockers, etc.

    And a
    simple home network with two computers, router.
    I've asked tech support to tell me how to load on older version (like 7-something) instead, so I can make use of the subscription I just re-upped.
    Anyone here have a hint on how to download that?
    Can't seem to find anything but the newest version on the CheckPoint website.

  3. #3
    hammernu Guest

    Default Re: vsmon trouble in version 8

    Absolutely. Just follows these links to download any version of any product:

    Support (click on Support, not the dropdown entries)

    Product-Specific Support (click on product)

    Release History (at bottom of page)

  4. #4
    Join Date
    Nov 2004

    Default Re: vsmon trouble in version 8

    did you actually tried to reset ZA?
    If yes, how?

    Have you tried to completely remove any trace of ZA and reinstall?
    If yes, how?

    Usually there three issue related to CPU usage..

    1. Other conflicting software or drivers
    2. Corrupted or incorrect settings
    3. Corrupted installation

    The first is resolved with MSCONFIG
    The second by resetting the ZA settings
    The third by manually removing ZA from you system

    Hope this helps.

    P.S. Install new version of ZA only when you are advised by the automatic update features in ZA and not manually. This is to avoid any surprises due to unexpected problems with new releases.

    Click here for ZA Support
    Monday-Saturday 24x6 Pacific time
    Closed Sundays and Holidays

  5. #5
    jrmerrill Guest

    Default Re: vsmon trouble in version 8

    Fax, I appreciate your reply and I am sure you are getting used to dealing with frustrated people in this forum, forgive me if I still seem that way...
    I did piece thru all my startups and services which took a great deal of time, and I came up empty.
    That said I'm not sure what one can consider the use of msconfig to 'resolve' conflict issues, IF the conflict is with a software item that is even more commonly used than ZA...
    hardware drivers or utilities, MS Office-related stuff, Java, common networking items, etc.
    In these instances if there is a conflict, it is CheckPoint's job to deal with it and fix the conflict on the ZA end, not the other way around.
    Anyways that doesnt appear to be my problem.
    To reset I used the ctrl-shift-Rclick steps, etc.
    No luck, vsmon back with a fury.
    To uninstall the first time I merely used the regular ZA utility.

    While I am capable of working thru the now-apparently-famous 24 or 27 step process involving the registry etc, I consider that to be a tall order for consumers to tackle.
    Any program that embeds itself that thoroughly and cannot uninstall itself with its own utility is not worth the silicon it's printed on.

    nVidia's drivers used to embed that way
    serious users had
    to manually uninstall them
    before upgrading, but they
    listened to their users and fixed it.

    To answer your p.s., this was a fresh install from my new subscription to a brand new system rather than an upgrade from version 7.
    Rest assured I will not be upgrading my other machine to version 8 anytime soon.

    My 'updates' button on that machine will remain on 'manual' until I see significant fixes to version 8.
    I do have a lead now on DL'ing a version 7, thank you folks.

    - I took a deep breath and loaded 70483 and after some brief 'stress' testing all seems well, vsmon isn't scared of its own shadow......
    and the computer shuts down 5x faster, with a nod to all the folks dealing with that problem too.

    Message Edited by jrmerrill on 09-02-2008 11:02 PM

  6. #6
    Join Date
    Nov 2004

    Default Re: vsmon trouble in version 8


    MSCONFIG is to ensure there are no third party services and programs conflicting with ZA other than standard MS services and programs.
    There are millions of software tools for PC. Its not rare to find incompatibilities. Did you really disabled all services and programs as instructed?

    ZASS does not play nice with many other overlapping security tool. Such as, Spyware Doctor, SpySweeper, Adaware, SpybotS&D, PC tools Threatfire, other antivirus, other antispyware, registry tools, etc. If you want to troubleshoot issue with ZA you need to ensure to remove these tools and any of their left overs from the system.

    The reset of the database is to ensure your settings are correct and not corrupted. Obviously you should not restore any previous backup of the settings after the reset.

    You should ensure your hardware drivers are up to date.

    Finally you should try to remove ZA manually as described below:

    First remove ZA from XP add/remove programs then:

    01.) Restart your computer
    02.) When you see the screen go black and it starts booting back up keep
    tapping the "F8" key (at the top of your keyboard)
    03.) This should bring up a menu. Choose Safe Mode off the menu by
    using the arrow keys on the keyboard to highlight Safe Mode and press
    04.) If you get a message asking to go to Safe Mode, choose Yes. If you
    get a help and support window, close this.
    05.) Once you are at the desktop, Click Start, My Computer
    06.) Click Tools, Folder Options, View Tab
    07.) Place a dot next to "Show Hidden Files and Folders"
    08.) Remove the check from "Hide Protected Operating System Files
    09.) Choose Yes to the warning
    10.) Click OK
    11.) Double click C:

    Note: In the future steps if you do not see any files or folders, please click
    the "Show Files" link to view them.

    12.) Double Click the Program Files Folder
    13.) Right Click the Zone Labs Folder, click Delete, and choose Yes

    NOTE: If you cannot delete the entire folder, please open the Zone Labs -
    > ZoneAlarm folder and delete out as many of the files listed here as

    14.) Close this window
    15.) Click Start, My Computer
    16.) Double Click the C:
    17.) Double Click the Windows Folder (It may also be WinNT)
    18.) Right Click the Internet Logs Folder, click Delete, and choose Yes
    19.) Double Click the System32 Folder
    20.) Right Click the Zone Labs Folder, click Delete, and choose Yes

    NOTE: If you cannot delete the entire folder, please open the Zone Labs
    folder and delete out as many of the files listed here as possible.

    21.) Locate and delete the following files in the System32 folder if they are

    - vsconfig.xml
    - vsxml.dll
    - vsregexp.dll
    - vsdata.dll
    - vsdata95.vxd
    - vsdatant.sys
    - vsmonapi.dll
    - vspubapi.dll
    - vsinit.dll
    - vsutil.dll
    - vswmi.dll
    - zlcommdb.dll
    - zlcomm.dll
    - z llictbl.dat
    - zpeng24.dll

    22.) Clear your Temp Directory per the instructions below.

    - Go to Start -> Run
    - Type %temp% and click OK
    - Select all of these files and delete them

    23.) Clear the Prefetch folder per the instructions below.

    - Go to Start -> Run
    - Type Prefetch and click OK
    - Select all of these files and delete them

    24.) Remove the following registry entries by going to Start -> Run and
    typing in regedit. Use the folders on the left side of the window to navigate
    to the specified directories.

    HKEY_LOCAL_MACHINE\Software\Zone Labs
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\vsmon
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\vsdatant

    *Important Advisory: Deleting registry entries incorrectly may cause
    serious problems to your operating system, which may necessitate the
    need to reinstall it. Please make sure you are able to perform these
    deletions correctly before you decide to edit the entries. If you are not
    sure, you should seek help from someone who is familiar with editing the

    For information about how to edit the registry in Windows, from your
    desktop, click Start >> Run >> and type regedit. Click on Help >> Help
    Topics. Under the Contents tab, click Change Keys and Values (this may
    be found under the How to... section).

    Also, you should always make a backup of the registry before editing it.
    You can find this in the same section of the Help files.

    25.) Close this window, then empty your recycle bin.
    26.) Restart the computer.

    If the above indications are followed closely then you should be able to install ZA without problem.
    Download a fresh copy of ZASS installer here:


    Click here for ZA Support
    Monday-Saturday 24x6 Pacific time
    Closed Sundays and Holidays

  7. #7
    jrmerrill Guest

    Default Re: vsmon trouble in version 8

    Well I see release 80020 is going great also, based on the other threads today

    I'm sticking with 70043 for a while.
    Do they test these things in real world environments by chance ?
    If most major, contemporary software products had this many 'corrupt installs' and conflicts they'd be thrown out of the market by consumers.
    Not sure how internet security products are managing to survive despite such failures.

  8. #8
    apd Guest

    Default Re: vsmon trouble in version 8

    That is mainly because we as consumers are expecting flaws as if they are necessary. I (and most of us here) have gone this this very issue (slow system) about a year ago. Have had zone labs for 8 years from when all they had was a firewall. This is my last purchase.

    And yes I work in software product development and I know how complex a million of conflicting software and their incompatibilities can get. But I put this on a brand new system. Just windows XP and sp3 and zone labs. Same issue of slow system.

    I know Fax is going to be uppity about this post and talk about zonelabs not reading this etc.He has been a tireless soldier and I give him full credit for keeping me in the fold and buying zonelab products. This is not a rant nor a frustration outlet. Just stating facts as they are. This release was unacceptable. I feel let down by own faithful family (zonelabs) twice.

  9. #9
    Join Date
    Nov 2004

    Default Re: vsmon trouble in version 8

    actually, in effect, if you exclude XP issues on shutdown that some users are experiencing, version 8 is faster and lighter (less memory use) than version 7. I see it in both XP and VISTA system. I must be lucky...

    If you have CPU issues or general slowdown of the system then the issue must be related to other local conditions.

    There many steps you can perform.
    First by isolating ZA from the rest of non-OS related program and services (selective boot-up)
    Secondly by resetting any ZA custom settings
    Thirdly by remove manually all ZA core files to ensure no corrupted file is impairing ZA to work.

    The above procedures have been posted here many times and have resolved most of the issue with ZA.
    Also consider that users like to install overlapping security tools one on top of the other with the end results to be less protected and to cause hang/malfunctions/crashes of the system.

    If you have other security tool please remove them and install back only when you see that ZA is working as it should.

    Hope this helps.


    Click here for ZA Support
    Monday-Saturday 24x6 Pacific time
    Closed Sundays and Holidays

  10. #10
    guitarspaz Guest

    Default Re: vsmon trouble in version 8

    For what it's worth, I gave up on Version 8. I did clean removals, installs, checked for conflicting programs in msconfig, cleared registry keys and directories, changing settings to minimize scanning, etc. On two entirely different machines, one AMD, one Intel, both running XP, version 8.x made the machines extremely slow, to the point of being not useable. In both cases, VSMON was **bleep**ing up excessive CPU time (50% typically) even when no scans were active. I reinstalled the latest 7.x and life is back to normal now. I'm staying away from version 8 indefinitely, or at least until I see some fixes posted in the rev history. I'm confident that I don't have a system configuration issue, unless it's just an XP or service pack problem in general. Will be interested if someone finds a way around this issue in XP.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts