As Guru Fax said above, the version of ZA for Vista with no Service Pack was originally 7.1.078.000, but had severe compatibility problems with Vista SP1, so version 7.1.248.000 was released, which fixes several problems encountered. To go from Vista with NO service pack to Vista with SP1, you must first install version 7.1.248 and THEN install Vista SP1. Be sure to disable ZA and your AV program during installation of the Service Pack. If you absolutely need to have a firewall on during the installation, some have suggested enabling Windows Firewall temporarily to help protect you if you don't have a router between your computer and the Internet.

Version 7.1.248.000 can be downloaded here: http://download.zonealarm.com/bin/fr...248_000_en.exe

I hope this helps if you're still having problems.